summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-11-26 00:48:46 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2013-11-26 00:49:10 +0100
commit29f11fa1131ae9e71dde92c321564571e23e5781 (patch)
tree12af38a1c5b0d49bbd5e8216a8a096cd347066d4 /dev-python
parentapp-accessibility/at-spi2-core: 2.8.0 → 2.10.2 (diff)
downloadgnome-29f11fa1131ae9e71dde92c321564571e23e5781.tar.gz
gnome-29f11fa1131ae9e71dde92c321564571e23e5781.tar.bz2
gnome-29f11fa1131ae9e71dde92c321564571e23e5781.zip
dev-python/pyatspi: 2.8.0 → 2.10.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyatspi/Manifest11
-rw-r--r--dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch26
-rw-r--r--dev-python/pyatspi/metadata.xml5
-rw-r--r--dev-python/pyatspi/pyatspi-2.10.0.ebuild59
-rw-r--r--dev-python/pyatspi/pyatspi-9999.ebuild46
5 files changed, 119 insertions, 28 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
new file mode 100644
index 00000000..051b821a
--- /dev/null
+++ b/dev-python/pyatspi/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST pyatspi-2.10.0.tar.xz 289612 SHA256 42f89ddb9a236448503573e4cd1ddb174e233e005316de9acdb957eb1aa9ad84 SHA512 21c600707bd2972dc1afc758d4220d254fb3a7dd4c05bedfa78d05136463e4a3ae9d3e31f81d6cfe0f93880ea099298509988759ecfd700b336705971c7227f8 WHIRLPOOL f167d56500d432a65a668a905dadc06275305067abea3fc01b55949448371e327ad0717d6560b951cf5c8532bab00b9e3ba0dd9dae0316df9f3550d360aab6b4
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iEYEAREKAAYFAlKT4d8ACgkQ1fmVwcYIWAYHywCeMXCcqAauPv5tMZJU/xLMFNBo
+a2cAoM5px/dmf7s/5k3iS5tsyduk2B/v
+=/C5Y
+-----END PGP SIGNATURE-----
diff --git a/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch b/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch
new file mode 100644
index 00000000..423cd644
--- /dev/null
+++ b/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch
@@ -0,0 +1,26 @@
+From 4f10a696002179082e41568b5109400ac8478a96 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 10 Dec 2012 04:52:03 -0500
+Subject: [PATCH] examples: support python2 and python3 syntax
+
+https://bugzilla.gnome.org/show_bug.cgi?id=689957
+---
+ examples/magFocusTracker.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/magFocusTracker.py b/examples/magFocusTracker.py
+index 47efe00..7ca3b67 100755
+--- a/examples/magFocusTracker.py
++++ b/examples/magFocusTracker.py
+@@ -282,7 +282,7 @@ def main():
+ startTracking()
+ pyatspi.Registry.start()
+ else:
+- print 'Magnification service not available. Exiting.'
++ print('Magnification service not available. Exiting.')
+
+ return 0
+
+--
+1.8.0
+
diff --git a/dev-python/pyatspi/metadata.xml b/dev-python/pyatspi/metadata.xml
new file mode 100644
index 00000000..d9f21e6a
--- /dev/null
+++ b/dev-python/pyatspi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-accessibility</herd>
+</pkgmetadata>
diff --git a/dev-python/pyatspi/pyatspi-2.10.0.ebuild b/dev-python/pyatspi/pyatspi-2.10.0.ebuild
new file mode 100644
index 00000000..c2ccc441
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.10.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit eutils gnome2 python-r1
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="" # test
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# test suite is obsolete (at-spi-1.x era) and unpassable
+RESTRICT="test"
+
+COMMON_DEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-${PV}[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=689957
+ epatch "${FILESDIR}/${PN}-2.6.0-examples-python3.patch"
+
+ gnome2_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ docinto examples
+ dodoc examples/*.py
+}
diff --git a/dev-python/pyatspi/pyatspi-9999.ebuild b/dev-python/pyatspi/pyatspi-9999.ebuild
index c1ed0476..80dceb82 100644
--- a/dev-python/pyatspi/pyatspi-9999.ebuild
+++ b/dev-python/pyatspi/pyatspi-9999.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="no"
-PYTHON_DEPEND="2:2.5 3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 *-jython *-pypy-*"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-inherit gnome2 python
+inherit eutils gnome2 python-r1
if [[ ${PV} = 9999 ]]; then
GNOME_LIVE_MODULE="pyatspi2"
inherit gnome2-live
@@ -23,15 +21,18 @@ SLOT="0"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~amd64 ~arm ~hppa ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
IUSE="" # test
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# test suite is obsolete (at-spi-1.x era) and unpassable
RESTRICT="test"
-COMMON_DEPEND="dev-python/dbus-python
- >=dev-python/pygobject-2.90.1:3
+COMMON_DEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
"
RDEPEND="${COMMON_DEPEND}
>=sys-apps/dbus-1
@@ -41,37 +42,26 @@ RDEPEND="${COMMON_DEPEND}
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
-pkg_setup() {
- G2CONF="${G2CONF} --disable-tests"
- python_pkg_setup
-}
-
src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=689957
+ epatch "${FILESDIR}/${PN}-2.6.0-examples-python3.patch"
+
gnome2_src_prepare
- python_clean_py-compile_files
python_copy_sources
}
src_configure() {
- python_execute_function -s gnome2_src_configure
+ python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
}
src_compile() {
- python_execute_function -s gnome2_src_compile
+ python_foreach_impl run_in_build_dir gnome2_src_compile
}
src_install() {
- python_execute_function -s gnome2_src_install
- python_clean_installation_image
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- python_mod_optimize pyatspi
-}
+ python_foreach_impl run_in_build_dir gnome2_src_install
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup pyatspi
+ docinto examples
+ dodoc examples/*.py
}