summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-06 18:14:40 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-20 18:50:26 +0200
commit5c129f82cb8b0b8b7fd2c5b6d9fec71d15be2a17 (patch)
tree7a217b526d122bfcd936300a421c9068c3972812 /gnome-extra/gnome-boxes
parentsys-libs/libosinfo: 0.2.7 → 0.2.10 (diff)
downloadgnome-5c129f82cb8b0b8b7fd2c5b6d9fec71d15be2a17.tar.gz
gnome-5c129f82cb8b0b8b7fd2c5b6d9fec71d15be2a17.tar.bz2
gnome-5c129f82cb8b0b8b7fd2c5b6d9fec71d15be2a17.zip
gnome-extra/gnome-boxes: 3.10.2 → 3.12.0
Diffstat (limited to 'gnome-extra/gnome-boxes')
-rw-r--r--gnome-extra/gnome-boxes/Manifest11
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-3.12.0.ebuild92
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-9999.ebuild11
3 files changed, 107 insertions, 7 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
new file mode 100644
index 00000000..b5f76210
--- /dev/null
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-boxes-3.12.0.tar.xz 1899192 SHA256 fbeac187fefd5fc825beda058e1f25731949bd2e32a1754acfc5fe3dc1edc9ae SHA512 4c231e49d56b9d7bdb8ff91ac6526c3336e816baf0ab922ae9c83a9d3ad0ecde1720d82541cb3ee3285497c7e892f49c016d24aacff4d8574e96af0437f3ed40 WHIRLPOOL d38a25aff117f7319ac7e9ac590a86ea45f8e3fc9524ae0f5ab5314fa0a845c31ca3c9b77a1c759836c1cfc0a1cbc1c300d9dc1752529de3f7e557fd8eab6197
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNBfXEACgkQ1fmVwcYIWAa19QCfT9CZtUnrhXS0wU55Y40EoFxJ
+gToAoLnYb+/UMVVD1Qm75cUnbB3PqD8c
+=98Y8
+-----END PGP SIGNATURE-----
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-3.12.0.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-3.12.0.ebuild
new file mode 100644
index 00000000..b21a4999
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-3.12.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.24"
+
+inherit linux-info gnome2 vala
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Boxes"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+# We force 'bindist' due licenses from gnome-boxes-nonfree
+IUSE="smartcard usbredir" #bindist
+KEYWORDS="~amd64" # qemu-kvm[spice] is 64bit-only
+
+# NOTE: sys-fs/* stuff is called via exec()
+# FIXME: ovirt is not available in tree
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=dev-libs/libxml2-2.7.8:2
+ >=sys-libs/libosinfo-0.2.9
+ >=app-emulation/qemu-1.3.1[spice,smartcard?,usbredir?]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/libvirt-glib-0.1.7
+ >=x11-libs/gtk+-3.11:3
+ >=net-libs/gtk-vnc-0.4.4[gtk3]
+ >=net-misc/spice-gtk-0.16[gtk3,smartcard?,usbredir?]
+
+ >=app-misc/tracker-0.16:0=[iso]
+
+ >=sys-apps/util-linux-2.20
+ >=net-libs/libsoup-2.38:2.4
+
+ sys-fs/fuse
+ sys-fs/fuseiso
+ sys-fs/mtools
+ >=virtual/udev-165[gudev]
+"
+# !bindist? ( gnome-extra/gnome-boxes-nonfree )
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+pkg_pretend() {
+ linux_config_exists
+
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes!"
+ fi
+}
+
+src_prepare() {
+ # Do not change CFLAGS, wondering about VALA ones but appears to be
+ # needed as noted in configure comments below
+ sed 's/CFLAGS="$CFLAGS -O0 -ggdb3"//' -i configure{.ac,} || die
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # debug needed for splitdebug proper behavior (cardoe)
+ gnome2_src_configure \
+ --enable-debug \
+ --disable-strict-cc \
+ $(use_enable usbredir) \
+ $(use_enable smartcard) \
+ --enable-ovirt=no
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "Before running gnome-boxes, you will need to load the KVM modules"
+ elog "If you have an Intel Processor, run:"
+ elog " modprobe kvm-intel"
+ einfo
+ elog "If you have an AMD Processor, run:"
+ elog " modprobe kvm-amd"
+}
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-9999.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-9999.ebuild
index 874b79b6..3108a46a 100644
--- a/gnome-extra/gnome-boxes/gnome-boxes-9999.ebuild
+++ b/gnome-extra/gnome-boxes/gnome-boxes-9999.ebuild
@@ -5,7 +5,7 @@
EAPI="5"
GCONF_DEBUG="no"
VALA_USE_DEPEND="vapigen"
-VALA_MIN_API_VERSION="0.22"
+VALA_MIN_API_VERSION="0.24"
inherit linux-info gnome2 vala
if [[ ${PV} = 9999 ]]; then
@@ -27,21 +27,19 @@ fi
# NOTE: sys-fs/* stuff is called via exec()
# FIXME: ovirt is not available in tree
RDEPEND="
- >=dev-libs/glib-2.32:2
+ >=dev-libs/glib-2.38:2
>=dev-libs/gobject-introspection-0.9.6
>=dev-libs/libxml2-2.7.8:2
- >=sys-libs/libosinfo-0.2.7
+ >=sys-libs/libosinfo-0.2.9
>=app-emulation/qemu-1.3.1[spice,smartcard?,usbredir?]
>=app-emulation/libvirt-0.9.3[libvirtd,qemu]
>=app-emulation/libvirt-glib-0.1.7
- >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtk+-3.11:3
>=net-libs/gtk-vnc-0.4.4[gtk3]
>=net-misc/spice-gtk-0.16[gtk3,smartcard?,usbredir?]
>=app-misc/tracker-0.16:0=[iso]
- >=media-libs/clutter-gtk-1.3.2:1.0
- >=media-libs/clutter-1.11.14:1.0
>=sys-apps/util-linux-2.20
>=net-libs/libsoup-2.38:2.4
@@ -88,7 +86,6 @@ src_prepare() {
}
src_configure() {
- DOCS="AUTHORS README NEWS THANKS TODO"
# debug needed for splitdebug proper behavior (cardoe)
gnome2_src_configure \
--enable-debug \