summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-05-27 23:39:01 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2018-05-27 23:49:09 +0200
commit846cc7dac77e6df6eecd946f28c1d67abea17c43 (patch)
treec8f032ded267641e6959ac07856ea50e0b38e455 /gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
parentgnome-extra/gnome-contacts: drop unused intltool (diff)
downloadgnome-846cc7dac77e6df6eecd946f28c1d67abea17c43.tar.gz
gnome-846cc7dac77e6df6eecd946f28c1d67abea17c43.tar.bz2
gnome-846cc7dac77e6df6eecd946f28c1d67abea17c43.zip
gnome-extra/gnome-contacts: synchronize live ebuild
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Manifest-Sign-Key: 0x5A56C8CD0C13248A
Diffstat (limited to 'gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild')
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
index 0c3a7c0a..e68bf5bb 100644
--- a/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
+++ b/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
@@ -1,54 +1,50 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
-GCONF_DEBUG="no"
+EAPI=6
VALA_USE_DEPEND="vapigen"
VALA_MIN_API_VERSION="0.24"
-inherit gnome2 vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
+inherit git-r3 gnome-meson vala
DESCRIPTION="GNOME contact management application"
HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
+SRC_URI=""
+EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gnome-contacts.git"
LICENSE="GPL-2+"
SLOT="0"
IUSE="v4l"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
- EGIT_HAS_SUBMODULES=true
else
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
+
VALA_DEPEND="
$(vala_depend)
- >=dev-libs/gobject-introspection-0.9.6
+ >=dev-libs/gobject-introspection-0.9.6:=
dev-libs/folks[vala(+)]
- gnome-base/gnome-desktop[introspection]
+ gnome-base/gnome-desktop:3=[introspection]
gnome-extra/evolution-data-server[vala]
net-libs/telepathy-glib[vala]
- x11-libs/libnotify[introspection]
"
# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
RDEPEND="
- >=dev-libs/folks-0.9.5:=[eds,telepathy]
- >=dev-libs/glib-2.37.6:2
+ >=dev-libs/folks-0.11.4:=[eds,telepathy]
+ >=dev-libs/glib-2.44:2
>=dev-libs/libgee-0.10:0.8
>=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
>=gnome-base/gnome-desktop-3.0:3=
+ media-libs/clutter:1.0
media-libs/clutter-gtk:1.0
media-libs/libchamplain:0.12
- net-libs/gnome-online-accounts
- >=net-libs/telepathy-glib-0.17.5
+ net-libs/gnome-online-accounts:=[vala]
+ >=net-libs/telepathy-glib-0.22
>=sci-geosciences/geocode-glib-3.15.3
x11-libs/cairo:=
x11-libs/gdk-pixbuf:2
- x11-libs/libnotify:=
- >=x11-libs/gtk+-3.12:3
+ >=x11-libs/gtk+-3.22:3
x11-libs/pango
v4l? ( >=media-video/cheese-3.5.91:= )
"
@@ -57,11 +53,14 @@ DEPEND="${RDEPEND}
app-text/docbook-xml-dtd:4.2
app-text/docbook-xsl-stylesheets
dev-libs/libxslt
- >=dev-util/intltool-0.40
>=sys-devel/gettext-0.17
virtual/pkgconfig
"
+src_unpack() {
+ git-r3_src_unpack
+}
+
src_prepare() {
# Regenerate the pre-generated C sources, bug #471628
if ! use v4l; then
@@ -69,9 +68,11 @@ src_prepare() {
fi
vala_src_prepare
- gnome2_src_prepare
+ gnome-meson_src_prepare
}
src_configure() {
- gnome2_src_configure $(use_with v4l cheese)
+ gnome-meson_src_configure \
+ -Dwith-manpage=true \
+ $(meson_use v4l with-cheese)
}