summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-12-08 22:31:27 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2014-12-08 22:49:09 +0100
commitbbc276313ab4716dda3e8aba285ecc8c8cc093bd (patch)
tree03af6dc3e022c9aa6590e7b6633ae854fc685f3c /media-libs
parentmedia-libs/clutter: add multiple backend support (diff)
downloadgnome-bbc276313ab4716dda3e8aba285ecc8c8cc093bd.tar.gz
gnome-bbc276313ab4716dda3e8aba285ecc8c8cc093bd.tar.bz2
gnome-bbc276313ab4716dda3e8aba285ecc8c8cc093bd.zip
media-libs/cogl: add support for kms backend
Can be used by mutter[kms]
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cogl/cogl-1.18.2.ebuild9
-rw-r--r--media-libs/cogl/cogl-9999.ebuild9
2 files changed, 12 insertions, 6 deletions
diff --git a/media-libs/cogl/cogl-1.18.2.ebuild b/media-libs/cogl/cogl-1.18.2.ebuild
index 83e1cfc0..a30478de 100644
--- a/media-libs/cogl/cogl-1.18.2.ebuild
+++ b/media-libs/cogl/cogl-1.18.2.ebuild
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.cogl3d.org/"
LICENSE="MIT BSD"
SLOT="1.0/20" # subslot = .so version
# doc and profile disable for now due bugs #484750 and #483332
-IUSE="examples gles2 gstreamer +introspection +opengl +pango test wayland" # doc profile
+IUSE="examples gles2 gstreamer +introspection +kms +opengl +pango test wayland" # doc profile
REQUIRED_USE="wayland? ( gles2 )"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
@@ -22,7 +22,6 @@ COMMON_DEPEND="
>=dev-libs/glib-2.32:2
x11-libs/cairo:=
>=x11-libs/gdk-pixbuf-2:2
- x11-libs/libdrm:=
x11-libs/libX11
>=x11-libs/libXcomposite-0.4
x11-libs/libXdamage
@@ -36,6 +35,9 @@ COMMON_DEPEND="
media-libs/gst-plugins-base:1.0 )
introspection? ( >=dev-libs/gobject-introspection-1.34.2 )
+ kms? (
+ media-libs/mesa[gbm]
+ x11-libs/libdrm:= )
pango? ( >=x11-libs/pango-1.20.0[introspection?] )
wayland? (
>=dev-libs/wayland-1.1.90
@@ -75,7 +77,7 @@ src_prepare() {
}
src_configure() {
- # TODO: think about kms-egl, quartz, sdl
+ # TODO: think about quartz, sdl
# Prefer gl over gles2 if both are selected
# Profiling needs uprof, which is not available in portage yet, bug #484750
# FIXME: Doesn't provide prebuilt docs, but they can neither be rebuilt, bug #483332
@@ -94,6 +96,7 @@ src_configure() {
$(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
$(use_enable gstreamer cogl-gst) \
$(use_enable introspection) \
+ $(use_enable kms kms-egl-platform) \
$(use_enable pango cogl-pango) \
$(use_enable test unit-tests) \
$(use_enable wayland wayland-egl-platform) \
diff --git a/media-libs/cogl/cogl-9999.ebuild b/media-libs/cogl/cogl-9999.ebuild
index 2ab4111e..b1635493 100644
--- a/media-libs/cogl/cogl-9999.ebuild
+++ b/media-libs/cogl/cogl-9999.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="http://www.cogl3d.org/"
LICENSE="MIT BSD"
SLOT="2.0/0" # subslot = .so version
# doc and profile disable for now due bugs #484750 and #483332
-IUSE="examples gles2 gstreamer +introspection +opengl +pango test wayland" # doc profile
+IUSE="examples gles2 gstreamer +introspection +kms +opengl +pango test wayland" # doc profile
REQUIRED_USE="wayland? ( gles2 )"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
@@ -30,7 +30,6 @@ COMMON_DEPEND="
>=dev-libs/glib-2.32:2
x11-libs/cairo:=
>=x11-libs/gdk-pixbuf-2:2
- x11-libs/libdrm:=
x11-libs/libX11
>=x11-libs/libXcomposite-0.4
x11-libs/libXdamage
@@ -44,6 +43,9 @@ COMMON_DEPEND="
media-libs/gst-plugins-base:1.0 )
introspection? ( >=dev-libs/gobject-introspection-1.34.2 )
+ kms? (
+ media-libs/mesa[gbm]
+ x11-libs/libdrm:= )
pango? ( >=x11-libs/pango-1.20.0[introspection?] )
wayland? (
>=dev-libs/wayland-1.1.90
@@ -90,7 +92,7 @@ src_prepare() {
}
src_configure() {
- # TODO: think about kms-egl, quartz, sdl
+ # TODO: think about quartz, sdl
# Prefer gl over gles2 if both are selected
# Profiling needs uprof, which is not available in portage yet, bug #484750
# FIXME: Doesn't provide prebuilt docs, but they can neither be rebuilt, bug #483332
@@ -109,6 +111,7 @@ src_configure() {
$(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
$(use_enable gstreamer cogl-gst) \
$(use_enable introspection) \
+ $(use_enable kms kms-egl-platform) \
$(use_enable pango cogl-pango) \
$(use_enable test unit-tests) \
$(use_enable wayland wayland-egl-platform) \