aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-12 22:33:17 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-21 15:20:05 +0200
commit6acf741827de724604b5bdca6faa531412c8a317 (patch)
treed437c92c00fd316b6cb0e65a227cca023f95ec34 /www-client
parentnet-libs/webkit-gtk: 2.2.6 → 2.4.1 (diff)
downloadgnome-6acf741827de724604b5bdca6faa531412c8a317.tar.gz
gnome-6acf741827de724604b5bdca6faa531412c8a317.tar.bz2
gnome-6acf741827de724604b5bdca6faa531412c8a317.zip
www-client/epiphany: 3.10.3 → 3.12.0
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest11
-rw-r--r--www-client/epiphany/epiphany-3.12.0.ebuild88
-rw-r--r--www-client/epiphany/epiphany-9999.ebuild12
3 files changed, 107 insertions, 4 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
new file mode 100644
index 00000000..7f721b40
--- /dev/null
+++ b/www-client/epiphany/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST epiphany-3.12.0.tar.xz 3023172 SHA256 c1872e38854b01320d5b8fc17179ebd0ae5ee247c92d3d3cdb7f2b9f54c90d25 SHA512 b28bf7ed9090025d18a9b797c5ac268564038166675dbd998c3534074724a1796be4b55f7b7c56f6308807410929963d5c3c2d9524b586e949482f6c7850d5bf WHIRLPOOL 7b95a3dbee784d62590304fc2e3bca673d33cada5ad3d9cd8cc65d883c329594589894e1d37a661b58c4662bfdc84a217b6243b53bc8e4e9b288f4aa39fd99dc
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNJow4ACgkQ1fmVwcYIWAacEQCePnfAGUUPSToV2RB/uR8d8aiF
+BNUAoJh0H1Sb6DHmo/U5296wXY6l+W4s
+=jsbH
+-----END PGP SIGNATURE-----
diff --git a/www-client/epiphany/epiphany-3.12.0.ebuild b/www-client/epiphany/epiphany-3.12.0.ebuild
new file mode 100644
index 00000000..a98962b9
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.12.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 pax-utils versionator virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://projects.gnome.org/epiphany/"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+jit +nss test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.4:3[jit?]
+ >=net-libs/libsoup-2.42.1:2.4
+ >=x11-libs/gtk+-3.11.6:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# Tests refuse to run with the gsettings trick for some reason
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ gnome2_src_install
+ use jit && pax-mark m "${ED}usr/bin/epiphany"
+}
diff --git a/www-client/epiphany/epiphany-9999.ebuild b/www-client/epiphany/epiphany-9999.ebuild
index 6924f26a..2f8c5470 100644
--- a/www-client/epiphany/epiphany-9999.ebuild
+++ b/www-client/epiphany/epiphany-9999.ebuild
@@ -24,16 +24,16 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
-RDEPEND="
+COMMON_DEPEND="
>=app-crypt/gcr-3.5.5
>=app-crypt/libsecret-0.14
>=app-text/iso-codes-0.35
- >=dev-libs/glib-2.38.0:2
+ >=dev-libs/glib-2.38:2
>=dev-libs/libxml2-2.6.12:2
>=dev-libs/libxslt-1.1.7
>=gnome-base/gsettings-desktop-schemas-0.0.1
>=net-dns/avahi-0.6.22[dbus]
- >=net-libs/webkit-gtk-2.3.90:3[jit?]
+ >=net-libs/webkit-gtk-2.4:3[jit?]
>=net-libs/libsoup-2.42.1:2.4
>=x11-libs/gtk+-3.11.6:3
>=x11-libs/libnotify-0.5.1:=
@@ -48,9 +48,13 @@ RDEPEND="
nss? ( dev-libs/nss )
"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ !www-client/epiphany-extensions
+"
# paxctl needed for bug #407085
# eautoreconf requires gnome-common-3.5.5
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.50
sys-apps/paxctl
sys-devel/gettext