summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-10 17:25:06 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-10 17:57:15 +0200
commit8b8539fb4af81892dda144e6a11a7782da569664 (patch)
tree67133b2d2c3c377eb3f4b49eb5108947717b0644 /www-client
parentdev-libs/gobject-introspection-common: 1.42.0 → 1.44.0 (diff)
downloadgnome-8b8539fb4af81892dda144e6a11a7782da569664.tar.gz
gnome-8b8539fb4af81892dda144e6a11a7782da569664.tar.bz2
gnome-8b8539fb4af81892dda144e6a11a7782da569664.zip
www-client/epiphany: 3.14.2 → 3.16.0
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest11
-rw-r--r--www-client/epiphany/epiphany-3.16.0.ebuild98
-rw-r--r--www-client/epiphany/epiphany-9999.ebuild10
-rw-r--r--www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch (renamed from www-client/epiphany/files/epiphany-3.14.0-unittest-1.patch)20
4 files changed, 125 insertions, 14 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
new file mode 100644
index 00000000..191a3bfc
--- /dev/null
+++ b/www-client/epiphany/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST epiphany-3.16.0.tar.xz 3101220 SHA256 e8471b492649ee2a5dbbb76ac9225f0131f95895c3962bc2842799e872d82cae SHA512 acf9030de86fa1248297b74bcddafe55de26f2e0ee07e7f9f7bc0af8e176e195921e605dc180b3f7a32217054f9bd7eaf68eaa368b8d0ded0d15e59740c7b4e5 WHIRLPOOL 1dfb575841d3308bd3b1a3e98e456454e6eff9dfbbd1b84ab89b52bb4fa1d6f1fb06aa5a3a62fd2eea543bd42cb121fc1157796e387c49696773fc57042f22d6
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlVPeFMACgkQ1fmVwcYIWAYenACgsropAkFyQANT9cpA8I3rbqji
+DBcAoKQpXsIFCtrADxyCtJQP5viOjH0z
+=YnEP
+-----END PGP SIGNATURE-----
diff --git a/www-client/epiphany/epiphany-3.16.0.ebuild b/www-client/epiphany/epiphany-3.16.0.ebuild
new file mode 100644
index 00000000..586636f0
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.16.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 pax-utils versionator virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+jit +nss test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.7.4:4[jit?]
+ >=net-libs/libsoup-2.48:2.4
+ >=x11-libs/gtk+-3.13:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-common-3.6
+ >=dev-util/intltool-0.50
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix missing symbol in webextension.so, bug #728972
+ epatch "${FILESDIR}"/${PN}-3.14.0-missing-symbol.patch
+
+ # Fix unittests
+ epatch "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
+ epatch "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ gnome2_src_install
+ use jit && pax-mark m "${ED}usr/bin/epiphany"
+}
diff --git a/www-client/epiphany/epiphany-9999.ebuild b/www-client/epiphany/epiphany-9999.ebuild
index ccd3c47f..16aa1d61 100644
--- a/www-client/epiphany/epiphany-9999.ebuild
+++ b/www-client/epiphany/epiphany-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -12,7 +12,7 @@ if [[ ${PV} = 9999 ]]; then
fi
DESCRIPTION="GNOME webbrowser based on Webkit"
-HOMEPAGE="http://projects.gnome.org/epiphany/"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
# TODO: coverage
LICENSE="GPL-2"
@@ -33,7 +33,7 @@ COMMON_DEPEND="
>=dev-libs/libxslt-1.1.7
>=gnome-base/gsettings-desktop-schemas-0.0.1
>=net-dns/avahi-0.6.22[dbus]
- >=net-libs/webkit-gtk-2.5.90:4[jit?]
+ >=net-libs/webkit-gtk-2.7.4:4[jit?]
>=net-libs/libsoup-2.48:2.4
>=x11-libs/gtk+-3.13:3
>=x11-libs/libnotify-0.5.1:=
@@ -61,7 +61,9 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
"
if [[ ${PV} == 9999 ]]; then
- DEPEND="${DEPEND} app-text/yelp-tools"
+ DEPEND="${DEPEND}
+ app-text/yelp-tools
+ >=gnome-base/gnome-common-3.6"
fi
src_configure() {
diff --git a/www-client/epiphany/files/epiphany-3.14.0-unittest-1.patch b/www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch
index 3b948a5a..baa8a421 100644
--- a/www-client/epiphany/files/epiphany-3.14.0-unittest-1.patch
+++ b/www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch
@@ -1,6 +1,6 @@
-From ddf0dea8e4eb5fe263ddc85d661ce58e55dd554f Mon Sep 17 00:00:00 2001
+From 7ed4a68e2106480f0984703f70b7c25734803161 Mon Sep 17 00:00:00 2001
From: Gilles Dartiguelongue <eva@gentoo.org>
-Date: Sun, 19 Oct 2014 23:03:02 +0200
+Date: Sun, 10 May 2015 17:35:57 +0200
Subject: [PATCH 2/3] Gentoo tests run in ${PORTAGE_TMPDIR} which is not
guaranteed to be /tmp
@@ -9,22 +9,22 @@ Subject: [PATCH 2/3] Gentoo tests run in ${PORTAGE_TMPDIR} which is not
1 file changed, 5 deletions(-)
diff --git a/tests/ephy-file-helpers-test.c b/tests/ephy-file-helpers-test.c
-index c33c1da..bdf7455 100644
+index 43d0009..0fcb585 100644
--- a/tests/ephy-file-helpers-test.c
+++ b/tests/ephy-file-helpers-test.c
-@@ -92,12 +92,7 @@ test_ephy_file_helpers_init (void)
- GFile *file;
+@@ -89,12 +89,7 @@ test_ephy_file_helpers_init (void)
- file = g_file_new_for_path (tmp_dir);
+ /* Cleanup dir left behind. */
+ if (keep_dir) {
- /* As a safety measure, only try recursive delete on paths
- * prefixed with /tmp. */
- if (g_str_has_prefix (tmp_dir, "/tmp"))
- g_assert (ephy_file_delete_dir_recursively (file, NULL));
+ g_assert (ephy_file_delete_dir_recursively (tmp_dir, NULL));
- else
- g_warning ("INIT: dangerous path returned as tmp_dir: %s", tmp_dir);
-
- g_object_unref (file);
}
+
+ g_free (tmp_dir);
--
-2.1.2
+2.3.6