aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-26 17:01:37 -0500
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-26 17:23:58 -0500
commit97dc4791c6de898efcce3cf856db2c90a96b9db0 (patch)
tree1211530af7caf8b80fe6fe4f0203a4cf492ce4e0 /www-client
parentapp-editors/gedit: 3.3.2 → 3.3.4 (diff)
downloadgnome-97dc4791c6de898efcce3cf856db2c90a96b9db0.tar.gz
gnome-97dc4791c6de898efcce3cf856db2c90a96b9db0.tar.bz2
gnome-97dc4791c6de898efcce3cf856db2c90a96b9db0.zip
www-client/epiphany: 3.3.5 → 3.3.90
Bump and clean up ebuild. Test suite requires gsettings schemas from epiphany-3.3.5.
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest6
-rw-r--r--www-client/epiphany/epiphany-3.3.90.ebuild (renamed from www-client/epiphany/epiphany-3.3.5.ebuild)21
-rw-r--r--www-client/epiphany/epiphany-9999.ebuild28
3 files changed, 38 insertions, 17 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 0c28022b..5ceeb173 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,3 +1,3 @@
-DIST epiphany-3.3.5.tar.xz 5087876 RMD160 675821e906639664504e818c486f03dea5b08dec SHA1 f5ff103ea7d54c9dc38fa365855ae8e9b8a46ef7 SHA256 961cd2f326cca92723720e89c0ba2917f71319e17a984d32a29dc55c20eb9579
-EBUILD epiphany-3.3.5.ebuild 1655 RMD160 39841aea4fc9ef6380aa93f4517e753a4d8c9454 SHA1 23345fda159b6fcc0ec6be0eabb68110d09ed980 SHA256 03d3a94136d9a9b0600e77e94e2a4b03ef7ac0f1abbd4b3db7879cba92c456b1
-EBUILD epiphany-9999.ebuild 1743 RMD160 5b6dcc65492bfd6e6346151756ab88ae5ad4ded3 SHA1 68596a659bdd33e6a86cbd04f45c72db0fd69bee SHA256 4fbe4e3789ce640d42c68f8ee90f771fcc05acef0e6c34733af1e56fd7552b67
+DIST epiphany-3.3.90.tar.xz 5087716 RMD160 0007bd0f628090de36f0fb664464c9fc294ec9c4 SHA1 147547964e745aa8c2e2a6eb47d323d0044ea28c SHA256 9c8c311d228f9dd46df6008979d63ab2a8d31a4d43a846213c24c143307100ba
+EBUILD epiphany-3.3.90.ebuild 1992 RMD160 0f85e35af5be9415f17980bb4b36ca15063513f4 SHA1 97d7dceae0376ce0130081d3640a7cd954c6fe65 SHA256 51bfb15f24ea66ab317d36b0b044d16e4ad8deebce033675c3c6deca782db216
+EBUILD epiphany-9999.ebuild 2094 RMD160 46045678a30cf93c8857d8bb34b702d5e2ad81fe SHA1 109ca0db37f3810a5699817a8b31e0f8e2a88789 SHA256 9a9f9762125c7fcea936c0d03d2702569c6f15158e53fb094947fda12df4cd14
diff --git a/www-client/epiphany/epiphany-3.3.5.ebuild b/www-client/epiphany/epiphany-3.3.90.ebuild
index 37028b74..7196555c 100644
--- a/www-client/epiphany/epiphany-3.3.5.ebuild
+++ b/www-client/epiphany/epiphany-3.3.90.ebuild
@@ -5,7 +5,7 @@
EAPI="4"
GCONF_DEBUG="yes"
-inherit eutils gnome2
+inherit eutils gnome2 versionator virtualx
DESCRIPTION="GNOME webbrowser based on Webkit"
HOMEPAGE="http://projects.gnome.org/epiphany/"
@@ -16,7 +16,7 @@ IUSE="avahi doc +introspection +nss test"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
# XXX: Should we add seed support? Seed seems to be unmaintained now.
-COMMON_DEPEND=">=dev-libs/glib-2.31.2:2
+RDEPEND=">=dev-libs/glib-2.31.2:2
>=x11-libs/gtk+-3.3.14:3[introspection?]
>=dev-libs/libxml2-2.6.12:2
>=dev-libs/libxslt-1.1.7
@@ -31,14 +31,13 @@ COMMON_DEPEND=">=dev-libs/glib-2.31.2:2
x11-libs/libSM
x11-libs/libX11
- app-misc/ca-certificates
x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
avahi? ( >=net-dns/avahi-0.6.22 )
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
nss? ( dev-libs/nss )"
-DEPEND="${COMMON_DEPEND}"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
app-text/gnome-doc-utils
>=dev-util/intltool-0.40
dev-util/pkgconfig
@@ -58,3 +57,15 @@ pkg_setup() {
$(use_enable nss)
$(use_enable test tests)"
}
+
+src_test() {
+ # Tests require gsettings schemas from >=epiphany-3.3.5 to be installed
+ local v=$(best_version www-client/epiphany)
+ v=${v/www-client\/epiphany-/}
+ if version_is_at_least 3.3.5 "${v}"; then
+ Xemake check
+ else
+ ewarn "Skipping tests. To run tests, >=${PN}-3.3.5 needs to be already"
+ ewarn "installed on the system."
+ fi
+}
diff --git a/www-client/epiphany/epiphany-9999.ebuild b/www-client/epiphany/epiphany-9999.ebuild
index 6216de9a..1377caf0 100644
--- a/www-client/epiphany/epiphany-9999.ebuild
+++ b/www-client/epiphany/epiphany-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.30.2.ebuild,v 1.1 2010/06/13 21:09:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-3.2.1.ebuild,v 1.1 2011/11/06 04:57:01 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
-inherit eutils gnome2
+inherit eutils gnome2 versionator virtualx
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -15,15 +15,15 @@ HOMEPAGE="http://projects.gnome.org/epiphany/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="avahi doc +introspection nss test"
+IUSE="avahi doc +introspection +nss test"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
# XXX: Should we add seed support? Seed seems to be unmaintained now.
-COMMON_DEPEND=">=dev-libs/glib-2.31.2:2
+RDEPEND=">=dev-libs/glib-2.31.2:2
>=x11-libs/gtk+-3.3.14:3[introspection?]
>=dev-libs/libxml2-2.6.12:2
>=dev-libs/libxslt-1.1.7
@@ -38,21 +38,19 @@ COMMON_DEPEND=">=dev-libs/glib-2.31.2:2
x11-libs/libSM
x11-libs/libX11
- app-misc/ca-certificates
x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
avahi? ( >=net-dns/avahi-0.6.22 )
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
nss? ( dev-libs/nss )"
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
app-text/gnome-doc-utils
>=dev-util/intltool-0.40
dev-util/pkgconfig
sys-devel/gettext
doc? ( >=dev-util/gtk-doc-1 )"
-
pkg_setup() {
DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
G2CONF="${G2CONF}
@@ -66,3 +64,15 @@ pkg_setup() {
$(use_enable nss)
$(use_enable test tests)"
}
+
+src_test() {
+ # Tests require gsettings schemas from >=epiphany-3.3.5 to be installed
+ local v=$(best_version www-client/epiphany)
+ v=${v/www-client\/epiphany-/}
+ if version_is_at_least 3.3.5 "${v}"; then
+ Xemake check
+ else
+ ewarn "Skipping tests. To run tests, >=${PN}-3.3.5 needs to be already"
+ ewarn "installed on the system."
+ fi
+}