summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/itstool/Manifest19
-rw-r--r--dev-util/itstool/files/itstool-segfault.patch58
-rw-r--r--dev-util/itstool/itstool-2.0.4-r1.ebuild37
-rw-r--r--dev-util/itstool/itstool-2.0.5.ebuild40
-rw-r--r--dev-util/itstool/itstool-9999.ebuild53
-rw-r--r--dev-util/itstool/metadata.xml13
6 files changed, 0 insertions, 220 deletions
diff --git a/dev-util/itstool/Manifest b/dev-util/itstool/Manifest
deleted file mode 100644
index 887edb25..00000000
--- a/dev-util/itstool/Manifest
+++ /dev/null
@@ -1,19 +0,0 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA256
-
-DIST 2.0.4.tar.gz 79430 BLAKE2B 373222ed4e24d8707e2a16da1dca965c233f1a703f3e48489669f8291c71794253d06833a44cebbebde4ca5d97b6465331b024ac4483377c1929b5630b10fa60 SHA512 c4c12229419e376c378986c5e5e5de9d006e5a938d7935ae91ba1f5a70484ff519038ba6bba91329a54d96c7e53ea12fcf1122d63e891fd5c64813cebf5ad8fa
-DIST 2.0.5.tar.gz 79772 BLAKE2B 12ce0642cffed10fcd3ba754afea86e4415705889e08f888ee71f399d3564253113909f7d6cf8432346a248f85b64b1a9abb30b641144a37c9b1bb5d82213ea3 SHA512 5e99a3ef955472dff86a8189e88c9796bb6353d663742fb72c53a39a2e380d511d15ca7825ff03a3c88cd7763fccdf213fc64b80a2156304976b8cb2125d6437
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2
-
-iQGSBAEBCAB9FiEEwuxCASuoJfEwMLVW05x7ASJpZiAFAlxxWG9fFIAAAAAALgAo
-aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEMy
-RUM0MjAxMkJBODI1RjEzMDMwQjU1NkQzOUM3QjAxMjI2OTY2MjAACgkQ05x7ASJp
-ZiB7zwf3W9Gl8bMSgwCQL/zxVIlwrQI2ybPgme/nS8VIyefeIzrUGNXp1fIyheFW
-/P6kCvlrdYZuHG3H2NGAb+8UxYL9lyXK1nLnX2oYmHG3cRJM2M634BzgeQTWJpvE
-QIYl4dorMUgKqpYu0HvinYHEHQ/9zvw7tjFn50yuRmdLMWFr7trrTtaMMLyjpSYa
-vfYZEXSGcfxplIOY1UP832ZB9ZTtminlbGVKd2hmpxVTUgV+Npzdoi/C8WHBWQdX
-YytzckJNxiN/JiKTdS//l83P/EyXByVGNVu9z+mpD97u6/toHgP2r2s6KQZPnIDg
-PiHyBRUymcg6jIhdA8EeShXpXesv
-=R5rN
------END PGP SIGNATURE-----
diff --git a/dev-util/itstool/files/itstool-segfault.patch b/dev-util/itstool/files/itstool-segfault.patch
deleted file mode 100644
index 840daccd..00000000
--- a/dev-util/itstool/files/itstool-segfault.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 9b84c007a73e8275ca45762f1bfa3ab7c3a852e2 Mon Sep 17 00:00:00 2001
-From: Shaun McCance <shaunm@redhat.com>
-Date: Wed, 25 Oct 2017 12:10:03 -0400
-Subject: [PATCH] Be more careful about libxml2 memory management
-
-I think this fixes https://github.com/itstool/itstool/issues/17
----
- itstool.in | 13 +++++++++++--
- 1 file changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/itstool.in b/itstool.in
-index c1d0585..a16eba9 100755
---- a/itstool.in
-+++ b/itstool.in
-@@ -477,6 +477,7 @@ class Document (object):
- if load_dtd:
- ctxt.loadSubset(1)
- if keep_entities:
-+ ctxt.loadSubset(1)
- ctxt.ctxtUseOptions(libxml2.XML_PARSE_DTDLOAD)
- ctxt.replaceEntities(0)
- else:
-@@ -1043,6 +1044,7 @@ class Document (object):
- if self._load_dtd:
- ctxt.loadSubset(1)
- if self._keep_entities:
-+ ctxt.loadSubset(1)
- ctxt.ctxtUseOptions(libxml2.XML_PARSE_DTDLOAD)
- ctxt.replaceEntities(0)
- else:
-@@ -1069,7 +1071,9 @@ class Document (object):
- ph_node = msg.get_placeholder(child.name).node
- if self.has_child_elements(ph_node):
- self.merge_translations(translations, None, ph_node, strict=strict)
-- child.replaceNode(ph_node)
-+ newnode = ph_node.copyNode(1)
-+ newnode.setTreeDoc(self._doc)
-+ child.replaceNode(newnode)
- else:
- repl = self.get_translated(ph_node, translations, strict=strict, lang=lang)
- child.replaceNode(repl)
-@@ -1084,10 +1088,15 @@ class Document (object):
- (lang + ' ') if lang is not None else '',
- msgstr.encode('utf-8')))
- self._xml_err = ''
-+ ctxt.doc().freeDoc()
- return node
- retnode = node.copyNode(2)
-+ retnode.setTreeDoc(self._doc)
- for child in xml_child_iter(trnode):
-- retnode.addChild(child.copyNode(1))
-+ newnode = child.copyNode(1)
-+ newnode.setTreeDoc(self._doc)
-+ retnode.addChild(newnode)
-+
- ctxt.doc().freeDoc()
- return retnode
-
diff --git a/dev-util/itstool/itstool-2.0.4-r1.ebuild b/dev-util/itstool/itstool-2.0.4-r1.ebuild
deleted file mode 100644
index a04c0574..00000000
--- a/dev-util/itstool/itstool-2.0.4-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="xml"
-
-inherit autotools python-single-r1
-
-DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
-HOMEPAGE="http://itstool.org/"
-SRC_URI="https://github.com/itstool/itstool/archive/${PV}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-linux"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/libxml2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- eapply "${FILESDIR}/${PN}-segfault.patch"
- python_fix_shebang .
- eapply_user
- eautoreconf
-}
-
-src_test() {
- suite="${S}"/tests/run_tests.py
- PYTHONPATH="." "${PYTHON}" ${suite} || die "test suite '${suite}' failed"
- unset suite
-}
diff --git a/dev-util/itstool/itstool-2.0.5.ebuild b/dev-util/itstool/itstool-2.0.5.ebuild
deleted file mode 100644
index 95f43f8d..00000000
--- a/dev-util/itstool/itstool-2.0.5.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6})
-PYTHON_REQ_USE="xml"
-
-inherit autotools python-single-r1
-
-DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
-HOMEPAGE="http://itstool.org/"
-SRC_URI="https://github.com/itstool/itstool/archive/${PV}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-linux"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/libxml2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-segfault.patch"
-)
-
-src_prepare() {
- python_fix_shebang .
- eapply_user
- eautoreconf
-}
-
-src_test() {
- suite="${S}"/tests/run_tests.py
- PYTHONPATH="." "${PYTHON}" ${suite} || die "test suite '${suite}' failed"
- unset suite
-}
diff --git a/dev-util/itstool/itstool-9999.ebuild b/dev-util/itstool/itstool-9999.ebuild
deleted file mode 100644
index bd66841d..00000000
--- a/dev-util/itstool/itstool-9999.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
-PYTHON_REQ_USE="xml"
-
-inherit autotools python-single-r1
-
-if [[ ${PV} = 9999 ]]; then
- inherit git-r3
-fi
-
-DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
-HOMEPAGE="http://itstool.org/"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/itstool/itstool.git"
-else
- SRC_URI="https://github.com/itstool/itstool/archive/${PV}.tar.gz"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-linux"
-fi
-
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/libxml2[python,${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-segfault.patch"
-)
-
-src_prepare() {
- python_fix_shebang .
- eapply_user
- eautoreconf
-}
-
-src_test() {
- suite="${S}"/tests/run_tests.py
- PYTHONPATH="." "${PYTHON}" ${suite} || die "test suite '${suite}' failed"
- unset suite
-}
diff --git a/dev-util/itstool/metadata.xml b/dev-util/itstool/metadata.xml
deleted file mode 100644
index 90e918d8..00000000
--- a/dev-util/itstool/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <longdescription lang="en">ITS Tool allows you to translate your XML documents
- with gettext PO files, using rules from the W3C Internationalization Tag Set
- (ITS) to determine what to translate and how to separate it into PO file
- messages.
-</longdescription>
-</pkgmetadata>