summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/seahorse-sharing/Manifest1
-rw-r--r--app-crypt/seahorse-sharing/seahorse-sharing-9999.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-crypt/seahorse-sharing/Manifest b/app-crypt/seahorse-sharing/Manifest
new file mode 100644
index 00000000..e8509992
--- /dev/null
+++ b/app-crypt/seahorse-sharing/Manifest
@@ -0,0 +1 @@
+EBUILD seahorse-sharing-9999.ebuild 1352 RMD160 b2b583adbe6452aaf9477806f3122fcee7ec90ae SHA1 fb16c12a03af3fbbd7da8483eda8ec1b00f3d20f SHA256 24456fe607cc40b428e2bf170a8dbdbef853e7ca09f11d6afa1a6ff904305b26
diff --git a/app-crypt/seahorse-sharing/seahorse-sharing-9999.ebuild b/app-crypt/seahorse-sharing/seahorse-sharing-9999.ebuild
new file mode 100644
index 00000000..86408d77
--- /dev/null
+++ b/app-crypt/seahorse-sharing/seahorse-sharing-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Daemon for PGP public key sharing using DNS-SD and HKP"
+HOMEPAGE="http://projects.gnome.org/seahorse/"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE=""
+
+COMMON_DEPEND="dev-libs/glib:2
+ >=net-dns/avahi-0.6
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-3:3
+
+ >=app-crypt/gpgme-1
+ || (
+ =app-crypt/gnupg-2.0*
+ =app-crypt/gnupg-1.4* )"
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-3.2"
+# ${PN} was part of seahorse before 3.2
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ DOCS="AUTHORS MAINTAINERS NEWS" # ChangeLog has nothing useful
+ # Do not pass --enable-tests to configure - package has no tests
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ # Avoid eautoreconf
+ sed -e 's:$CFLAGS -g -O0:$CFLAGS:' -i configure || die "sed failed"
+}
+
+pkg_postinst() {
+ elog "To use ${PN}, the Avahi daemon must be running. On an OpenRC"
+ elog "system, you can start the Avahi daemon by"
+ elog "# /etc/init.d/avahi-daemon start"
+ elog "To start Avahi automatically, add it to the default runlevel:"
+ elog "# rc-update add avahi-daemon default"
+}