summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/file-roller/file-roller-9999.ebuild')
-rw-r--r--app-arch/file-roller/file-roller-9999.ebuild109
1 files changed, 47 insertions, 62 deletions
diff --git a/app-arch/file-roller/file-roller-9999.ebuild b/app-arch/file-roller/file-roller-9999.ebuild
index 4a45d613..5e5ecb5e 100644
--- a/app-arch/file-roller/file-roller-9999.ebuild
+++ b/app-arch/file-roller/file-roller-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit eutils gnome2 readme.gentoo
+inherit eutils gnome2
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -14,39 +14,36 @@ fi
DESCRIPTION="Archive manager for GNOME"
HOMEPAGE="http://fileroller.sourceforge.net/"
-LICENSE="GPL-2+ CC-BY-SA-3.0"
+LICENSE="GPL-2+ CCPL-Attribution-ShareAlike-3.0"
SLOT="0"
IUSE="nautilus packagekit"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
fi
# gdk-pixbuf used extensively in the source
# cairo used in eggtreemultidnd.c
# pango used in fr-window
-RDEPEND="
- >=app-arch/libarchive-3:=
- >=dev-libs/glib-2.36:2
- >=dev-libs/json-glib-0.14
- >=x11-libs/gtk+-3.9.3:3
- >=x11-libs/libnotify-0.4.3:=
+RDEPEND=">=dev-libs/glib-2.29.14:2
sys-apps/file
x11-libs/cairo
x11-libs/gdk-pixbuf:2
- x11-libs/libICE
- x11-libs/libSM
x11-libs/pango
+ x11-libs/libSM
+ x11-libs/libICE
+ >=x11-libs/gtk+-3.4:3
+ >=app-arch/libarchive-3:=
+ >=x11-libs/libnotify-0.4.3:=
+ >=dev-libs/json-glib-0.14
nautilus? ( >=gnome-base/nautilus-3 )
packagekit? ( app-admin/packagekit-base )
"
DEPEND="${RDEPEND}
- dev-util/desktop-file-utils
>=dev-util/intltool-0.40.0
sys-devel/gettext
- virtual/pkgconfig
-"
+ virtual/pkgconfig"
# eautoreconf needs:
# gnome-base/gnome-common
@@ -55,62 +52,50 @@ if [[ ${PV} = 9999 ]]; then
app-text/yelp-tools"
fi
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="
-${PN} is a frontend for several archiving utilities. If you want a
-particular achive format support, see ${HOMEPAGE}
-and install the relevant package. For example:
-7-zip - app-arch/p7zip
-ace - app-arch/unace
-arj - app-arch/arj
-cpio - app-arch/cpio
-deb - app-arch/dpkg
-iso - app-cdr/cdrtools
-jar,zip - app-arch/zip and app-arch/unzip
-lha - app-arch/lha
-lzop - app-arch/lzop
-rar - app-arch/unrar or app-arch/unar
-rpm - app-arch/rpm
-unstuff - app-arch/stuffit
-zoo - app-arch/zoo"
-
src_prepare() {
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --disable-run-in-place
+ --disable-static
+ --disable-debug
+ --enable-magic
+ --enable-libarchive
+ --with-smclient=xsmp
+ $(use_enable nautilus nautilus-actions)
+ $(use_enable packagekit)"
+ [[ ${PV} != 9999 ]] && G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+ gnome2_src_prepare
+
# Use absolute path to GNU tar since star doesn't have the same
# options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
- # app-arch/{un,}rar-5 support, https://bugzilla.gnome.org/show_bug.cgi?id=707568
- epatch "${FILESDIR}"/${PN}-3.8.4-rar-5.patch
-
# File providing Gentoo package names for various archivers
cp -f "${FILESDIR}/3.6.0-packages.match" data/packages.match || die
-
- gnome2_src_prepare
-}
-
-src_configure() {
- local myconf=""
- [[ ${PV} != 9999 ]] && myconf="${myconf} ITSTOOL=$(type -P true)"
- DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
- # --disable-debug because enabling it adds -O0 to CFLAGS
- gnome2_src_configure \
- --disable-run-in-place \
- --disable-static \
- --disable-debug \
- --enable-magic \
- --enable-libarchive \
- --with-smclient=xsmp \
- $(use_enable nautilus nautilus-actions) \
- $(use_enable packagekit) \
- ${myconf}
-}
-
-src_install() {
- gnome2_src_install
- readme.gentoo_create_doc
}
pkg_postinst() {
gnome2_pkg_postinst
- readme.gentoo_print_elog
+
+ elog "${PN} is a frontend for several archiving utilities. If you want a"
+ elog "particular achive format support, see ${HOMEPAGE}"
+ elog "and install the relevant package."
+ elog
+ elog "for example:"
+ elog " 7-zip - app-arch/p7zip"
+ elog " ace - app-arch/unace"
+ elog " arj - app-arch/arj"
+ elog " cpio - app-arch/cpio"
+ elog " deb - app-arch/dpkg"
+ elog " iso - app-cdr/cdrtools"
+ elog " jar,zip - app-arch/zip and app-arch/unzip"
+ elog " lha - app-arch/lha"
+ elog " lzop - app-arch/lzop"
+ elog " rar - app-arch/unrar or app-arch/unar"
+ elog " rpm - app-arch/rpm"
+ elog " unstuff - app-arch/stuffit"
+ elog " zoo - app-arch/zoo"
}