summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/Manifest11
-rw-r--r--app-arch/file-roller/file-roller-3.16.1.ebuild96
-rw-r--r--app-arch/file-roller/file-roller-9999.ebuild7
3 files changed, 109 insertions, 5 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
new file mode 100644
index 00000000..26285053
--- /dev/null
+++ b/app-arch/file-roller/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST file-roller-3.16.1.tar.xz 1409468 SHA256 d0e3cf1af1bc30e29e6bbf9444fed859092e999bc4686541c021d6c1f6a58689 SHA512 e9e633ba79e016d0bd35a6d370ff70095c2711277881bea7198a7cc35e02fae681baeb26537d9f43373a4d5b0fd1634359b17fdaedde38234fc61e1760f16a58 WHIRLPOOL b7530412a9d2616acf1146b4cae20513079a2ddb8308fb0004dece07e230a371a18555ed6b6eb3fee99f8d127fc95e66259caef1d053231256433f0e09715186
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlVGjwYACgkQ1fmVwcYIWAbdXACfUKSCoCK6WVLxwxRxCUA/DqVn
+vfAAoKqa6KhKdadrvNNIY2lm+4AUO6+T
+=uuGD
+-----END PGP SIGNATURE-----
diff --git a/app-arch/file-roller/file-roller-3.16.1.ebuild b/app-arch/file-roller/file-roller-3.16.1.ebuild
new file mode 100644
index 00000000..49781489
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.16.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 readme.gentoo
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/ https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.13.2:3
+ >=x11-libs/libnotify-0.4.3:=
+ sys-apps/file
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ nautilus? ( >=gnome-base/nautilus-3 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
+
+ # File providing Gentoo package names for various archivers
+ cp -f "${FILESDIR}/3.6.0-packages.match" data/packages.match || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ $(use_enable nautilus nautilus-actions) \
+ $(use_enable packagekit) \
+ ITSTOOL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/app-arch/file-roller/file-roller-9999.ebuild b/app-arch/file-roller/file-roller-9999.ebuild
index 834bd595..64e2c59d 100644
--- a/app-arch/file-roller/file-roller-9999.ebuild
+++ b/app-arch/file-roller/file-roller-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -12,7 +12,7 @@ if [[ ${PV} = 9999 ]]; then
fi
DESCRIPTION="Archive manager for GNOME"
-HOMEPAGE="http://fileroller.sourceforge.net/"
+HOMEPAGE="http://fileroller.sourceforge.net/ https://wiki.gnome.org/Apps/FileRoller"
LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
@@ -35,8 +35,6 @@ RDEPEND="
sys-apps/file
x11-libs/cairo
x11-libs/gdk-pixbuf:2
- x11-libs/libICE
- x11-libs/libSM
x11-libs/pango
nautilus? ( >=gnome-base/nautilus-3 )
packagekit? ( app-admin/packagekit-base )
@@ -96,7 +94,6 @@ src_configure() {
--disable-debug \
--enable-magic \
--enable-libarchive \
- --with-smclient=xsmp \
$(use_enable nautilus nautilus-actions) \
$(use_enable packagekit) \
${myconf}