summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sound-juicer/Manifest11
-rw-r--r--media-sound/sound-juicer/sound-juicer-3.16.1.ebuild71
-rw-r--r--media-sound/sound-juicer/sound-juicer-9999.ebuild8
3 files changed, 87 insertions, 3 deletions
diff --git a/media-sound/sound-juicer/Manifest b/media-sound/sound-juicer/Manifest
new file mode 100644
index 00000000..0a289245
--- /dev/null
+++ b/media-sound/sound-juicer/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST sound-juicer-3.16.1.tar.xz 811148 SHA256 dfb744504a60f8069257584b74d90cba1ce99c744a7106b68627ad1d40b2a657 SHA512 9d9065942f0bdb2609f03cc561186cfdf67042e986a0f4a0e23835e56c210335f87c351a4d7e44a7dbb3960af19a3e6ba2dc3d1d6c6a5ce62bb27cfc2ea52352 WHIRLPOOL 86859d332610f8228660be213495212e89eb09a743214e10229e144858c147c64638c94ff89fef4dffb97477ba8d196e0385e64e3a942fea2e959d14f74c6678
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlVGklwACgkQ1fmVwcYIWAbkeQCg5Gvt8QGuW41h/412DxhDbvl7
+g20AoKKRvtahC9LzUq0MFEOriRAaVv6K
+=0yqR
+-----END PGP SIGNATURE-----
diff --git a/media-sound/sound-juicer/sound-juicer-3.16.1.ebuild b/media-sound/sound-juicer/sound-juicer-3.16.1.ebuild
new file mode 100644
index 00000000..eabd252d
--- /dev/null
+++ b/media-sound/sound-juicer/sound-juicer-3.16.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="CD ripper for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/SoundJuicer"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="flac test vorbis"
+
+COMMON_DEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.4:3
+ media-libs/libcanberra[gtk3]
+ >=app-cdr/brasero-2.90
+ sys-apps/dbus
+ gnome-base/gsettings-desktop-schemas
+
+ media-libs/libdiscid
+ >=media-libs/musicbrainz-5.0.1:5
+
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0[vorbis?]
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs[cdda,udev]
+ || (
+ media-plugins/gst-plugins-cdparanoia:1.0
+ media-plugins/gst-plugins-cdio:1.0 )
+ media-plugins/gst-plugins-meta:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+ test? ( ~app-text/docbook-xml-dtd-4.3 )
+"
+# eautoreconf needs gnome-common
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: gst macros does not take GST_INSPECT override anymore but we need a
+ # way to disable inspection due to gst-clutter always creating a GL context
+ # which is forbidden in sandbox since it needs write access to
+ # /dev/card*/dri
+ sed -e "s|\(gstinspect=\).*|\1$(type -P true)|" \
+ -i configure || die
+}
+
+src_configure() {
+ gnome2_src_configure ITSTOOL="$(type -P true)"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if [ -z ${REPLACING_VERSIONS} ]; then
+ ewarn "The list of audio encoding profiles in ${P} is non-customizable."
+ ewarn "A possible workaround is to rip to flac using ${PN}, and convert to"
+ ewarn "your desired format using a separate tool."
+ fi
+}
diff --git a/media-sound/sound-juicer/sound-juicer-9999.ebuild b/media-sound/sound-juicer/sound-juicer-9999.ebuild
index f6294f1e..f12f1497 100644
--- a/media-sound/sound-juicer/sound-juicer-9999.ebuild
+++ b/media-sound/sound-juicer/sound-juicer-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -46,15 +46,17 @@ RDEPEND="${COMMON_DEPEND}
media-plugins/gst-plugins-meta:1.0
"
DEPEND="${COMMON_DEPEND}
+ dev-libs/appstream-glib
>=dev-util/intltool-0.50
- >=app-text/scrollkeeper-0.3.5
virtual/pkgconfig
test? ( ~app-text/docbook-xml-dtd-4.3 )
"
if [[ ${PV} = 9999 ]]; then
DEPEND="${DEPEND}
- app-text/yelp-tools"
+ app-text/yelp-tools
+ gnome-base/gnome-common
+ "
fi
src_prepare() {