summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnome-online-accounts/Manifest15
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.18.0.ebuild78
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild3
-rw-r--r--net-libs/gnome-online-accounts/metadata.xml2
4 files changed, 95 insertions, 3 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
new file mode 100644
index 00000000..c51ed49a
--- /dev/null
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST gnome-online-accounts-3.18.0.tar.xz 1459224 SHA256 fc2dac96551746576759bd14f9b322bae1dd0aeedc0e755065ddf5eaaefacd34 SHA512 c6229d126912286f439b43c2a0309e2669665251f0578d018642335d2bb2b1ccaf735b90a35d0a5172af08a6904130e915fb725bd3930a517d1651c4059de2f0 WHIRLPOOL 1b67eaab3731ace907a838ebaa76061e8de98d7a3e472fc6553d2a55c208d5c30835d60bd0279d8b903fe50e1f6f8aaedf4e9dc582959c76cd3abba57ca20d7a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iQEcBAEBCAAGBQJWHK+hAAoJEOnlaGd+i01CcLEH/iVDqMxLTPOlFbkmDBaH5TlE
+hUGDh/qpsOrLjFyxsrk+fYNFuLtnTk3gC31luC06+c52vt2naNHbKORrfR6VuruN
+CyX3y/foG6hiklejcKxw8oWFIMb+JuFG0qnuf9d/st5F4dEbFRPUpPYjolsOgQU2
+CJW1lyYa/tn5GULSsP6AHsiD+XI7Uy+k0mmL66kSY3v5IoZWXb34ZIszgq/Njxxl
+8wUsCnEYLYd7w8EYKycRBhMao/eMmJl56ABr+OG0eVgoTdcARyk8CgWkXR7mG4QU
+j+zzKdSzHodtHtoGcEXbjYfFaz/IaWg00TdW0uarZdAAqRgItIWuNNh2TY2CnrA=
+=NDb+
+-----END PGP SIGNATURE-----
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.18.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.18.0.ebuild
new file mode 100644
index 00000000..198f4e54
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.18.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+IUSE="gnome +introspection kerberos" # telepathy"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.35:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.11.1:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ kerberos? (
+ app-crypt/gcr:0=
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ # telepathy optional support is really badly done, bug #494456
+ gnome2_src_configure \
+ --disable-static \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-lastfm \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ --enable-windows-live \
+ $(use_enable kerberos)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
index 4b0fb8f1..88c58c01 100644
--- a/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
@@ -40,7 +40,7 @@ RDEPEND="
>=x11-libs/gtk+-3.11.1:3
x11-libs/pango
- introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
kerberos? (
app-crypt/gcr:0=
app-crypt/mit-krb5 )
@@ -77,6 +77,7 @@ src_configure() {
--enable-flickr \
--enable-foursquare \
--enable-imap-smtp \
+ --enable-lastfm \
--enable-media-server \
--enable-owncloud \
--enable-pocket \
diff --git a/net-libs/gnome-online-accounts/metadata.xml b/net-libs/gnome-online-accounts/metadata.xml
index aa2fde5f..a93b05f4 100644
--- a/net-libs/gnome-online-accounts/metadata.xml
+++ b/net-libs/gnome-online-accounts/metadata.xml
@@ -5,7 +5,5 @@
<use>
<flag name="gnome">Use <pkg>gnome-base/gnome-control-center</pkg>
to set GNOME online accounts preferences</flag>
- <flag name="telepathy">Provide widget to configure the telepathy
- frawework</flag>
</use>
</pkgmetadata>