summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest6
-rw-r--r--www-client/epiphany/epiphany-3.2.0.ebuild87
-rw-r--r--www-client/epiphany/epiphany-9999.ebuild37
-rw-r--r--www-client/epiphany/files/epiphany-3.2.0-networkmanager-crash.patch31
-rw-r--r--www-client/epiphany/files/epiphany-3.2.0-optional-networkmanager.patch94
5 files changed, 241 insertions, 14 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 0fb6d39d..65416d5a 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,5 @@
-EBUILD epiphany-9999.ebuild 1936 RMD160 b4ac96b79eb331db76841d962927a54e075f1f97 SHA1 98805f604f4e6c6b6cb9441446595ec6c7cd6234 SHA256 1a44095a9e41eef13f441f9a36d2ca276db102338d6f9c27547f505d2906ecfc
+AUX epiphany-3.2.0-networkmanager-crash.patch 1118 RMD160 5a692f9339f239d32dacbc2165db64b036445f7d SHA1 dcd1265476b77767128578845f5bd8175f54e509 SHA256 ef1423bfaea72c44bd1bc1cc49d06e98dab89235fab2ad5dcd89d87b4d62cb4f
+AUX epiphany-3.2.0-optional-networkmanager.patch 2729 RMD160 1f95db1db426d8be1ef85dc2c7c36178077b546b SHA1 0b1849ed500a46dbebf52fbe14959e650ef8d828 SHA256 a992b9d25b77f404d8af7435e7ac2b84da2e08a0a99eb6ae212a0302e935b661
+DIST epiphany-3.2.0.tar.xz 5104056 RMD160 88441d9c028f5caa1109c3607efcdf2fe67bdd42 SHA1 229dc7f1e0d489113b3d273620754d171c3dcd63 SHA256 e5402cb8b52d3de5c09feb01bbf28a1bd3c20f260a2e0956c9d132f41040e5d2
+EBUILD epiphany-3.2.0.ebuild 2530 RMD160 5bec4f80a6f454c8ad7950a890adaeadbf2bd5f1 SHA1 77598ffb173834ca4ee394546fff417c4a1e39af SHA256 8901a0a5d9789ebc48de93b1797fb9120ca608f4ebfaef2c470f39a9865284c7
+EBUILD epiphany-9999.ebuild 2417 RMD160 0cc62ba8404bb772774cf0f043c32324092ded87 SHA1 5020244b5aaa162c8702e338375e8f1015186bbe SHA256 407711d4eb6974af7b6e8b47ffb10f6797457ffcf68e6f6c326121c0d4c7382e
diff --git a/www-client/epiphany/epiphany-3.2.0.ebuild b/www-client/epiphany/epiphany-3.2.0.ebuild
new file mode 100644
index 00000000..08c4fc79
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.2.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.30.2.ebuild,v 1.1 2010/06/13 21:09:33 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://projects.gnome.org/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="avahi doc +introspection +networkmanager +nss test"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+fi
+
+# XXX: Should we add seed support? Seed seems to be unmaintained now.
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND=">=dev-libs/glib-2.30.0:2
+ >=x11-libs/gtk+-3.0.2:3[introspection?]
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=app-text/iso-codes-0.35
+ >=net-libs/webkit-gtk-1.6.1:3[introspection?]
+ >=net-libs/libsoup-gnome-2.33.1:2.4
+ >=gnome-base/gnome-keyring-2.26.0
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=x11-libs/libnotify-0.5.1
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+
+ app-misc/ca-certificates
+ x11-themes/gnome-icon-theme
+
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ nss? ( dev-libs/nss )"
+# networkmanager is used purely via dbus
+RDEPEND="${COMMON_DEPEND}
+ networkmanager? ( >=net-misc/networkmanager-0.8.997 )"
+DEPEND="${COMMON_DEPEND}
+ app-text/gnome-doc-utils
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ G2CONF="${G2CONF}
+ --enable-shared
+ --disable-maintainer-mode
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
+ --with-distributor-name=Gentoo
+ --with-ca-file=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
+ $(use_enable avahi zeroconf)
+ $(use_enable introspection)
+ $(use_enable nss)
+ $(use_enable test tests)"
+ # Upstream no longer makes networkmanager optional, but we still want
+ # to make it possible for prefix users to use epiphany
+ use networkmanager && CFLAGS="${CFLAGS} -DENABLE_NETWORK_MANAGER"
+}
+
+src_prepare() {
+ # Upstream patch to fix a crash, will be in next release
+ epatch "${FILESDIR}/${P}-networkmanager-crash.patch"
+
+ # Make networkmanager optional for prefix people
+ epatch "${FILESDIR}/${PN}-3.2.0-optional-networkmanager.patch"
+ gnome2_src_prepare
+}
diff --git a/www-client/epiphany/epiphany-9999.ebuild b/www-client/epiphany/epiphany-9999.ebuild
index 729aa1e5..95b0ea4c 100644
--- a/www-client/epiphany/epiphany-9999.ebuild
+++ b/www-client/epiphany/epiphany-9999.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://projects.gnome.org/epiphany/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="avahi doc +introspection networkmanager +nss test"
+IUSE="avahi doc +introspection +networkmanager +nss test"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
@@ -23,17 +23,18 @@ else
fi
# XXX: Should we add seed support? Seed seems to be unmaintained now.
-RDEPEND=">=dev-libs/glib-2.25.13:2
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND=">=dev-libs/glib-2.30.0:2
>=x11-libs/gtk+-3.0.2:3[introspection?]
>=dev-libs/libxml2-2.6.12:2
>=dev-libs/libxslt-1.1.7
- >=x11-libs/startup-notification-0.5
- >=dev-libs/dbus-glib-0.71
>=app-text/iso-codes-0.35
- >=net-libs/webkit-gtk-1.4.2:3[introspection?]
+ >=net-libs/webkit-gtk-1.6.1:3[introspection?]
>=net-libs/libsoup-gnome-2.33.1:2.4
>=gnome-base/gnome-keyring-2.26.0
>=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=x11-libs/libnotify-0.5.1
x11-libs/libICE
x11-libs/libSM
@@ -44,16 +45,18 @@ RDEPEND=">=dev-libs/glib-2.25.13:2
avahi? ( >=net-dns/avahi-0.6.22 )
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- networkmanager? ( net-misc/networkmanager )
- nss? ( dev-libs/nss )
-"
-DEPEND="${RDEPEND}
+ nss? ( dev-libs/nss )"
+# networkmanager is used purely via dbus
+RDEPEND="${COMMON_DEPEND}
+ networkmanager? ( >=net-misc/networkmanager-0.8.997 )"
+DEPEND="${COMMON_DEPEND}
app-text/gnome-doc-utils
+ >=dev-util/gdbus-codegen-2.30.0
>=dev-util/intltool-0.40
dev-util/pkgconfig
sys-devel/gettext
- doc? ( >=dev-util/gtk-doc-1 )
-"
+ doc? ( >=dev-util/gtk-doc-1 )"
+
pkg_setup() {
DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
@@ -64,10 +67,18 @@ pkg_setup() {
--disable-scrollkeeper
--disable-static
--with-distributor-name=Gentoo
- --with-ca-file=${ROOT}/etc/ssl/certs/ca-certificates.crt
+ --with-ca-file=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
$(use_enable avahi zeroconf)
$(use_enable introspection)
- $(use_enable networkmanager network-manager)
$(use_enable nss)
$(use_enable test tests)"
+ # Upstream no longer makes networkmanager optional, but we still want
+ # to make it possible for prefix users to use epiphany
+ use networkmanager && CFLAGS="${CFLAGS} -DENABLE_NETWORK_MANAGER"
+}
+
+src_prepare() {
+ # Make networkmanager optional for prefix people
+ epatch "${FILESDIR}/${PN}-3.2.0-optional-networkmanager.patch"
+ gnome2_src_prepare
}
diff --git a/www-client/epiphany/files/epiphany-3.2.0-networkmanager-crash.patch b/www-client/epiphany/files/epiphany-3.2.0-networkmanager-crash.patch
new file mode 100644
index 00000000..0742af3c
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.2.0-networkmanager-crash.patch
@@ -0,0 +1,31 @@
+From 1cb7fb1109aecedd224d03fda202165adf3423a7 Mon Sep 17 00:00:00 2001
+From: Ionut Biru <ibiru@archlinux.org>
+Date: Mon, 26 Sep 2011 18:12:40 +0000
+Subject: Don't crash when network manager is not available
+
+https://bugzilla.gnome.org/show_bug.cgi?id=659103
+
+Signed-off-by: Ionut Biru <ibiru@archlinux.org>
+---
+diff --git a/src/ephy-shell.c b/src/ephy-shell.c
+index bf8eb18..c436da1 100644
+--- a/src/ephy-shell.c
++++ b/src/ephy-shell.c
+@@ -470,10 +470,11 @@ impl_get_embed_single (EphyEmbedShell *embed_shell)
+ priv->embed_single_connected = TRUE;
+
+ /* Now we need the net monitor */
+- ephy_shell_get_net_monitor (shell);
+- ephy_shell_sync_network_status (priv->nm_proxy,
+- ephy_network_manager_get_state (priv->nm_proxy),
+- shell);
++ if (ephy_shell_get_net_monitor (shell)) {
++ ephy_shell_sync_network_status (priv->nm_proxy,
++ ephy_network_manager_get_state (priv->nm_proxy),
++ shell);
++ }
+ }
+
+ return embed_single;
+--
+cgit v0.9.0.2
diff --git a/www-client/epiphany/files/epiphany-3.2.0-optional-networkmanager.patch b/www-client/epiphany/files/epiphany-3.2.0-optional-networkmanager.patch
new file mode 100644
index 00000000..0ac61120
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.2.0-optional-networkmanager.patch
@@ -0,0 +1,94 @@
+From c29d0825816a541c98a3b0b7f1d6bae454cba2b5 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gmail.com>
+Date: Wed, 7 Sep 2011 17:17:42 -0400
+Subject: [PATCH] Make networkmanager optional
+
+Some people cannot use it for various reasons (e.g. prefix).
+---
+ src/ephy-shell.c | 14 ++++++++++++++
+ 1 files changed, 14 insertions(+), 0 deletions(-)
+
+diff --git a/src/ephy-shell.c b/src/ephy-shell.c
+index c436da1..29b79e6 100644
+--- a/src/ephy-shell.c
++++ b/src/ephy-shell.c
+@@ -63,7 +63,9 @@ struct _EphyShellPrivate {
+ EggToolbarsModel *toolbars_model;
+ EggToolbarsModel *fs_toolbars_model;
+ EphyExtensionsManager *extensions_manager;
++#ifdef ENABLE_NETWORK_MANAGER
+ EphyNetworkManager *nm_proxy;
++#endif
+ GtkWidget *bme;
+ GtkWidget *history_window;
+ GObject *pdm_dialog;
+@@ -435,6 +437,8 @@ ephy_shell_new_window_cb (EphyEmbedSingle *single,
+ NULL, NULL, flags, chromemask, is_popup, 0);
+ }
+
++#ifdef ENABLE_NETWORK_MANAGER
++
+ static void
+ ephy_shell_sync_network_status (EphyNetworkManager *nm_proxy,
+ NMState state,
+@@ -452,6 +456,8 @@ ephy_shell_sync_network_status (EphyNetworkManager *nm_proxy,
+ ephy_embed_single_set_network_status (single, net_status);
+ }
+
++#endif /* ENABLE_NETWORK_MANAGER */
++
+ static GObject*
+ impl_get_embed_single (EphyEmbedShell *embed_shell)
+ {
+@@ -469,12 +475,14 @@ impl_get_embed_single (EphyEmbedShell *embed_shell)
+
+ priv->embed_single_connected = TRUE;
+
++#ifdef ENABLE_NETWORK_MANAGER
+ /* Now we need the net monitor */
+ if (ephy_shell_get_net_monitor (shell)) {
+ ephy_shell_sync_network_status (priv->nm_proxy,
+ ephy_network_manager_get_state (priv->nm_proxy),
+ shell);
+ }
++#endif
+ }
+
+ return embed_single;
+@@ -563,6 +571,7 @@ ephy_shell_dispose (GObject *object)
+ priv->bookmarks = NULL;
+ }
+
++#ifdef ENABLE_NETWORK_MANAGER
+ if (priv->nm_proxy != NULL) {
+ LOG ("Unref net monitor ");
+ g_signal_handlers_disconnect_by_func
+@@ -570,6 +579,7 @@ ephy_shell_dispose (GObject *object)
+ g_object_unref (priv->nm_proxy);
+ priv->nm_proxy = NULL;
+ }
++#endif /* ENABLE_NETWORK_MANAGER */
+
+ G_OBJECT_CLASS (ephy_shell_parent_class)->dispose (object);
+ }
+@@ -915,6 +925,7 @@ ephy_shell_get_extensions_manager (EphyShell *es)
+ GObject *
+ ephy_shell_get_net_monitor (EphyShell *shell)
+ {
++#ifdef ENABLE_NETWORK_MANAGER
+ EphyShellPrivate *priv = shell->priv;
+
+ if (priv->nm_proxy == NULL) {
+@@ -929,6 +940,9 @@ ephy_shell_get_net_monitor (EphyShell *shell)
+ }
+
+ return G_OBJECT (priv->nm_proxy);
++#else
++ return NULL;
++#endif /* ENABLE_NETWORK_MANAGER */
+ }
+
+ static void
+--
+1.7.6.1
+