aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Remove unsourceable ebuildsHEADmasterMatt Turner2021-06-2069-4322/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* gnome-base/libgnome-keyring: DeleteMatt Turner2021-03-235-83/+0
| | | | | Bug: https://bugs.gentoo.org/777915 Signed-off-by: Matt Turner <mattst88@gentoo.org>
* media-video/totem-9999: sync with main treeMart Raudsepp2021-01-306-375/+75
| | | | | Closes: https://bugs.gentoo.org/767559 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome2.eclass: sync with main repositoryMart Raudsepp2021-01-301-71/+33
| | | | | | Just a copy with the ewarn about experimental overlay kept for now Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* eclass: Drop various unnecessary or redundant main tree copiesMart Raudsepp2021-01-303-857/+0
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* media-sound/rhythmbox-9999: sync with main treeMart Raudsepp2021-01-301-13/+9
| | | | | | Bug: https://bugs.gentoo.org/767559 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* app-editors/gedit: Drop outdated and live ebuildMart Raudsepp2021-01-304-229/+0
| | | | | | | | | 3.30.2 or newer has been in main tree for a long time, and the live ebuild is very outdated here on top of autotools. Just drop it as it doesn't have any valid python targets anymore. Bug: https://bugs.gentoo.org/767559 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* x11-themes/gtk-engines-unico: Drop live ebuildMart Raudsepp2020-07-032-65/+0
| | | | | | | | This used removed bzr.eclass and Gentoo doesn't even package bzr anymore, so just delete it. Closes: https://bugs.gentoo.org/730568 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* scripts/gen_archlist.py: Change shebang to python3Matt Turner2020-04-031-1/+1
| | | | | | | | | | Commit d78f89c5d2f0 (scripts/gen_archlist: Hack it to work with python3) made the script at least work in python3 but intentionally left the shebang as python2. Today, portage doesn't have python2_7 in PYTHON_COMPAT, so regardless of the quality of the python3 support in this script it's the only option. Signed-off-by: Matt Turner <mattst88@gentoo.org>
* scripts/gen_archlist.py: Drop ia64 from stable archesMatt Turner2020-04-031-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* */*: Drop sh keywordsMart Raudsepp2020-03-2835-35/+35
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* scripts/gen_archlist.py: Drop ~sh completely (discontinued)Mart Raudsepp2020-03-281-1/+1
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* app-office/gnome-todo: evolution-data-server-3.33 compatibility revbumpMart Raudsepp2020-03-172-0/+637
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* app-office/gnome-todo: ebuild touchupsMart Raudsepp2020-03-171-4/+6
| | | | | | | | | | * Add missing todoist plugin deps * Require libecal-1.2 requiring e-d-s * Drop extra icon cache update call * docbook-xml-dtd dep for gtk-doc Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* scripts/gen_archlist.py: Drop alpha from stable archesMatt Turner2020-03-041-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-libs/glib: drop epunt-cxxMart Raudsepp2020-02-291-4/+2
| | | | | | | | | makes no sense with meson and this live ebuild needs a huge sync with in-tree version, but fix the global scope inherit failure at least for now. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-libs/gom: remove, available in ::gentooRémi Cardona2020-01-163-101/+0
| | | | Signed-off-by: Rémi Cardona <remi@gentoo.org>
* dev-util/itstool: remove, 2.0.6 available in ::gentooMart Raudsepp2019-11-176-220/+0
| | | | | | Closes: https://bugs.gentoo.org/653154 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-desktop: add 3.34Sobhan Mohammadpour2019-09-144-0/+110
| | | | Package-Manager: Portage-2.3.76, Repoman-2.3.17
* gnome-base/nautilus: add 3.34.0Sobhan Mohammadpour2019-09-143-0/+144
| | | | Package-Manager: Portage-2.3.76, Repoman-2.3.17
* app-misc/bijiben: remove, 3.32.2 available in ::gentooMart Raudsepp2019-09-084-72/+0
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-extra/evolution-data-server: 3.30.5-r1 → 3.32.2Sobhan Mohammadpour2019-05-023-3/+160
| | | | | Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
* gui-libs/amtk: remove, available in ::gentooMart Raudsepp2019-03-223-64/+0
| | | | | | | | | Main tree version doesn't support valgrind, as it seems to only be a check that adds extra make targets, but isn't used out of the box for tests at all as-is. Also uses proper SLOT dep for gtk+ and correct HOMEPAGE. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gui-libs/amtk: fix SLOT to 5Mart Raudsepp2019-03-222-2/+3
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* x11-libs/amtk: Move to gui-libs/amtk where main tree is nowMart Raudsepp2019-03-224-0/+1
|
* app-arch/file-roller: remove 3.30.1, fixed available in ::gentooMart Raudsepp2019-03-222-118/+0
| | | | | | | Main tree version adapts to libmagic removal Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* media-sound/rhythmbox-9999: blind syncMart Raudsepp2019-03-222-71/+48
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* media-sound/gnome-music-3.28.1: remove, 3.28.2.1 available in ::gentooMart Raudsepp2019-03-113-83/+0
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-extra/gnome-boxes: remove releases (in ::gentoo), blind sync liveMart Raudsepp2019-03-114-231/+31
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* app-editors/latexila: fix minor problemsSobhan Mohammadpour2019-02-281-2/+3
| | | | | | | | add slot to libxml2, move vala_depend to depend and add glib-utils to DEPEND Package-Manager: Portage-2.3.62, Repoman-2.3.12 Manifest-Sign-Key: 0x7DF238CF0AA182E1 Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
* remove outdated gjs mask and fix package.mask orderingSobhan Mohammadpour2019-02-281-8/+4
| | | | Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
* add app-editors/latexila-3.30.2 to package.maskSobhan Mohammadpour2019-02-281-0/+4
| | | | Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
* app-editors/latexila: bump to 3.30.2Sobhan Mohammadpour2019-02-282-21/+35
| | | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Manifest-Sign-Key: 0x7DF238CF0AA182E1 Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
* dev-util/itstool: updated live ebuildDennis Lamm2019-02-241-3/+8
| | | | | | | | | | Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> added PYTHON 3 to PYTHON_COMPAT added segfault-patch Package-Manager: Portage-2.3.51, Repoman-2.3.11 Manifest-Sign-Key: 0xD39C7B0122696620
* app-cdr/brasero: blind sync live ebuildMart Raudsepp2019-02-241-13/+7
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* x11-misc/colord: remove outdated live ebuildMart Raudsepp2019-02-242-167/+0
| | | | | | | Upstream uses meson now and it's hosted elsewhere than the ebuild had as repo location. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome2-live.eclass: Update repo URI to gitlabMart Raudsepp2019-02-241-1/+1
| | | | | Closes: https://bugs.gentoo.org/678106 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* sci-geosciences/geocode-glib: remove, available in ::gentooMart Raudsepp2019-02-233-78/+0
| | | | | | The -r0 in main tree is better than the -r1 here. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* net-misc/rygel: remove, available in ::gentooMart Raudsepp2019-02-233-132/+0
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-python/pyatspi: remove 2.26, available in ::gentooMart Raudsepp2019-02-232-80/+0
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-libs/gjs-9999: sync in libffi subslot operator usageMart Raudsepp2019-02-231-2/+2
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-libs/gjs: remove non-live, available in ::gentooMart Raudsepp2019-02-232-80/+0
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* net-libs/libsoup: remove, newer available in ::gentooMart Raudsepp2019-02-235-276/+0
| | | | | | | 9999 is also removed as its autotools based, but upstream uses only meson now. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* net-libs/glib-networking: remove, newer available in ::gentooMart Raudsepp2019-02-234-158/+0
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* media-sound/gnome-music: remove 3.26, available in ::gentooMart Raudsepp2019-02-232-86/+0
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* media-gfx/gnome-photos: remove 3.26, available in ::gentooMart Raudsepp2019-02-232-90/+0
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-extra/gnome-tweak-tool: remove, available in ::gentooMart Raudsepp2019-02-237-251/+0
| | | | | | | | | 9999 is outdated and doesn't even use meson yet, so that is removed as well. Main tree version moves to python-single-r1 and thus removes much of the complexity present here in overlay. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-extra/gnome-contacts-9999: blind sync live ebuildMart Raudsepp2019-02-232-35/+36
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-extra/gnome-contacts: remove 3.26, available in ::gentooMart Raudsepp2019-02-234-170/+0
| | | | | | | Also remove long obsolete leftover patch files Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* vala.eclass: remove outdated eclassMart Raudsepp2019-02-231-148/+0
| | | | | | | Main tree version supports newer than 0.36 vala too, plus other changes needed for supporting 0.40+ vala. Signed-off-by: Mart Raudsepp <leio@gentoo.org>