summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-09-25 10:00:01 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-09-25 10:00:01 +0000
commitdbfdee3500c8e9229c970e4415e5566a534c03ad (patch)
tree73a8b60c54b1754a9099b2b783acdf6abc1903a4
parentNevermind, tests work (diff)
downloadgnustep-dbfdee3500c8e9229c970e4415e5566a534c03ad.tar.gz
gnustep-dbfdee3500c8e9229c970e4415e5566a534c03ad.tar.bz2
gnustep-dbfdee3500c8e9229c970e4415e5566a534c03ad.zip
Bump to prerelease 2, remove 2.5
svn path=/overlay/; revision=413
-rw-r--r--sys-devel/llvm/Manifest5
-rw-r--r--sys-devel/llvm/files/llvm-2.3-disable-strip.patch19
-rw-r--r--sys-devel/llvm/llvm-2.5.ebuild187
-rw-r--r--sys-devel/llvm/llvm-2.6_pre2.ebuild146
4 files changed, 148 insertions, 209 deletions
diff --git a/sys-devel/llvm/Manifest b/sys-devel/llvm/Manifest
index c95d4be..ffa9385 100644
--- a/sys-devel/llvm/Manifest
+++ b/sys-devel/llvm/Manifest
@@ -1,5 +1,4 @@
-AUX llvm-2.3-disable-strip.patch 529 RMD160 f422ef955e196291dfdb9b44e8920e25b54a8dce SHA1 9e182792d2a5dac3fd541a3e6462399322ce31cd SHA256 d6409688ca95689bcf27b5c1ba290b65485d77fb207c0f83883e9c62caa1780f
-DIST llvm-2.5.tar.gz 6660609 RMD160 2c904b8d0bcce565ed11114b921321a0404e23fe SHA1 67f4bace9e64cc39255583aa837470d9b9de0aa5 SHA256 8f3d69e63bc5d1ee2c2ee49ff07ccb7e070070a0e937813d2a6179b9e2e173ed
DIST llvm-2.6.tar.gz 7776874 RMD160 f8ddbb155ae479ebb51c05f281e16bff78d13590 SHA1 0196659ceaf81ef903b832de6a336c4924a79892 SHA256 fe463b3d74f4fecdbbcd2252024d0122464e1dd90ad63fd409c64010affa725e
-EBUILD llvm-2.5.ebuild 5576 RMD160 a6a0175b8f60dcad2b546c8997f460e10c5eb813 SHA1 3ad0437909e4cf6e2a711ca0ff7653155cd4148f SHA256 95293653bf7bada49d24a97273ee5325100e2eb8fb2d12033e36b60a51292e2e
+DIST llvm-2.6_pre2.tar.gz 7782489 RMD160 142751db6e0f130ef6e442c0fe9c5943cab47b9e SHA1 ec4d9ffa1d3dbd8a3f657006d5cc62c5548484ac SHA256 da24eda98e32512e432d6996ccd8007cd0a18b773075e453b7f8058ee33e8f04
EBUILD llvm-2.6_pre.ebuild 4510 RMD160 8fb97ae76e864b7d24f7c66ad9a3e723e1019047 SHA1 7de28baa7deee08a2949922e72c893bb47410978 SHA256 8781093c437f4c26c58e6f6963e331fa82417d9af799ff34f97d776da2aed6fe
+EBUILD llvm-2.6_pre2.ebuild 4551 RMD160 4a3a9b5ba521214fb8b6c31f36f0027e810c9255 SHA1 db81e92fc3b754d1e7f0698d988e19d56dd8852d SHA256 bf97e921eb96995201c2a9ddd29bbe4480c36b838d1ce158a363bd59a96907fd
diff --git a/sys-devel/llvm/files/llvm-2.3-disable-strip.patch b/sys-devel/llvm/files/llvm-2.3-disable-strip.patch
deleted file mode 100644
index aeff886..0000000
--- a/sys-devel/llvm/files/llvm-2.3-disable-strip.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- Makefile.rules.orig 2008-08-21 10:54:42.000000000 +0300
-+++ Makefile.rules 2008-08-21 10:55:27.000000000 +0300
-@@ -398,11 +398,11 @@
- endif
-
- # By default, strip symbol information from executable
--ifndef KEEP_SYMBOLS
-- Strip := $(PLATFORMSTRIPOPTS)
-- StripWarnMsg := "(without symbols)"
-- Install.StripFlag += -s
--endif
-+#ifndef KEEP_SYMBOLS
-+# Strip := $(PLATFORMSTRIPOPTS)
-+# StripWarnMsg := "(without symbols)"
-+# Install.StripFlag += -s
-+#endif
-
- # Adjust linker flags for building an executable
- ifdef TOOLNAME
diff --git a/sys-devel/llvm/llvm-2.5.ebuild b/sys-devel/llvm/llvm-2.5.ebuild
deleted file mode 100644
index dc94a63..0000000
--- a/sys-devel/llvm/llvm-2.5.ebuild
+++ /dev/null
@@ -1,187 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/llvm-${PV}.tar.gz"
-
-LICENSE="LLVM"
-# most part of LLVM fall under the "University of Illinois Open Source License"
-# which doesn't seem to exist in portage yet, so I call it 'LLVM' for now. it
-# can be read from llvm/LICENSE.TXT in the source tarball.
-
-# the directory llvm/runtime/GCCLibraries/libc contains a stripped down C
-# library licensed under the LGPL 2.1 with some third party copyrights, see the
-# two LICENCE* files in that directory. Those parts do *not* get built, so
-# we omit LGPL in ${LICENCE}
-
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE="debug alltargets pic"
-# 'jit' is not a flag anymore. at least on x86, disabling it saves nothing
-# at all, so having it always enabled for platforms that support it is fine
-
-# we're not mirrored, fetch from homepage
-RESTRICT="mirror"
-
-DEPEND="dev-lang/perl
- >=sys-devel/make-3.79
- >=sys-devel/flex-2.5.4
- >=sys-devel/bison-1.28
- >=sys-devel/gcc-3.0
- "
-RDEPEND="dev-lang/perl"
-PDEPEND=""
-# note that app-arch/pax is no longer a dependency
-
-S="${WORKDIR}/llvm-${PV}"
-
-pkg_setup() {
-
- broken_gcc=( 3.2.2 3.2.3 3.3.2 4.1.1 )
- broken_gcc_x86=( 3.4.0 3.4.2 )
- broken_gcc_amd64=( 3.4.6 )
-
- gcc_vers=`gcc-fullversion`
-
- for version in ${broken_gcc[@]}
- do
- if [ "$gcc_vers" = "$version" ]; then
- elog "Your version of gcc is known to miscompile llvm"
- elog "check http://www.llvm.org/docs/GettingStarted.html for \
-possible solutions"
- die "Your version of gcc is known to miscompile llvm"
- fi
- done
-
- if use x86; then
- for version in ${broken_gcc_x86[@]}
- do
- if [ "$gcc_vers" = "$version" ]; then
- elog "Your version of gcc is known to miscompile llvm in x86 \
-architectures"
- elog "check http://www.llvm.org/docs/GettingStarted.html for \
-possible solutions"
- die "Your version of gcc is known to miscompile llvm"
- fi
- done
- fi
-
- if use amd64; then
- for version in ${broken_gcc_amd64[@]}
- do
- if [ "$gcc_vers" = "$version" ]; then
- elog "Your version of gcc is known to miscompile llvm in amd64 \
-architectures"
- elog "check http://www.llvm.org/docs/GettingStarted.html for \
-possible solutions"
- die "Your version of gcc is known to miscompile llvm"
- fi
- done
- fi
-
- broken_bison=( 1.85 1.875 )
-
- for version in ${broken_bison[@]}
- do
- if [ $(bison --version | head -n1 | cut -f4 -d" ") = "$version" ]; then
- elog "Your version of Bison is known not to work with llvm, please \
-upgrade to a newer version"
- die "Your version of Bison is known not to work with llvm"
- fi
- done
-
-
- buggy_ld=( 2.16 2.17 )
-
- for version in ${buggy_ld[@]}
- do
- if [ $(ld --version | head -n1 | cut -f5 -d" ") = "$version" ]; then
- ewarn "Your version of Binutils is known to be problematic with \
-llvm -> llvm team recommends upgrading"
- fi
- done
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # unfortunately ./configure won't listen to --mandir and the-like, so take
- # care of this.
- einfo "Fixing install dirs"
- sed -e 's,^PROJ_docsdir.*,PROJ_docsdir := $(DESTDIR)$(PROJ_prefix)/share/doc/'${PF}, \
- -e 's,^PROJ_etcdir.*,PROJ_etcdir := $(DESTDIR)/etc/llvm,' \
- -i Makefile.config.in || die "sed failed"
-
- # fix gccld and gccas, which would otherwise point to the build directory
- einfo "Fixing gccld and gccas"
- sed -e 's,^TOOLDIR.*,TOOLDIR=/usr/bin,' \
- -i tools/gccld/gccld.sh tools/gccas/gccas.sh || die "sed failed"
-
- # all binaries get rpath'd to a dir in the temporary tree that doesn't
- # contain libraries anyway; can safely remove those to avoid QA warnings
- # (the exception would be if we build shared libraries, which we don't)
- einfo "Fixing rpath"
- sed -e 's,-rpath \$(ToolDir),,g' -i Makefile.rules || die "sed failed"
-
- epatch "${FILESDIR}"/llvm-2.3-dont-build-hello.patch
- epatch "${FILESDIR}"/llvm-2.3-disable-strip.patch
-}
-
-
-src_compile() {
- local CONF_FLAGS=""
-
- if use debug; then
- CONF_FLAGS="${CONF_FLAGS} --disable-optimized"
- einfo "Note: Compiling LLVM in debug mode will create huge and slow binaries"
- # ...and you probably shouldn't use tmpfs, unless it can hold 900MB
- else
- CONF_FLAGS="${CONF_FLAGS} --enable-optimized --disable-assertions \
---disable-expensive-checks"
- fi
-
- if use alltargets; then
- CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
- else
- CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
- fi
-
- if use amd64 || use pic; then
- CONF_FLAGS="${CONF_FLAGS} --enable-pic"
- fi
-
- # a few minor things would be built a bit differently depending on whether
- # llvm-gcc is already present on the system or not. let's avoid that by
- # not letting it find llvm-gcc. llvm-gcc isn't required for anything
- # anyway. this dummy path will get spread to a few places, but none where
- # it really matters.
- CONF_FLAGS="${CONF_FLAGS} --with-llvmgccdir=/dev/null"
-
- econf ${CONF_FLAGS} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install()
-{
- make DESTDIR="${D}" install || die "make install failed"
-
- # for some reason, LLVM creates a few .dir files. remove them
- find "${D}" -name .dir -print0 | xargs -r0 rm
-
- # tblgen does not get installed and wouldn't be very useful anyway
- # so remove their man pages. llvmgcc.1 and llvmgxx.1 are present here for
- # unknown reasons. llvm-gcc will install proper man pages for itself, so
- # remove them here
- einfo "Removing unnecessary man pages"
- rm "${D}"/usr/share/man/man1/{tblgen,llvmgcc,llvmgxx}.1
-
-}
-
-
diff --git a/sys-devel/llvm/llvm-2.6_pre2.ebuild b/sys-devel/llvm/llvm-2.6_pre2.ebuild
new file mode 100644
index 0000000..d78c660
--- /dev/null
+++ b/sys-devel/llvm/llvm-2.6_pre2.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Low Level Virtual Machine"
+HOMEPAGE="http://llvm.org/"
+#SRC_URI="http://llvm.org/releases/${PV}/${P}.tar.gz"
+SRC_URI="http://llvm.org/prereleases/${PV/_pre*}/pre-release${PV/*_pre}/${PN}-${PV/_pre*}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Uoi-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alltargets debug test"
+
+DEPEND="dev-lang/perl
+ >=sys-devel/make-3.79
+ >=sys-devel/flex-2.5.4
+ >=sys-devel/bison-1.28
+ !~sys-devel/bison-1.85
+ !~sys-devel/bison-1.875
+ >=sys-devel/gcc-3.0
+ >=sys-devel/binutils-2.18
+ test? ( dev-util/dejagnu )"
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${PN}-${PV/_pre*}
+
+pkg_setup() {
+ # need to check if the active compiler is ok
+
+ broken_gcc=" 3.2.2 3.2.3 3.3.2 4.1.1 "
+ broken_gcc_x86=" 3.4.0 3.4.2 "
+ broken_gcc_amd64=" 3.4.6 "
+
+ gcc_vers=$(gcc-fullversion)
+
+ if [[ ${broken_gcc} == *" ${version} "* ]] ; then
+ elog "Your version of gcc is known to miscompile llvm."
+ elog "Check http://www.llvm.org/docs/GettingStarted.html for"
+ elog "possible solutions."
+ die "Your currently active version of gcc is known to miscompile llvm"
+ fi
+
+ if [[ ${CHOST} == i*86-* && ${broken_gcc_x86} == *" ${version} "* ]] ; then
+ elog "Your version of gcc is known to miscompile llvm on x86"
+ elog "architectures. Check"
+ elog "http://www.llvm.org/docs/GettingStarted.html for possible"
+ elog "solutions."
+ die "Your currently active version of gcc is known to miscompile llvm"
+ fi
+
+ if [[ ${CHOST} == x86_64-* && ${broken_gcc_amd64} == *" ${version} "* ]];
+ then
+ elog "Your version of gcc is known to miscompile llvm in amd64"
+ elog "architectures. Check"
+ elog "http://www.llvm.org/docs/GettingStarted.html for possible"
+ elog "solutions."
+ die "Your currently active version of gcc is known to miscompile llvm"
+ fi
+}
+
+src_prepare() {
+ # unfortunately ./configure won't listen to --mandir and the-like, so take
+ # care of this.
+ einfo "Fixing install dirs"
+ sed -e 's,^PROJ_docsdir.*,PROJ_docsdir := $(DESTDIR)$(PROJ_prefix)/share/doc/'${PF}, \
+ -e 's,^PROJ_etcdir.*,PROJ_etcdir := $(DESTDIR)/etc/llvm,' \
+ -i Makefile.config.in || die "sed failed"
+
+ # point by default to the build directory
+ einfo "Fixing gccld and gccas"
+ sed -e 's,^TOOLDIR.*,TOOLDIR=/usr/bin,' \
+ -i tools/gccld/gccld.sh tools/gccas/gccas.sh || die "sed failed"
+
+ einfo "Fixing rpath"
+ sed -e 's/\$(RPATH) -Wl,\$(\(ToolDir\|LibDir\))//g' -i Makefile.rules || die "sed failed"
+}
+
+src_configure() {
+ local CONF_FLAGS=""
+
+ if use debug; then
+ CONF_FLAGS="${CONF_FLAGS} --disable-optimized"
+ einfo "Note: Compiling LLVM in debug mode will create huge and slow binaries"
+ # ...and you probably shouldn't use tmpfs, unless it can hold 900MB
+ else
+ CONF_FLAGS="${CONF_FLAGS} \
+ --enable-optimized \
+ --disable-assertions \
+ --disable-expensive-checks"
+ fi
+
+ if use alltargets; then
+ CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
+ else
+ CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
+ fi
+
+ if use amd64; then
+ CONF_FLAGS="${CONF_FLAGS} --enable-pic"
+ fi
+
+ # things would be built differently depending on whether llvm-gcc is
+ # already present on the system or not.
+ local LLVM_GCC_DIR=/dev/null
+ local LLVM_GCC_DRIVER=nope ; local LLVM_GPP_DRIVER=nope
+ if has_version sys-devel/llvm-gcc ; then
+ LLVM_GCC_DIR=$(find /usr/$(get_libdir)/llvm-gcc/ -mindepth 1 -maxdepth 1 2> /dev/null)
+ LLVM_GCC_DRIVER=$(find ${LLVM_GCC_DIR} -name 'llvm*-gcc' 2> /dev/null)
+
+ if [[ -z ${LLVM_GCC_DRIVER} ]] ; then
+ die "failed to find installed llvm-gcc, LLVM_GCC_DIR=${LLVM_GCC_DIR}"
+ fi
+
+ einfo "Using $LLVM_GCC_DRIVER"
+ LLVM_GPP_DRIVER=${LLVM_GCC_DRIVER/%-gcc/-g++}
+ fi
+
+ CONF_FLAGS="${CONF_FLAGS} \
+ --with-llvmgccdir=${LLVM_GCC_DIR} \
+ --with-llvmgcc=${LLVM_GCC_DRIVER} \
+ --with-llvmgxx=${LLVM_GPP_DRIVER}"
+
+ econf ${CONF_FLAGS} || die "econf failed"
+}
+
+src_compile() {
+ emake VERBOSE=1 KEEP_SYMBOLS=1 || die "emake failed"
+}
+
+src_install() {
+ emake KEEP_SYMBOLS=1 DESTDIR="${D}" install || die "install failed"
+
+ # don't install html.tar.gz in /usr/share/doc -- FIXME: USE=doc
+ einfo "Removing archived html documentation"
+ rm "${D}"/usr/share/doc/${PF}/*tar.gz \
+ || die "no such file ${D}/usr/share/doc/${PF}/*tar.gz"
+
+ # tblgen does not get installed, so remove its man page.
+ # llvmgcc.1 and llvmgxx.1 are present here for unknown reasons. But, since
+ # llvm-gcc installs bad man pages, keep the 2 files alive
+ rm "${D}"/usr/share/man/man1/tblgen.1
+}