summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-13 19:23:53 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-13 19:23:53 +0000
commitbed85ec56fdeeb0d2b8483cd39afc190b5d22113 (patch)
tree7173e00b765c5970ad5bf5fcc3803db303757bb6
parentadd gnustep-apps/vindaloo (diff)
downloadprefix-bed85ec56fdeeb0d2b8483cd39afc190b5d22113.tar.gz
prefix-bed85ec56fdeeb0d2b8483cd39afc190b5d22113.tar.bz2
prefix-bed85ec56fdeeb0d2b8483cd39afc190b5d22113.zip
add gnustep-apps/zipper
(Portage 2.2.00.7595-prefix/SVN/Linux 2.6.20-1.2925.fc6 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+) svn path=/prefix-overlay/; revision=290
-rw-r--r--gnustep-apps/zipper/Manifest2
-rw-r--r--gnustep-apps/zipper/zipper-1.2.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/gnustep-apps/zipper/Manifest b/gnustep-apps/zipper/Manifest
new file mode 100644
index 0000000..06821a1
--- /dev/null
+++ b/gnustep-apps/zipper/Manifest
@@ -0,0 +1,2 @@
+DIST Zipper-1.2.tar.gz 476243 RMD160 c965b7af2f503c4701da34641fcc52b54cb45511 SHA1 e59a87347073e1be1b6d4435656c26c6751581f1 SHA256 c46453468030acb92c3ddbe2cb7b11573cc0c5ec4b8ae849541a71d38e96d012
+EBUILD zipper-1.2.ebuild 720 RMD160 e8254a79e16ec8769e6d1ea3db10e30a8d99aae9 SHA1 c366b3ffe51a124a79758df08431f5b7a02fc23c SHA256 101a3a5fb5bf8888d84c49aa3f7b2b1d252f3588cc1af6e42f20170a75b33c2d
diff --git a/gnustep-apps/zipper/zipper-1.2.ebuild b/gnustep-apps/zipper/zipper-1.2.ebuild
new file mode 100644
index 0000000..32a91ea
--- /dev/null
+++ b/gnustep-apps/zipper/zipper-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="prefix"
+
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/z/Z}
+
+DESCRIPTION="Zipper is a tool for inspecting and extracting compressed archives"
+HOMEPAGE="http://xanthippe.dyndns.org/Zipper/"
+SRC_URI="http://xanthippe.dyndns.org/Zipper/${P/z/Z}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="gnustep-libs/renaissance"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+
+ elog "Optional archives programs zipper can use:"
+ elog "app-arch/unzip (ZIP files)"
+ elog "app-arch/lha (LZH archives)"
+ elog "app-arch/unlzx (Amiga LZX archives)"
+ elog "app-arch/rar (RAR files)"
+}