aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-24 09:07:07 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-24 09:07:07 -0400
commit6ffc2a5b105c79686c2de389b87ae99d99455cd5 (patch)
tree72063f189b86c1e6775bf0862aa6dcf18b031bfd /sys-kernel/hardened-sources/hardened-sources-4.2.4.ebuild
parentsys-kernel/hardened-sources: testing patchset 20151020. (diff)
downloadhardened-dev-6ffc2a5b105c79686c2de389b87ae99d99455cd5.tar.gz
hardened-dev-6ffc2a5b105c79686c2de389b87ae99d99455cd5.tar.bz2
hardened-dev-6ffc2a5b105c79686c2de389b87ae99d99455cd5.zip
sys-kernel/hardened-sources: testing patchset 20151022.
Package-Manager: portage-2.2.20.1 Manifest-Sign-Key: 0x9384FA6EF52D4BBA
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-4.2.4.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-4.2.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-4.2.4.ebuild b/sys-kernel/hardened-sources/hardened-sources-4.2.4.ebuild
new file mode 100644
index 00000000..bf12ce9c
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-4.2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="6"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="
+ 1500_XATTR_USER_PREFIX.patch
+ 1600_dm-crypt-limit-max-segment-size.patch
+ 2900_dev-root-proc-mount-fix.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.1*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}