aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/dosfstools/files/dosfstools-3.0.28-fix_build_with_musl.patch')
-rw-r--r--sys-fs/dosfstools/files/dosfstools-3.0.28-fix_build_with_musl.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/sys-fs/dosfstools/files/dosfstools-3.0.28-fix_build_with_musl.patch b/sys-fs/dosfstools/files/dosfstools-3.0.28-fix_build_with_musl.patch
deleted file mode 100644
index b4953786..00000000
--- a/sys-fs/dosfstools/files/dosfstools-3.0.28-fix_build_with_musl.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/Makefile b/Makefile
-index f22a4c5..967defe 100644
---- a/Makefile
-+++ b/Makefile
-@@ -30,7 +30,7 @@ MANDIR = $(PREFIX)/share/man
- #OPTFLAGS = -O2 -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
- #WARNFLAGS = -Wall -pedantic -std=c99
- WARNFLAGS = -Wall -Wextra -Wno-sign-compare -Wno-missing-field-initializers -Wmissing-prototypes -Wstrict-prototypes -Wwrite-strings
--CFLAGS += $(OPTFLAGS) $(WARNFLAGS) $(DEBUGFLAGS)
-+CFLAGS += $(OPTFLAGS) $(WARNFLAGS) $(DEBUGFLAGS) -D _GNU_SOURCE
-
- VPATH = src
-
-diff --git a/src/mkfs.fat.c b/src/mkfs.fat.c
-index b38d116..7e6c996 100644
---- a/src/mkfs.fat.c
-+++ b/src/mkfs.fat.c
-@@ -60,6 +60,7 @@
- #include <sys/ioctl.h>
- #include <sys/stat.h>
- #include <sys/time.h>
-+#include <sys/types.h>
- #include <unistd.h>
- #include <time.h>
- #include <errno.h>