aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2010-07-15 14:30:24 +0200
committerMagnus Granberg <zorry@gentoo.org>2010-07-15 14:30:24 +0200
commita3142b8ec7135f0f57ff10929dd448fcc61b8b2f (patch)
tree7426bbc5ce08c049cb7e006d324187a524d27920
parentUpdated the patch to fix typo (diff)
downloadhardened-gccpatchset-a3142b8ec7135f0f57ff10929dd448fcc61b8b2f.tar.gz
hardened-gccpatchset-a3142b8ec7135f0f57ff10929dd448fcc61b8b2f.tar.bz2
hardened-gccpatchset-a3142b8ec7135f0f57ff10929dd448fcc61b8b2f.zip
Wtrampolines patch Committed revision 162205 upstrem
-rw-r--r--Todo15
-rw-r--r--upstream/warntrampolins/README9
-rwxr-xr-xupstream/warntrampolins/Wtrampolines.patch126
3 files changed, 3 insertions, 147 deletions
diff --git a/Todo b/Todo
index 370290c..c382db0 100644
--- a/Todo
+++ b/Todo
@@ -1,15 +1,6 @@
-piepatch-0.4.1 on gcc 4.4.3-r4
-Is commited to the overlay
-/Zorry
-
-piepatch 0.4.1
-Need to test if we still need the hunk 7 of gcc/Makefile.in
-$(out_object_file): ix86_split_to_parts() stack smashing attack b.g.o #149292.
-/Zorry
-
-specs-0.9.5 for 4.3.4
-Commited in the overlay
+piepatch-0.4.5 on gcc 4.4.3-r3 4.4.1-r1 4.5.0
+Is commited to the tree
/Zorry
upstream
-the warntrampolin need some work befor it it mail to gcc-patches or gcc bug tracker.
+The -Wtrampolines patch is Committed revision 162205 upstream
diff --git a/upstream/warntrampolins/README b/upstream/warntrampolins/README
deleted file mode 100644
index 735255f..0000000
--- a/upstream/warntrampolins/README
+++ /dev/null
@@ -1,9 +0,0 @@
- This trivial patch causes gcc to emit a warning whenever
- it generates a trampoline. These are otherwise hard to
- locate. It is rigged to default ON - to have it default
- to OFF remove the text 'Init(1)' from the common.opt
- patch, leaving just 'Common Var(warn_trampolines)'.
- Kevin F. Quinn <kevquinn@gentoo.org> 17 Jan 2006
-
-Ported to GCC 4.5.x /Zorry
-http://gcc.gnu.org/ml/gcc-patches/2010-05/msg00352.html
diff --git a/upstream/warntrampolins/Wtrampolines.patch b/upstream/warntrampolins/Wtrampolines.patch
deleted file mode 100755
index ce2c004..0000000
--- a/upstream/warntrampolins/Wtrampolines.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-2010-06-29 Magnus Granberg <zorry@gentoo.org>, Kevin F. Quinn <kevquinn@gentoo.org>
-
- * gcc/builtins.c: (expand_builtin_init_trampoline): if -Wtrampolines make a warning.
- * gcc/common.opt: Add -Wtrampolines.
- * gcc/doc/invoke.texi: Add -Wtrampolines.
- * gcc/testsuite/gcc.dg/Wtrampolines.c: New.
-
---- gcc/builtins.c.zorry 2010-04-13 15:47:11.000000000 +0200
-+++ gcc/builtins.c 2010-06-16 12:33:54.000000000 +0200
-@@ -5150,6 +5150,11 @@
- targetm.calls.trampoline_init (m_tramp, t_func, r_chain);
-
- trampolines_created = 1;
-+
-+ if (warn_trampolines)
-+ warning_at (DECL_SOURCE_LOCATION (t_func), OPT_Wtrampolines,
-+ "trampoline generated for nested function %qD", t_func);
-+
- return const0_rtx;
- }
-
---- gcc/common.opt.zorry 2010-03-18 04:01:09.000000000 +0100
-+++ gcc/common.opt 2010-05-06 00:44:18.000000000 +0200
-@@ -192,6 +192,10 @@
- Common Var(warn_system_headers) Warning
- Do not suppress warnings from system headers
-
-+Wtrampolines
-+Common Var(warn_trampolines) Warnings
-+Warn whenever a trampoline is generated
-+
- Wtype-limits
- Common Var(warn_type_limits) Init(-1) Warning
- Warn if a comparison is always true or always false due to the limited range of the data type
---- gcc/doc/invoke.texi.zorry 2010-04-06 16:02:22.000000000 +0200
-+++ gcc/doc/invoke.texi 2010-05-06 00:20:25.000000000 +0200
-@@ -258,8 +258,8 @@
- -Wstrict-aliasing -Wstrict-aliasing=n @gol
- -Wstrict-overflow -Wstrict-overflow=@var{n} @gol
- -Wswitch -Wswitch-default -Wswitch-enum -Wsync-nand @gol
---Wsystem-headers -Wtrigraphs -Wtype-limits -Wundef -Wuninitialized @gol
---Wunknown-pragmas -Wno-pragmas @gol
-+-Wsystem-headers -Wtrampolines -Wtrigraphs -Wtype-limits -Wundef @gol
-+-Wuninitialized -Wunknown-pragmas -Wno-pragmas @gol
- -Wunsuffixed-float-constants -Wunused -Wunused-function @gol
- -Wunused-label -Wunused-parameter -Wno-unused-result -Wunused-value -Wunused-variable @gol
- -Wvariadic-macros -Wvla @gol
-@@ -3603,6 +3603,18 @@
- option will @emph{not} warn about unknown pragmas in system
- headers---for that, @option{-Wunknown-pragmas} must also be used.
-
-+@item -Wtrampolines
-+@opindex Wtrampolines
-+@opindex Wno-trampolines
-+ Warn about trampolines generated for pointers to nested functions.
-+
-+ A trampoline is a small piece of data or code that is created at run
-+ time on the stack when the address of a nested function is taken, and
-+ is used to call the nested function indirectly. For some targets, it
-+ is made up of data only and thus requires no special treatment. But,
-+ for most targets, it is made up of code and thus requires the stack
-+ to be made executable in order for the program to work properly.
-+
- @item -Wfloat-equal
- @opindex Wfloat-equal
- @opindex Wno-float-equal
---- gcc/testsuite/gcc.dg/Wtrampolines.c.zorry 2010-05-05 12:53:11.000000000 +0200
-+++ gcc/testsuite/gcc.dg/Wtrampolines.c 2010-05-06 00:26:05.000000000 +0200
-@@ -0,0 +1,57 @@
-+/* Origin: trampoline-1.c Waldek Hebisch <hebisch@math.uni.wroc.pl> */
-+/* Ported to test -Wtrampolines Magnus Granberg <zorry@gentoo.org> */
-+
-+/* { dg-do compile } */
-+/* { dg-require-effective-target trampolines } */
-+/* { dg-options "-O2 -Wtrampolines" } */
-+
-+#ifndef NO_TRAMPOLINES
-+
-+/* This used to fail on various versions of Solaris 2 because the
-+ trampoline couldn't be made executable. */
-+
-+extern void abort(void);
-+extern double fabs(double);
-+
-+void foo (void)
-+{
-+ const int correct[1100] = {1, 0, -2, 0, 1, 0, 1, -1, -10, -30, -67};
-+ int i;
-+
-+ double x1 (void) {return 1; }
-+ double x2 (void) {return -1;}
-+ double x3 (void) {return -1;}
-+ double x4 (void) {return 1; }
-+ double x5 (void) {return 0; }
-+
-+ typedef double pfun(void);
-+
-+ double a (int k, pfun x1, pfun x2, pfun x3, pfun x4, pfun x5)
-+ {
-+ double b (void) /* { dg-warning "trampoline generated for nested function 'b'" } */
-+ {
-+ k = k - 1;
-+ return a (k, b, x1, x2, x3, x4 );
-+ }
-+
-+ if (k <= 0)
-+ return x4 () + x5 ();
-+ else
-+ return b ();
-+ }
-+
-+ for (i=0; i<=10; i++)
-+ {
-+ if (fabs(a( i, x1, x2, x3, x4, x5 ) - correct [i]) > 0.1)
-+ abort();
-+ }
-+}
-+#endif
-+
-+int main (void)
-+{
-+#ifndef NO_TRAMPOLINES
-+ foo ();
-+#endif
-+ return 0;
-+}