summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-25 06:04:00 -0400
committerAnthony G. Basile <blueness@gentoo.org>2012-06-25 06:04:00 -0400
commit8d4deae3cf2fd7033538796ae0771644988ffbe6 (patch)
tree765cc311eabe0af7aba4f440099108181b3b9a80
parentGrsec/PaX: 2.9.1-3.4.4-201206221855 (diff)
downloadhardened-patchset-8d4deae3cf2fd7033538796ae0771644988ffbe6.tar.gz
hardened-patchset-8d4deae3cf2fd7033538796ae0771644988ffbe6.tar.bz2
hardened-patchset-8d4deae3cf2fd7033538796ae0771644988ffbe6.zip
Correct patch 4420 for 3.4.420120623
-rw-r--r--3.4.4/0000_README2
-rw-r--r--3.4.4/4420_grsecurity-2.9.1-3.4.4-201206231147.patch (renamed from 3.4.4/4420_grsecurity-2.9.1-3.4.3-201206221855.patch)18
2 files changed, 10 insertions, 10 deletions
diff --git a/3.4.4/0000_README b/3.4.4/0000_README
index 399b294..dbb8629 100644
--- a/3.4.4/0000_README
+++ b/3.4.4/0000_README
@@ -2,7 +2,7 @@ README
-----------------------------------------------------------------------------
Individual Patch Descriptions:
-----------------------------------------------------------------------------
-Patch: 4420_grsecurity-2.9.1-3.4.3-201206221855.patch
+Patch: 4420_grsecurity-2.9.1-3.4.4-201206231147.patch
From: http://www.grsecurity.net
Desc: hardened-sources base patch from upstream grsecurity
diff --git a/3.4.4/4420_grsecurity-2.9.1-3.4.3-201206221855.patch b/3.4.4/4420_grsecurity-2.9.1-3.4.4-201206231147.patch
index 11b28cf..758a4c4 100644
--- a/3.4.4/4420_grsecurity-2.9.1-3.4.3-201206221855.patch
+++ b/3.4.4/4420_grsecurity-2.9.1-3.4.4-201206231147.patch
@@ -229,7 +229,7 @@ index c1601e5..08557ce 100644
pcd. [PARIDE]
diff --git a/Makefile b/Makefile
-index a0804c6..6e08a63 100644
+index 058320d..817f7ad 100644
--- a/Makefile
+++ b/Makefile
@@ -245,8 +245,9 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
@@ -27111,7 +27111,7 @@ index 00aaf04..4a26505 100644
-}
-__setup("vdso=", vdso_setup);
diff --git a/arch/x86/xen/enlighten.c b/arch/x86/xen/enlighten.c
-index 6c7f1e8..de96944 100644
+index 40edfc3..b4d80ac 100644
--- a/arch/x86/xen/enlighten.c
+++ b/arch/x86/xen/enlighten.c
@@ -95,8 +95,6 @@ EXPORT_SYMBOL_GPL(xen_start_info);
@@ -27123,7 +27123,7 @@ index 6c7f1e8..de96944 100644
RESERVE_BRK(shared_info_page_brk, PAGE_SIZE);
__read_mostly int xen_have_vector_callback;
EXPORT_SYMBOL_GPL(xen_have_vector_callback);
-@@ -1157,30 +1155,30 @@ static const struct pv_apic_ops xen_apic_ops __initconst = {
+@@ -1165,30 +1163,30 @@ static const struct pv_apic_ops xen_apic_ops __initconst = {
#endif
};
@@ -27161,7 +27161,7 @@ index 6c7f1e8..de96944 100644
{
if (pm_power_off)
pm_power_off();
-@@ -1283,7 +1281,17 @@ asmlinkage void __init xen_start_kernel(void)
+@@ -1291,7 +1289,17 @@ asmlinkage void __init xen_start_kernel(void)
__userpte_alloc_gfp &= ~__GFP_HIGHMEM;
/* Work out if we support NX */
@@ -27180,7 +27180,7 @@ index 6c7f1e8..de96944 100644
xen_setup_features();
-@@ -1314,13 +1322,6 @@ asmlinkage void __init xen_start_kernel(void)
+@@ -1322,13 +1330,6 @@ asmlinkage void __init xen_start_kernel(void)
machine_ops = xen_machine_ops;
@@ -67010,7 +67010,7 @@ index a307cc9..27fd2e9 100644
/* set it to 0 if there are no waiters left: */
diff --git a/kernel/panic.c b/kernel/panic.c
-index 8ed89a1..e83856a 100644
+index 9ed023b..e49543e 100644
--- a/kernel/panic.c
+++ b/kernel/panic.c
@@ -402,7 +402,7 @@ static void warn_slowpath_common(const char *file, int line, void *caller,
@@ -68981,7 +68981,7 @@ index 0fa92f6..89950b2 100644
struct ftrace_func_probe *entry;
struct ftrace_page *pg;
diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
-index 2a22255..cdcdd06 100644
+index 464a96f..bc0bd88 100644
--- a/kernel/trace/trace.c
+++ b/kernel/trace/trace.c
@@ -4312,10 +4312,9 @@ static const struct file_operations tracing_dyn_info_fops = {
@@ -73390,7 +73390,7 @@ index 5c13f13..f1cfc13 100644
}
diff --git a/mm/swapfile.c b/mm/swapfile.c
-index fafc26d..1b7493e 100644
+index 38186d9..bfba6d3 100644
--- a/mm/swapfile.c
+++ b/mm/swapfile.c
@@ -61,7 +61,7 @@ static DEFINE_MUTEX(swapon_mutex);
@@ -73431,7 +73431,7 @@ index fafc26d..1b7493e 100644
return 0;
}
-@@ -2127,7 +2127,7 @@ SYSCALL_DEFINE2(swapon, const char __user *, specialfile, int, swap_flags)
+@@ -2123,7 +2123,7 @@ SYSCALL_DEFINE2(swapon, const char __user *, specialfile, int, swap_flags)
(p->flags & SWP_DISCARDABLE) ? "D" : "");
mutex_unlock(&swapon_mutex);