aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-01-30 21:43:47 +0000
committerJames Le Cuirot <chewi@gentoo.org>2017-01-30 21:43:47 +0000
commit7a1d1c3636659d1033ad034828f6f4aa85a7a087 (patch)
tree1765f957c76243bb5ab9257b40b0fd6049d06d39
parentdev-java/icedtea: Update to 3.3.0 release: http://bitly.com/it30300 (diff)
downloadjava-7a1d1c3636659d1033ad034828f6f4aa85a7a087.tar.gz
java-7a1d1c3636659d1033ad034828f6f4aa85a7a087.tar.bz2
java-7a1d1c3636659d1033ad034828f6f4aa85a7a087.zip
dev-java/icedtea: EAPI bump to 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-java/icedtea/icedtea-3.3.0.ebuild6
-rw-r--r--dev-java/icedtea/icedtea-3.3.0_pre00.ebuild15
-rw-r--r--dev-java/icedtea/icedtea-6.1.13.13.ebuild6
-rw-r--r--dev-java/icedtea/icedtea-6.9999.ebuild13
-rw-r--r--dev-java/icedtea/icedtea-7.2.6.8.ebuild8
-rw-r--r--dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild15
6 files changed, 30 insertions, 33 deletions
diff --git a/dev-java/icedtea/icedtea-3.3.0.ebuild b/dev-java/icedtea/icedtea-3.3.0.ebuild
index 222b064e..3e50184c 100644
--- a/dev-java/icedtea/icedtea-3.3.0.ebuild
+++ b/dev-java/icedtea/icedtea-3.3.0.ebuild
@@ -7,7 +7,7 @@
# * IF YOU CHANGE THIS EBUILD, CHANGE ICEDTEA-6.* AS WELL *
# *********************************************************
-EAPI="5"
+EAPI="6"
SLOT="8"
inherit check-reqs gnome2-utils java-pkg-2 java-vm-2 multiprocessing pax-utils prefix versionator
@@ -193,15 +193,13 @@ src_unpack() {
unpack ${SRC_PKG}
}
-java_prepare() {
+src_configure() {
# For bootstrap builds as the sandbox control file might not yet exist.
addpredict /proc/self/coredump_filter
# icedtea doesn't like some locales. #330433 #389717
export LANG="C" LC_ALL="C"
-}
-src_configure() {
local cacao_config config hotspot_port hs_config jamvm_config use_cacao use_jamvm use_zero zero_config
local vm=$(java-pkg_get-current-vm)
diff --git a/dev-java/icedtea/icedtea-3.3.0_pre00.ebuild b/dev-java/icedtea/icedtea-3.3.0_pre00.ebuild
index 138abb00..f668aef5 100644
--- a/dev-java/icedtea/icedtea-3.3.0_pre00.ebuild
+++ b/dev-java/icedtea/icedtea-3.3.0_pre00.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
@@ -7,7 +7,7 @@
# * IF YOU CHANGE THIS EBUILD, CHANGE ICEDTEA-6.* AS WELL *
# *********************************************************
-EAPI="5"
+EAPI="6"
SLOT="8"
inherit autotools check-reqs gnome2-utils java-pkg-2 java-vm-2 mercurial multiprocessing pax-utils prefix versionator virtualx
@@ -194,17 +194,18 @@ src_unpack() {
mercurial_src_unpack
}
-java_prepare() {
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
# For bootstrap builds as the sandbox control file might not yet exist.
addpredict /proc/self/coredump_filter
# icedtea doesn't like some locales. #330433 #389717
export LANG="C" LC_ALL="C"
- eautoreconf
-}
-
-src_configure() {
local cacao_config config hotspot_port hs_config jamvm_config use_cacao use_jamvm use_zero zero_config
local vm=$(java-pkg_get-current-vm)
diff --git a/dev-java/icedtea/icedtea-6.1.13.13.ebuild b/dev-java/icedtea/icedtea-6.1.13.13.ebuild
index 3520cbc0..3e24b6c3 100644
--- a/dev-java/icedtea/icedtea-6.1.13.13.ebuild
+++ b/dev-java/icedtea/icedtea-6.1.13.13.ebuild
@@ -7,7 +7,7 @@
# * IF YOU CHANGE THIS EBUILD, CHANGE ICEDTEA-7.* AS WELL *
# *********************************************************
-EAPI="5"
+EAPI="6"
SLOT="6"
inherit check-reqs java-pkg-2 java-vm-2 multiprocessing pax-utils versionator virtualx
@@ -157,15 +157,13 @@ src_unpack() {
unpack ${SRC_PKG}
}
-java_prepare() {
+src_configure() {
# For bootstrap builds as the sandbox control file might not yet exist.
addpredict /proc/self/coredump_filter
# icedtea doesn't like some locales. #330433 #389717
export LANG="C" LC_ALL="C"
-}
-src_configure() {
local cacao_config config hotspot_port jamvm_config use_cacao use_jamvm use_zero zero_config
local vm=$(java-pkg_get-current-vm)
diff --git a/dev-java/icedtea/icedtea-6.9999.ebuild b/dev-java/icedtea/icedtea-6.9999.ebuild
index 413ae968..8112b14f 100644
--- a/dev-java/icedtea/icedtea-6.9999.ebuild
+++ b/dev-java/icedtea/icedtea-6.9999.ebuild
@@ -7,7 +7,7 @@
# * IF YOU CHANGE THIS EBUILD, CHANGE ICEDTEA-7.* AS WELL *
# *********************************************************
-EAPI="5"
+EAPI="6"
SLOT="6"
inherit autotools check-reqs java-pkg-2 java-vm-2 mercurial multiprocessing pax-utils prefix versionator virtualx
@@ -154,17 +154,18 @@ src_unpack() {
mercurial_src_unpack
}
-java_prepare() {
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
# For bootstrap builds as the sandbox control file might not yet exist.
addpredict /proc/self/coredump_filter
# icedtea doesn't like some locales. #330433 #389717
export LANG="C" LC_ALL="C"
- eautoreconf
-}
-
-src_configure() {
local cacao_config config hotspot_port jamvm_config use_cacao use_jamvm use_zero zero_config
local vm=$(java-pkg_get-current-vm)
diff --git a/dev-java/icedtea/icedtea-7.2.6.8.ebuild b/dev-java/icedtea/icedtea-7.2.6.8.ebuild
index 1fa4d986..cf04f020 100644
--- a/dev-java/icedtea/icedtea-7.2.6.8.ebuild
+++ b/dev-java/icedtea/icedtea-7.2.6.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
@@ -7,7 +7,7 @@
# * IF YOU CHANGE THIS EBUILD, CHANGE ICEDTEA-6.* AS WELL *
# *********************************************************
-EAPI="5"
+EAPI="6"
SLOT="7"
inherit check-reqs gnome2-utils java-pkg-2 java-vm-2 multiprocessing pax-utils prefix versionator virtualx
@@ -192,15 +192,13 @@ src_unpack() {
unpack ${SRC_PKG}
}
-java_prepare() {
+src_configure() {
# For bootstrap builds as the sandbox control file might not yet exist.
addpredict /proc/self/coredump_filter
# icedtea doesn't like some locales. #330433 #389717
export LANG="C" LC_ALL="C"
-}
-src_configure() {
local cacao_config config hotspot_port jamvm_config use_cacao use_jamvm use_zero zero_config
local vm=$(java-pkg_get-current-vm)
diff --git a/dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild b/dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild
index d1b397c3..7559d6b4 100644
--- a/dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild
+++ b/dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
@@ -7,7 +7,7 @@
# * IF YOU CHANGE THIS EBUILD, CHANGE ICEDTEA-6.* AS WELL *
# *********************************************************
-EAPI="5"
+EAPI="6"
SLOT="7"
inherit autotools check-reqs gnome2-utils java-pkg-2 java-vm-2 mercurial multiprocessing pax-utils prefix versionator virtualx
@@ -193,17 +193,18 @@ src_unpack() {
mercurial_src_unpack
}
-java_prepare() {
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
# For bootstrap builds as the sandbox control file might not yet exist.
addpredict /proc/self/coredump_filter
# icedtea doesn't like some locales. #330433 #389717
export LANG="C" LC_ALL="C"
- eautoreconf
-}
-
-src_configure() {
local cacao_config config hotspot_port jamvm_config use_cacao use_jamvm use_zero zero_config
local vm=$(java-pkg_get-current-vm)