aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/breeze-plymouth/Manifest1
-rw-r--r--kde-plasma/breeze-plymouth/breeze-plymouth-5.22.90.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/kde-plasma/breeze-plymouth/Manifest b/kde-plasma/breeze-plymouth/Manifest
new file mode 100644
index 0000000000..be4b393604
--- /dev/null
+++ b/kde-plasma/breeze-plymouth/Manifest
@@ -0,0 +1 @@
+DIST breeze-plymouth-5.22.90.tar.xz 110536 BLAKE2B 1c79cfa4e9bf6497b772740197e8061aaec57aa116bef3f5bc59911fb12630ae6e596cb5d81746cec16151f4524f689f6d4c55f1420f20994348c657d4ad8434 SHA512 eeb3020608c62cdc5ce301e567c677631313c3c34dfb0ae9d8d2eef074dd5430785f8e548cd48fdfdfccea34dc531d51177660a0c9daa16da6aee5a2971b8623
diff --git a/kde-plasma/breeze-plymouth/breeze-plymouth-5.22.90.ebuild b/kde-plasma/breeze-plymouth/breeze-plymouth-5.22.90.ebuild
new file mode 100644
index 0000000000..ec9a8ea497
--- /dev/null
+++ b/kde-plasma/breeze-plymouth/breeze-plymouth-5.22.90.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+inherit cmake kde.org
+
+DESCRIPTION="Breeze theme for Plymouth"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND=">=kde-frameworks/extra-cmake-modules-${KFMIN}:5"
+DEPEND="sys-boot/plymouth"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISTRO_NAME="Gentoo Linux"
+ -DDISTRO_VERSION=
+ )
+
+ cmake_src_configure
+}