aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/okular/okular-16.12.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/kde-apps/okular/okular-16.12.1.ebuild b/kde-apps/okular/okular-16.12.1.ebuild
index 83f289c5dd..75719f0669 100644
--- a/kde-apps/okular/okular-16.12.1.ebuild
+++ b/kde-apps/okular/okular-16.12.1.ebuild
@@ -11,8 +11,8 @@ inherit kde5
DESCRIPTION="Universal document viewer based on KDE Frameworks"
HOMEPAGE="https://okular.kde.org https://www.kde.org/applications/graphics/okular"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="chm crypt djvu ebook +jpeg mobi +pdf +postscript speech +tiff"
+KEYWORDS=""
+IUSE="chm crypt djvu ebook +jpeg mobi mobile +pdf +postscript speech +tiff"
DEPEND="
$(add_frameworks_dep kactivities)
@@ -52,13 +52,16 @@ DEPEND="
speech? ( $(add_qt_dep qtspeech) )
tiff? ( media-libs/tiff:0 )
"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ mobile? ( dev-libs/kirigami:1 )
+"
# bug 603116
RESTRICT+=" test"
src_prepare() {
kde5_src_prepare
+ use mobile || cmake_comment_add_subdirectory mobile
use test || cmake_comment_add_subdirectory conf/autotests
}