aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/cmake/cmake-2.8.10.2-r2.ebuild1
-rw-r--r--dev-util/cmake/files/cmake-2.8.10.2-FindPythonInterp.patch22
-rw-r--r--dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch2
3 files changed, 24 insertions, 1 deletions
diff --git a/dev-util/cmake/cmake-2.8.10.2-r2.ebuild b/dev-util/cmake/cmake-2.8.10.2-r2.ebuild
index 7c50be3eda..b455710d32 100644
--- a/dev-util/cmake/cmake-2.8.10.2-r2.ebuild
+++ b/dev-util/cmake/cmake-2.8.10.2-r2.ebuild
@@ -55,6 +55,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.8.10-desktop.patch
"${FILESDIR}"/${PN}-2.8.10-libform.patch
"${FILESDIR}"/${PN}-2.8.10-more-no_host_paths.patch
+ "${FILESDIR}"/${PN}-2.8.10.2-FindPythonInterp.patch
"${FILESDIR}"/${PN}-2.8.10.2-FindPythonLibs.patch
"${FILESDIR}"/${PN}-2.8.10.2-implicit-include.patch
"${FILESDIR}"/${PN}-2.8.10.2-qt5.patch
diff --git a/dev-util/cmake/files/cmake-2.8.10.2-FindPythonInterp.patch b/dev-util/cmake/files/cmake-2.8.10.2-FindPythonInterp.patch
new file mode 100644
index 0000000000..a7e8688ec8
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.10.2-FindPythonInterp.patch
@@ -0,0 +1,22 @@
+--- Modules/FindPythonInterp.cmake
++++ Modules/FindPythonInterp.cmake
+@@ -60,6 +60,10 @@
+
+ list(APPEND _Python_NAMES python)
+
++if (CMAKE_BUILD_TYPE STREQUAL Gentoo)
++ set(_Python_NAMES python)
++endif()
++
+ # Search for the current active python version first
+ find_program(PYTHON_EXECUTABLE NAMES ${_Python_NAMES})
+
+@@ -76,7 +80,7 @@
+ unset(_PYTHON3_VERSIONS)
+
+ # Search for newest python version if python executable isn't found
+-if(NOT PYTHON_EXECUTABLE)
++if(NOT PYTHON_EXECUTABLE AND NOT CMAKE_BUILD_TYPE STREQUAL Gentoo)
+ foreach(_CURRENT_VERSION ${_Python_VERSIONS})
+ set(_Python_NAMES python${_CURRENT_VERSION})
+ if(WIN32)
diff --git a/dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch b/dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch
index 53b395c35b..80cc4d3887 100644
--- a/dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch
+++ b/dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch
@@ -6,7 +6,7 @@ index bffa9fb..8fc90ee 100644
${_PYTHON_FIND_OTHER_VERSIONS}
)
-+# Gentoo portage requries that you use exactly the given python version
++# Gentoo portage requires that you use exactly the given python version
+if (CMAKE_BUILD_TYPE STREQUAL Gentoo)
+ execute_process(COMMAND python -c "import sys; sys.stdout.write('.'.join([str(x) for x in sys.version_info[:2]]))"
+ OUTPUT_VARIABLE _Gentoo_Python_VERSION)