aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-browser-integration/Manifest1
-rw-r--r--kde-plasma/plasma-browser-integration/plasma-browser-integration-5.22.90.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/plasma-browser-integration/Manifest b/kde-plasma/plasma-browser-integration/Manifest
new file mode 100644
index 0000000000..745e9b3ada
--- /dev/null
+++ b/kde-plasma/plasma-browser-integration/Manifest
@@ -0,0 +1 @@
+DIST plasma-browser-integration-5.22.90.tar.xz 219512 BLAKE2B 86231665eceff465dd02bb8d5b6878aefcbd72cf7b5cdd52bc4b1e695a4b64a1da33bb00a84fe7e08f62d948565f4619bef9238e488e775bad690a219b8edad7 SHA512 63407dad52741b8646aab7a666029d1c3cf6b782cd8390306ee2023577b364056ba58f81de61d93463a183167120d7cba887dbcae20da9ee0c340bebc0dd0862
diff --git a/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.22.90.ebuild b/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.22.90.ebuild
new file mode 100644
index 0000000000..83cbeb1035
--- /dev/null
+++ b/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.22.90.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Integrate Chrome/Firefox better into Plasma through browser extensions"
+HOMEPAGE+=" https://community.kde.org/Plasma/Browser_Integration"
+
+LICENSE="GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kfilemetadata-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-frameworks/purpose-${KFMIN}:5
+ >=kde-plasma/plasma-workspace-${PVCUT}:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMOZILLA_DIR="${EPREFIX}/usr/$(get_libdir)/mozilla"
+ )
+
+ ecm_src_configure
+}