aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/csync/csync-0.60.2.ebuild9
-rw-r--r--net-misc/csync/files/csync-0.60.2-removebadtest.patch9
2 files changed, 11 insertions, 7 deletions
diff --git a/net-misc/csync/csync-0.60.2.ebuild b/net-misc/csync/csync-0.60.2.ebuild
index 4e9f5b8990..d94e4090cb 100644
--- a/net-misc/csync/csync-0.60.2.ebuild
+++ b/net-misc/csync/csync-0.60.2.ebuild
@@ -27,13 +27,12 @@ RDEPEND="
DEPEND="${DEPEND}
app-text/asciidoc
doc? ( app-doc/doxygen )
+ test? ( dev-util/cmocka )
"
-RESTRICT="test"
-#until we have an ebuild for cmocka at least
-
PATCHES=(
"${FILESDIR}/${PN}-0.60.2-automagicness.patch"
+ "${FILESDIR}/${PN}-0.60.2-removebadtest.patch"
)
S="${WORKDIR}/o${P}"
@@ -47,10 +46,6 @@ src_prepare() {
CMakeLists.txt || die
fi
- # punt owncloud test as it uses weird cmocka framework
- sed -i \
- -e 's:add_subdirectory(ownCloud)::' \
- tests/CMakeLists.txt || die
# proper docdir
sed -i \
-e "s:/doc/ocsync:/doc/${PF}:" \
diff --git a/net-misc/csync/files/csync-0.60.2-removebadtest.patch b/net-misc/csync/files/csync-0.60.2-removebadtest.patch
new file mode 100644
index 0000000000..5b8a3a6e96
--- /dev/null
+++ b/net-misc/csync/files/csync-0.60.2-removebadtest.patch
@@ -0,0 +1,9 @@
+--- a/tests/vio_tests/check_vio.c
++++ b/tests/vio_tests/check_vio.c
+@@ -505,7 +505,6 @@
+ unit_test_setup_teardown(check_csync_vio_mkdirs_some_exist, setup_dir, teardown),
+ unit_test_setup_teardown(check_csync_vio_rmdir, setup, teardown),
+ unit_test_setup_teardown(check_csync_vio_opendir, setup_dir, teardown),
+- unit_test_setup_teardown(check_csync_vio_opendir_perm, setup, teardown),
+ unit_test(check_csync_vio_closedir_null),
+ unit_test_setup_teardown(check_csync_vio_readdir, setup_dir, teardown),