aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevan Franchini <twitch153@gentoo.org>2015-10-16 13:39:53 -0400
committerDevan Franchini <twitch153@gentoo.org>2015-10-16 13:39:53 -0400
commit270a91aa1597b6637f297cba5dc8a334d9d59c58 (patch)
tree05563006c8aa888f3662cbcb53763a56c09b1e27
parentImproved grammar (diff)
downloadlayman-270a91aa1597b6637f297cba5dc8a334d9d59c58.tar.gz
layman-270a91aa1597b6637f297cba5dc8a334d9d59c58.tar.bz2
layman-270a91aa1597b6637f297cba5dc8a334d9d59c58.zip
setup.py: Makes sqlite database backend option
-rwxr-xr-xsetup.py15
1 files changed, 11 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index a0343f9..d8f468d 100755
--- a/setup.py
+++ b/setup.py
@@ -28,6 +28,10 @@ SELECTABLE = {
use_defaults = ' '.join(list(SELECTABLE))
+DB_PLUGINS = {
+ 'sqlite': 'layman.db_modules.sqlite_db'
+}
+
SYNC_PLUGINS = {
'sync-plugin-portage': 'portage.sync.modules.laymansync',
}
@@ -46,11 +50,14 @@ for mod in sorted(SELECTABLE):
if mod in USE:
modules.append('layman.overlays.modules.%s' % SELECTABLE[mod])
+for plugin in sorted(DB_PLUGINS):
+ if plugin in USE:
+ modules.append(DB_PLUGINS[plugin]
+
for plugin in sorted(SYNC_PLUGINS):
if plugin in USE:
modules.append(SYNC_PLUGINS[plugin])
-
class setup_plugins(Command):
""" Perform moves for the plugins into base namespace
so they can be installed. """
@@ -84,9 +91,9 @@ setup(
'http://git.overlays.gentoo.org/gitweb/?p=proj/layman.git;a=summary',
packages = ['layman', 'layman.config_modules',
'layman.config_modules.makeconf', 'layman.config_modules.reposconf',
- 'layman.db_modules', 'layman.db_modules.json_db',
- 'layman.db_modules.sqlite_db', 'layman.db_modules.xml_db',
- 'layman.overlays', 'layman.overlays.modules',
+ 'layman.db_modules', 'layman.db_modules.json_db',
+ 'layman.db_modules.xml_db', 'layman.overlays',
+ 'layman.overlays.modules',
] + modules,
scripts = ['bin/layman', 'bin/layman-overlay-maker',
'bin/layman-mounter', 'bin/layman-updater'],