aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-08-13 18:09:12 -0600
committerEric Blake <eblake@redhat.com>2012-08-24 09:51:08 -0600
commit6478ec1673a2b405353df898db70181e122f721e (patch)
tree610a9dc35cb8c0a828f86ff6cbcd093b97b48bff /src/Makefile.am
parentsnapshot: make virDomainSnapshotObjList opaque (diff)
downloadlibvirt-6478ec1673a2b405353df898db70181e122f721e.tar.gz
libvirt-6478ec1673a2b405353df898db70181e122f721e.tar.bz2
libvirt-6478ec1673a2b405353df898db70181e122f721e.zip
snapshot: split snapshot conf code into own file
This has several benefits: 1. Future snapshot-related code has a definite place to go (and I _will_ be adding some) 2. Snapshot errors now use the VIR_FROM_DOMAIN_SNAPSHOT error classification, which has been underutilized (previously only in libvirt.c) * src/conf/domain_conf.h, domain_conf.c: Split... * src/conf/snapshot_conf.h, snapshot_conf.c: ...into new files. * src/Makefile.am (DOMAIN_CONF_SOURCES): Build new files. * po/POTFILES.in: Mark new file for translation. * src/vbox/vbox_tmpl.c: Update caller. * src/esx/esx_driver.c: Likewise. * src/qemu/qemu_command.c: Likewise. * src/qemu/qemu_domain.h: Likewise.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 207457125..995e032d5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -153,7 +153,8 @@ DOMAIN_CONF_SOURCES = \
conf/capabilities.c conf/capabilities.h \
conf/domain_conf.c conf/domain_conf.h \
conf/domain_audit.c conf/domain_audit.h \
- conf/domain_nwfilter.c conf/domain_nwfilter.h
+ conf/domain_nwfilter.c conf/domain_nwfilter.h \
+ conf/snapshot_conf.c conf/snapshot_conf.h
DOMAIN_EVENT_SOURCES = \
conf/domain_event.c conf/domain_event.h