aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Guryanov <dguryanov@parallels.com>2012-07-31 22:56:05 +0400
committerDaniel Veillard <veillard@redhat.com>2012-08-01 11:44:26 +0800
commitcafc26ff5f401c31b5f9d6d60a4f8d54cfce27ca (patch)
tree5ab0b0ae62dbf79b7839f6e654e7b7dac8b40fc6 /src/Makefile.am
parentqemu: syntax fix (diff)
downloadlibvirt-cafc26ff5f401c31b5f9d6d60a4f8d54cfce27ca.tar.gz
libvirt-cafc26ff5f401c31b5f9d6d60a4f8d54cfce27ca.tar.bz2
libvirt-cafc26ff5f401c31b5f9d6d60a4f8d54cfce27ca.zip
parallels: add driver skeleton
Parallels Cloud Server is a cloud-ready virtualization solution that allows users to simultaneously run multiple virtual machines and containers on the same physical server. More information can be found here: http://www.parallels.com/products/pcs/ Also beta version of Parallels Cloud Server can be downloaded there. Signed-off-by: Dmitry Guryanov <dguryanov@parallels.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3f6c7f521..efab4e41e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -529,6 +529,10 @@ HYPERV_DRIVER_EXTRA_DIST = \
hyperv/hyperv_wmi_generator.py \
$(HYPERV_DRIVER_GENERATED)
+PARALLELS_DRIVER_SOURCES = \
+ parallels/parallels_driver.h \
+ parallels/parallels_driver.c
+
NETWORK_DRIVER_SOURCES = \
network/bridge_driver.h network/bridge_driver.c
@@ -967,6 +971,14 @@ libvirt_driver_hyperv_la_LIBADD = $(OPENWSMAN_LIBS)
libvirt_driver_hyperv_la_SOURCES = $(HYPERV_DRIVER_SOURCES)
endif
+if WITH_PARALLELS
+noinst_LTLIBRARIES += libvirt_driver_parallels.la
+libvirt_la_BUILT_LIBADD += libvirt_driver_parallels.la
+libvirt_driver_parallels_la_CFLAGS = \
+ -I$(top_srcdir)/src/conf $(AM_CFLAGS)
+libvirt_driver_parallels_la_SOURCES = $(PARALLELS_DRIVER_SOURCES)
+endif
+
if WITH_NETWORK
noinst_LTLIBRARIES += libvirt_driver_network_impl.la
libvirt_driver_network_la_SOURCES =
@@ -1180,6 +1192,7 @@ EXTRA_DIST += \
$(ESX_DRIVER_EXTRA_DIST) \
$(HYPERV_DRIVER_SOURCES) \
$(HYPERV_DRIVER_EXTRA_DIST) \
+ $(PARALLELS_DRIVER_SOURCES) \
$(NETWORK_DRIVER_SOURCES) \
$(INTERFACE_DRIVER_SOURCES) \
$(STORAGE_DRIVER_SOURCES) \