aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-09-04 10:57:25 -0600
committerEric Blake <eblake@redhat.com>2012-09-04 10:57:25 -0600
commitd74e5a4dfc434d3a1d01856d013a7f50d910fa95 (patch)
tree08c831433c3d0391a37fc519d3ac55c7a6cf9dfa /src/Makefile.am
parentInclude an extra header needed for OpenBSD. (diff)
downloadlibvirt-d74e5a4dfc434d3a1d01856d013a7f50d910fa95.tar.gz
libvirt-d74e5a4dfc434d3a1d01856d013a7f50d910fa95.tar.bz2
libvirt-d74e5a4dfc434d3a1d01856d013a7f50d910fa95.zip
build: use correct libraries for clock_gettime
On OpenBSD, clock_gettime() exists in libc rather than librt, and blindly linking with -lrt made the build fail. Gnulib already did the work for determining which libraries to use, so we should reuse that work rather than doing it ourselves. * bootstrap.conf (gnulib_modules): Pull in clock-time. * configure.ac (RT_LIBS): Drop. * src/Makefile.am (libvirt_util_la_LIBADD): Use gnulib variable instead. * src/util/virtime.c (includes): Simplify.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 95e1bea16..39adeac08 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -668,7 +668,7 @@ libvirt_util_la_CFLAGS = $(CAPNG_CFLAGS) $(YAJL_CFLAGS) $(LIBNL_CFLAGS) \
$(DBUS_CFLAGS) $(LDEXP_LIBM)
libvirt_util_la_LIBADD = $(CAPNG_LIBS) $(YAJL_LIBS) $(LIBNL_LIBS) \
$(THREAD_LIBS) $(AUDIT_LIBS) $(DEVMAPPER_LIBS) \
- $(RT_LIBS) $(DBUS_LIBS) $(MSCOM_LIBS) $(LIBXML_LIBS)
+ $(LIB_CLOCK_GETTIME) $(DBUS_LIBS) $(MSCOM_LIBS) $(LIBXML_LIBS)
noinst_LTLIBRARIES += libvirt_conf.la