summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2008-11-25 15:48:11 +0000
committerDaniel Veillard <veillard@redhat.com>2008-11-25 15:48:11 +0000
commit517ff04bec83abbe509251c8a1241b92b4fe2afd (patch)
tree717e43df3424057f445b43132d107895c1314379 /src
parentconfigure.in: avoid the following diagnostic when running ../configure ... (diff)
downloadlibvirt-517ff04bec83abbe509251c8a1241b92b4fe2afd.tar.gz
libvirt-517ff04bec83abbe509251c8a1241b92b4fe2afd.tar.bz2
libvirt-517ff04bec83abbe509251c8a1241b92b4fe2afd.zip
Release of 0.5.0v0.5.0LIBVIRT_0_5_0
* configure.in docs/* NEWS: release of 0.5.0 * po/*: updated from the translators and merged * docs/apibuild.py src/libvirt.c: avoid some warnings at doc generation time daniel
Diffstat (limited to 'src')
-rw-r--r--src/libvirt.c27
1 files changed, 20 insertions, 7 deletions
diff --git a/src/libvirt.c b/src/libvirt.c
index 6195a4e77..926c4a55c 100644
--- a/src/libvirt.c
+++ b/src/libvirt.c
@@ -1046,7 +1046,8 @@ virConnectClose(virConnectPtr conn)
return (0);
}
-/* Not for public use. This function is part of the internal
+/*
+ * Not for public use. This function is part of the internal
* implementation of driver features in the remote case.
*/
int
@@ -2384,7 +2385,8 @@ virDomainMigrate (virDomainPtr domain,
return ddomain;
}
-/* Not for public use. This function is part of the internal
+/*
+ * Not for public use. This function is part of the internal
* implementation of migration in the remote case.
*/
int
@@ -2413,7 +2415,8 @@ virDomainMigratePrepare (virConnectPtr dconn,
return -1;
}
-/* Not for public use. This function is part of the internal
+/*
+ * Not for public use. This function is part of the internal
* implementation of migration in the remote case.
*/
int
@@ -2443,7 +2446,8 @@ virDomainMigratePerform (virDomainPtr domain,
return -1;
}
-/* Not for public use. This function is part of the internal
+/*
+ * Not for public use. This function is part of the internal
* implementation of migration in the remote case.
*/
virDomainPtr
@@ -2471,7 +2475,8 @@ virDomainMigrateFinish (virConnectPtr dconn,
}
-/* Not for public use. This function is part of the internal
+/*
+ * Not for public use. This function is part of the internal
* implementation of migration in the remote case.
*/
int
@@ -2502,7 +2507,8 @@ virDomainMigratePrepare2 (virConnectPtr dconn,
return -1;
}
-/* Not for public use. This function is part of the internal
+/*
+ * Not for public use. This function is part of the internal
* implementation of migration in the remote case.
*/
virDomainPtr
@@ -5629,7 +5635,9 @@ char *virNodeDeviceGetXMLDesc(virNodeDevicePtr dev, unsigned int flags)
* virNodeDeviceGetName:
* @dev: the device
*
- * Returns the device name.
+ * Just return the device name
+ *
+ * Returns the device name or NULL in case of error
*/
const char *virNodeDeviceGetName(virNodeDevicePtr dev)
{
@@ -5647,6 +5655,8 @@ const char *virNodeDeviceGetName(virNodeDevicePtr dev)
* virNodeDeviceGetParent:
* @dev: the device
*
+ * Accessor for the parent of the device
+ *
* Returns the name of the device's parent, or NULL if the
* device has no parent.
*/
@@ -5670,6 +5680,8 @@ const char *virNodeDeviceGetParent(virNodeDevicePtr dev)
* virNodeDeviceNumOfCaps:
* @dev: the device
*
+ * Accessor for the number of capabilities supported by the device.
+ *
* Returns the number of capabilities supported by the device.
*/
int virNodeDeviceNumOfCaps(virNodeDevicePtr dev)
@@ -5750,6 +5762,7 @@ int virNodeDeviceFree(virNodeDevicePtr dev)
* @conn: pointer to the connection
* @cb: callback to the function handling domain events
* @opaque: opaque data to pass on to the callback
+ * @freecb: optional function to deallocate opaque when not used anymore
*
* Adds a Domain Event Callback.
* Registering for a domain callback will enable delivery of the events