aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-07-19 12:32:58 -0600
committerEric Blake <eblake@redhat.com>2011-07-21 10:34:51 -0600
commit8e22e08935655e5b39873bc8e1aa41d2ef2f8487 (patch)
tree842771f0ff7afff72077720ada521d40e63c8f08 /tests/commandhelper.c
parentcommand: avoid leaking fds across fork (diff)
downloadlibvirt-8e22e08935655e5b39873bc8e1aa41d2ef2f8487.tar.gz
libvirt-8e22e08935655e5b39873bc8e1aa41d2ef2f8487.tar.bz2
libvirt-8e22e08935655e5b39873bc8e1aa41d2ef2f8487.zip
build: rename files.h to virfile.h
In preparation for a future patch adding new virFile APIs. * src/util/files.h, src/util/files.c: Move... * src/util/virfile.h, src/util/virfile.c: ...here, and rename functions to virFile prefix. Macro names are intentionally left alone. * *.c: All '#include "files.h"' uses changed. * src/Makefile.am (UTIL_SOURCES): Reflect rename. * cfg.mk (exclude_file_name_regexp--sc_prohibit_close): Likewise. * src/libvirt_private.syms: Likewise. * docs/hacking.html.in: Likewise. * HACKING: Regenerate.
Diffstat (limited to 'tests/commandhelper.c')
-rw-r--r--tests/commandhelper.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/commandhelper.c b/tests/commandhelper.c
index d60d50581..cba208a20 100644
--- a/tests/commandhelper.c
+++ b/tests/commandhelper.c
@@ -29,7 +29,7 @@
#include "internal.h"
#include "util.h"
#include "memory.h"
-#include "files.h"
+#include "virfile.h"
static int envsort(const void *a, const void *b) {