summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2016-11-30 23:09:36 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2016-11-30 23:09:36 +0100
commit16fc2b4a0e409ef06f442e038a5705501ea20565 (patch)
tree55c87ccd6b2696a8f30fcd7b567595dde18cc4de
parentdev-lisp/kr: Updates manifest (diff)
downloadlisp-16fc2b4a.tar.gz
lisp-16fc2b4a.tar.bz2
lisp-16fc2b4a.zip
dev-lisp/cl-store: Updates header, EAPI and description
-rw-r--r--dev-lisp/cl-store/Manifest4
-rw-r--r--dev-lisp/cl-store/cl-store-0.8.10.ebuild7
-rw-r--r--dev-lisp/cl-store/cl-store-9999.ebuild18
3 files changed, 14 insertions, 15 deletions
diff --git a/dev-lisp/cl-store/Manifest b/dev-lisp/cl-store/Manifest
index ed268a88..02dbdfb8 100644
--- a/dev-lisp/cl-store/Manifest
+++ b/dev-lisp/cl-store/Manifest
@@ -1,3 +1,3 @@
DIST cl-store_0.8.10.tgz 59768 SHA256 816db0579d571301dd48890d243158ee66fb48a5a46987c46ef155065b124396 SHA512 222953ff402dd9aba7c9b86d33e50a59035f4eebedb8b28df3d921925758206aa288616552bbd6592411ab24b478deb7427b538150330f0f45f28c0eed6256e9 WHIRLPOOL 8254befd8c9c6af5fa8d2b79dddc09774f33d472f1323135b1dbe9555bafd8b563531fe2d3454e3d67183e6ec2faa9051785362e6b01400c1a82f604d1abb6ea
-EBUILD cl-store-0.8.10.ebuild 1019 SHA256 aa5791a68b17613635636f8c51dde1618a18da37b2c830eb555f18ee8639ca9c SHA512 170216aa238917f4fe1a0dc696a5289e9baa116f8fd65ec23a3441ba2d56e5ddd04e302485edbf966e2152ca8303c4f888fa3e51155328399474e2de87072ea9 WHIRLPOOL 49662fbc6e917988b96969c13fe2b6ad8a5c40ff7716fff5d82721e7d43f9d06e6774d8fa66b639b90944e0912957f2bfb311faccd1d3ee2825be046092e9be1
-EBUILD cl-store-9999.ebuild 1024 SHA256 a0c664c66859b838fda1efd878c21458e43ac1dd0ec053f8637e73ba333a2a5e SHA512 8a7f1d996dec0d58a6b626dbd56f29d333439c7415e23d0145d2601258fabe9e8b3a3449ffcca9aac789e9b20953cb1e8d46d96eb8fd0780bfc9358603f92087 WHIRLPOOL 593cb32adea41adb301b27f7608829424cc1ca1b0b39554188136d833a53de058f2d4fa628108f83c2baf4860946b24e32232e4b36a30bb85357abc91af992c5
+EBUILD cl-store-0.8.10.ebuild 1001 SHA256 86be5a235e51b5a47c7d27279b932a765556aa47464f7ccea7933aeea012916c SHA512 bac5bea5ba03d596f5dc5e0e78fceb535eb2aadf6e63ed2c74d8990886d0ef20fc2702665e0a450c2e9ca5328f39b6e58ff7848c4aaf8cd2c051701a1d06985b WHIRLPOOL 9d998193f1ed1906b424db2f6418c6302f3ff2e8fff5810d7e34a408dde9564a56bc8d1e6369a8db1596c110fcadfa498df96d830f2fa4283ad9c556598d3bc1
+EBUILD cl-store-9999.ebuild 899 SHA256 da38812a815699e51f10654fc01de3e756588a7a21752e8dcc9e21804b8ed64c SHA512 352dbc454584acab7042068fb3d7be0a8bee50d36db3c1fe68864c333c53f627986a2999c265145e442b68e71c3aea3f75fb091a010a388979e908ceca2139a1 WHIRLPOOL bf66372e9c5174e6a34928a200b4719e1cee3b43eedaefcd30ca80778558765697a4cf83461b247ebd350ad4fa4c7ae2889da6424bee9336b979191f974b5529
diff --git a/dev-lisp/cl-store/cl-store-0.8.10.ebuild b/dev-lisp/cl-store/cl-store-0.8.10.ebuild
index 17fbae5f..21bda5d9 100644
--- a/dev-lisp/cl-store/cl-store-0.8.10.ebuild
+++ b/dev-lisp/cl-store/cl-store-0.8.10.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
EAPI=2
+
inherit common-lisp-2 eutils
MY_P=${PN}_${PV}
-DESCRIPTION="CL-STORE is a Common Lisp library for serializing and deserializing Common Lisp objects."
+DESCRIPTION="Library for serializing and deserializing Common Lisp objects from streams."
HOMEPAGE="http://common-lisp.net/project/cl-store/"
SRC_URI="http://common-lisp.net/project/${PN}/files/${MY_P}.tgz"
diff --git a/dev-lisp/cl-store/cl-store-9999.ebuild b/dev-lisp/cl-store/cl-store-9999.ebuild
index ee5c3efa..564342e3 100644
--- a/dev-lisp/cl-store/cl-store-9999.ebuild
+++ b/dev-lisp/cl-store/cl-store-9999.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
-EAPI=5
+EAPI=6
-inherit common-lisp-3 git-2
+inherit common-lisp-3 git-r3
-DESCRIPTION="CL-STORE is a Common Lisp library for serializing and deserializing Common Lisp objects."
+DESCRIPTION="Library for serializing and deserializing Common Lisp objects from streams."
HOMEPAGE="http://common-lisp.net/project/cl-store"
EGIT_REPO_URI="https://github.com/skypher/${PN}.git"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="doc"
DEPEND="sys-apps/texinfo
@@ -25,10 +24,10 @@ src_prepare() {
src_compile() {
cd doc || die
- makeinfo ${PN}.texi -o ${PN}.info || die "Cannot build info docs"
+ makeinfo ${PN}.texi -o ${PN}.info || die
if use doc ; then
VARTEXFONTS="${T}"/fonts \
- texi2pdf ${PN}.texi -o ${PN}.pdf || die "Cannot build PDF docs"
+ texi2pdf ${PN}.texi -o ${PN}.pdf || die
fi
}
@@ -37,6 +36,5 @@ src_install() {
acl allegrocl clisp cmucl ecl lispworks openmcl sbcl
common-lisp-install-asdf
doinfo doc/${PN}.info
- use doc && dodoc doc/${PN}.pdf
- use doc && dohtml doc/{index.html,style.css}
+ use doc && dodoc doc/{index.html,style.css,${PN}.pdf}
}