summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2016-04-30 12:50:55 +0600
committerVadim A. Misbakh-Soloviov <git@mva.name>2016-04-30 12:50:55 +0600
commit361c448ef32972f43a119fd733ec820754ae3c9b (patch)
tree502e37fd27cb81d27782a4174c11c73d2144563b
parentluadoc: upstream renamed readme (diff)
downloadlua-361c448ef32972f43a119fd733ec820754ae3c9b.tar.gz
lua-361c448ef32972f43a119fd733ec820754ae3c9b.tar.bz2
lua-361c448ef32972f43a119fd733ec820754ae3c9b.zip
luajit: change src_prep patching according makefile changes
-rw-r--r--dev-lang/luajit/luajit-2.1.9999.ebuild31
1 files changed, 6 insertions, 25 deletions
diff --git a/dev-lang/luajit/luajit-2.1.9999.ebuild b/dev-lang/luajit/luajit-2.1.9999.ebuild
index 68a2986..4a69cf2 100644
--- a/dev-lang/luajit/luajit-2.1.9999.ebuild
+++ b/dev-lang/luajit/luajit-2.1.9999.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: This ebuild is from Lua overlay; Bumped by mva; $
-EAPI="5"
+EAPI="6"
-inherit base eutils multilib multilib-minimal portability pax-utils toolchain-funcs versionator flag-o-matic check-reqs git-r3
+inherit eutils multilib multilib-minimal portability pax-utils toolchain-funcs versionator flag-o-matic check-reqs git-r3
DESCRIPTION="Just-In-Time Compiler for the Lua programming language"
HOMEPAGE="http://luajit.org/"
@@ -30,7 +30,7 @@ PDEPEND="
virtual/lua[luajit]
"
-HTML_DOCS=( "doc/" )
+HTML_DOCS=( "doc/." )
MULTILIB_WRAPPED_HEADERS=(
/usr/include/luajit-${SLOT}/luaconf.h
@@ -54,45 +54,26 @@ pkg_setup() {
src_prepare(){
# fixing prefix and version
-# sed -r \
-# -e 's|^(VERSION)=.*|\1=$(MAJVER).$(MINVER)|' \
-# -e 's|\$\(MAJVER\)\.\$\(MINVER\)\.\$\(RELVER\)|$(VERSION)|' \
-# -e 's|^(FILE_MAN)=.*|\1=${PN}-$(VERSION).1|' \
-# -e 's|^(INSTALL_PCNAME)=.*|\1=${PN}-$(VERSION).pc|' \
-# -e 's|^(INSTALL_SOSHORT)=.*|\1=lib${PN}-${SLOT}.so|' \
-# -e 's|^(INSTALL_ANAME)=.*|\1=lib${PN}-${SLOT}.a|' \
-# -e 's|^(INSTALL_SONAME)=.*|\1=lib${PN}-${SLOT}.so.${PV}|' \
-# -e 's|( PREFIX)=.*|\1=/usr|' \
-# -e '/\$\(SYMLINK\)\ \$\(INSTALL_TNAME\)\ \$\(INSTALL_TSYM\)/d' \
-# -i Makefile || die "failed to fix prefix in Makefile"
-
sed -r \
-e 's|^(VERSION)=.*|\1=${PV}|' \
- -e 's|\$\(MAJVER\)\.\$\(MINVER\)\.\$\(RELVER\)|$(VERSION)|' \
+ -e 's|^(INSTALL_SONAME)=.*|\1=$(INSTALL_SOSHORT1).$(VERSION)|' \
-e 's|^(INSTALL_PCNAME)=.*|\1=${P}.pc|' \
-e 's|( PREFIX)=.*|\1=/usr|' \
-e 's|^(FILE_MAN)=.*|\1=${P}.1|' \
-i Makefile || die "failed to fix prefix in Makefile"
-# sed -r \
-# -e 's|^(libname=.*-)\$\{abiver\}|\1${majver}.${minver}|' \
-# -i "etc/${PN}.pc" || die "Failed to slottify"
-
-# sed -r \
-# -e 's|^(TARGET_SONAME)=.*|\1=lib${PN}-${SLOT}.so.${PV}|' \
-# -i src/Makefile || die "Failed to slottify"
-
sed -r \
-e 's|^(#define LUA_LJDIR).*|\1 "/'${P}'/"|' \
-i src/luaconf.h || die "Failed to slotify"
use debug && (
sed -r \
- -e 's/#(CCDEBUG= -g)/\1 -ggdb/' \
+ -e 's/#(CCDEBUG= -g)/\1 -ggdb -O0/' \
-i src/Makefile || die "Failed to enable debug"
)
mv "${S}"/etc/${PN}.1 "${S}"/etc/${P}.1
+ eapply_user
multilib_copy_sources
}