summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/portage/portage-2.3.6-r1.ebuild')
-rw-r--r--sys-apps/portage/portage-2.3.6-r1.ebuild275
1 files changed, 0 insertions, 275 deletions
diff --git a/sys-apps/portage/portage-2.3.6-r1.ebuild b/sys-apps/portage/portage-2.3.6-r1.ebuild
deleted file mode 100644
index 97dcf36b0..000000000
--- a/sys-apps/portage/portage-2.3.6-r1.ebuild
+++ /dev/null
@@ -1,275 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=(
- pypy
- python3_4 python3_5 python3_6
- python2_7
-)
-PYTHON_REQ_USE='bzip2(+),threads(+)'
-
-inherit distutils-r1 git-2 multilib
-
-EGIT_REPO_URI="git://anongit.gentoo.org/proj/portage.git"
-EGIT_BRANCH="multilib"
-EGIT_COMMIT="c7938eca955a49b2fc7c7ce714bf0ab6d1a53c7b"
-DESCRIPTION="Portage is the package management and distribution system for Gentoo"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-SLOT="0"
-IUSE="build doc epydoc +ipc linguas_ru +native-extensions selinux xattr"
-
-DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
- >=app-arch/tar-1.27
- dev-lang/python-exec:2
- >=sys-apps/sed-4.0.5 sys-devel/patch
- doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
- epydoc? ( >=dev-python/epydoc-2.0[$(python_gen_usedep 'python2*')] )
- >=sys-apps/abi-wrapper-1.0-r6"
-# Require sandbox-2.2 for bug #288863.
-# For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
-# quite slow, so it's not considered in the dependencies as an alternative to
-# to python-3.3 / pyxattr. Also, xattr support is only tested with Linux, so
-# for now, don't pull in xattr deps for other kernels.
-# For whirlpool hash, require python[ssl] (bug #425046).
-# For compgen, require bash[readline] (bug #445576).
-RDEPEND="
- >=app-arch/tar-1.27
- dev-lang/python-exec:2
- !build? (
- >=sys-apps/sed-4.0.5
- app-shells/bash:0[readline]
- >=app-admin/eselect-1.2
- )
- elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
- elibc_glibc? ( >=sys-apps/sandbox-2.2 )
- elibc_musl? ( >=sys-apps/sandbox-2.2 )
- elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
- >=app-misc/pax-utils-0.1.17
- selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
- xattr? ( kernel_linux? (
- >=sys-apps/install-xattr-0.3
- $(python_gen_cond_dep 'dev-python/pyxattr[${PYTHON_USEDEP}]' \
- python2_7 pypy)
- ) )
- !<app-admin/logrotate-3.8.0
- >=sys-apps/abi-wrapper-1.0-r6"
-PDEPEND="
- !build? (
- >=net-misc/rsync-2.6.4
- userland_GNU? ( >=sys-apps/coreutils-6.4 )
- )"
-# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
-# NOTE: FEATURES=installsources requires debugedit and rsync
-
-REQUIRED_USE="epydoc? ( $(python_gen_useflags 'python2*') )"
-
-pkg_setup() {
- use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
-}
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- if use native-extensions; then
- printf "[build_ext]\nportage-ext-modules=true\n" >> \
- setup.cfg || die
- fi
-
- if ! use ipc ; then
- einfo "Disabling ipc..."
- sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
- -i pym/_emerge/AbstractEbuildProcess.py || \
- die "failed to patch AbstractEbuildProcess.py"
- fi
-
- if use xattr && use kernel_linux ; then
- einfo "Adding FEATURES=xattr to make.globals ..."
- echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
- || die "failed to append to make.globals"
- fi
-
- if [[ -n ${EPREFIX} ]] ; then
- einfo "Setting portage.const.EPREFIX ..."
- sed -e "s|^\(SANDBOX_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/bin/sandbox\"\)|\\1${EPREFIX}\\2|" \
- -e "s|^\(FAKEROOT_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/bin/fakeroot\"\)|\\1${EPREFIX}\\2|" \
- -e "s|^\(BASH_BINARY[[:space:]]*=[[:space:]]*\"\)\(/bin/bash\"\)|\\1${EPREFIX}\\2|" \
- -e "s|^\(MOVE_BINARY[[:space:]]*=[[:space:]]*\"\)\(/bin/mv\"\)|\\1${EPREFIX}\\2|" \
- -e "s|^\(PRELINK_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/sbin/prelink\"\)|\\1${EPREFIX}\\2|" \
- -e "s|^\(EPREFIX[[:space:]]*=[[:space:]]*\"\).*|\\1${EPREFIX}\"|" \
- -i pym/portage/const.py || \
- die "Failed to patch portage.const.EPREFIX"
-
- einfo "Prefixing shebangs ..."
- while read -r -d $'\0' ; do
- local shebang=$(head -n1 "$REPLY")
- if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
- sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "$REPLY" || \
- die "sed failed"
- fi
- done < <(find . -type f -print0)
-
- einfo "Adjusting make.globals ..."
- sed -e "s|\(/usr/portage\)|${EPREFIX}\\1|" \
- -e "s|^\(PORTAGE_TMPDIR=\"\)\(/var/tmp\"\)|\\1${EPREFIX}\\2|" \
- -i cnf/make.globals || die "sed failed"
-
- einfo "Adjusting repos.conf ..."
- sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
- -e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
- -e "s|^\(location = \)\(/usr/portage\)|\\1${EPREFIX}\\2|" \
- -e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
- -i cnf/repos.conf || die "sed failed"
-
- einfo "Adding FEATURES=force-prefix to make.globals ..."
- echo -e '\nFEATURES="${FEATURES} force-prefix"' >> cnf/make.globals \
- || die "failed to append to make.globals"
- fi
-
- cd "${S}/cnf" || die
- if [ -f "make.conf.example.${ARCH}".diff ]; then
- patch make.conf.example "make.conf.example.${ARCH}".diff || \
- die "Failed to patch make.conf.example"
- else
- eerror ""
- eerror "Portage does not have an arch-specific configuration for this arch."
- eerror "Please notify the arch maintainer about this issue. Using generic."
- eerror ""
- fi
-}
-
-python_compile_all() {
- local targets=()
- use doc && targets+=( docbook )
- use epydoc && targets+=( epydoc )
-
- if [[ ${targets[@]} ]]; then
- esetup.py "${targets[@]}"
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install() {
- # Install sbin scripts to bindir for python-exec linking
- # they will be relocated in pkg_preinst()
- distutils-r1_python_install \
- --system-prefix="${EPREFIX}/usr" \
- --bindir="$(python_get_scriptdir)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
- --portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \
- --sbindir="$(python_get_scriptdir)" \
- --sysconfdir="${EPREFIX}/etc" \
- "${@}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- local targets=()
- use doc && targets+=( install_docbook )
- use epydoc && targets+=( install_epydoc )
-
- # install docs
- if [[ ${targets[@]} ]]; then
- esetup.py "${targets[@]}"
- fi
-
- # Due to distutils/python-exec limitations
- # these must be installed to /usr/bin.
- local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld'
- einfo "Moving admin scripts to the correct directory"
- dodir /usr/sbin
- for target in ${sbin_relocations}; do
- einfo "Moving /usr/bin/${target} to /usr/sbin/${target}"
- mv "${ED}usr/bin/${target}" "${ED}usr/sbin/${target}" || die "sbin scripts move failed!"
- done
-}
-
-pkg_preinst() {
- # comment out sanity test until it is fixed to work
- # with the new PORTAGE_PYM_PATH
- #if [[ $ROOT == / ]] ; then
- ## Run some minimal tests as a sanity check.
- #local test_runner=$(find "${ED}" -name runTests)
- #if [[ -n $test_runner && -x $test_runner ]] ; then
- #einfo "Running preinst sanity tests..."
- #"$test_runner" || die "preinst sanity tests failed"
- #fi
- #fi
-
- # elog dir must exist to avoid logrotate error for bug #415911.
- # This code runs in preinst in order to bypass the mapping of
- # portage:portage to root:root which happens after src_install.
- keepdir /var/log/portage/elog
- # This is allowed to fail if the user/group are invalid for prefix users.
- if chown portage:portage "${ED}"var/log/portage{,/elog} 2>/dev/null ; then
- chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog}
- fi
-
- if has_version ">=${CATEGORY}/${PN}-2.3.1" && \
- has_version "<${CATEGORY}/${PN}-2.3.3"; then
- SYNC_DEPTH_UPGRADE=true
- else
- SYNC_DEPTH_UPGRADE=false
- fi
-}
-
-get_ownership() {
- case ${USERLAND} in
- BSD)
- stat -f '%Su:%Sg' "${1}"
- ;;
- *)
- stat -c '%U:%G' "${1}"
- ;;
- esac
-}
-
-new_config_protect() {
- # Generate a ._cfg file even if the target file
- # does not exist, ensuring that the user will
- # notice the config change.
- local basename=${1##*/}
- local dirname=${1%/*}
- local i=0
- while true ; do
- local filename=$(
- echo -n "${dirname}/._cfg"
- printf "%04d" ${i}
- echo -n "_${basename}"
- )
- [[ -e ${filename} ]] || break
- (( i++ ))
- done
- echo "${filename}"
-}
-
-pkg_postinst() {
- if ${SYNC_DEPTH_UPGRADE}; then
- ewarn "Please note that this release no longer respects sync-depth for"
- ewarn "git repositories. There have been too many problems and"
- ewarn "performance issues. See bugs 552814, 559008"
- fi
-
- einfo
- elog "For setup instructions after switching to portage-multilib"
- elog "read doc/portage-multilib-instructions inside the multilib overlay"
- einfo
- elog "The bin/ dir of the overlay has some scripts to switch from lib32"
- elog "to MULTILIB_ABI or to add the default MULTILIB_ABI flags"
-
- einfo ""
- einfo "This release of portage NO LONGER contains the repoman code base."
- einfo "Repoman has its own ebuild and release package."
- einfo "For repoman functionality please emerge app-portage/repoman"
- einfo "Please report any bugs you may encounter."
- einfo ""
-}