aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-08-15 05:26:50 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-08-15 05:26:50 -0400
commite472fdfb3ae93daa4a44111c2df818fbc72dec3c (patch)
treee558df7b1f35cd12a48021bc31cdc19a357efba5
parentdev-lang/go: go support for musl (diff)
downloadmusl-e472fdfb3ae93daa4a44111c2df818fbc72dec3c.tar.gz
musl-e472fdfb3ae93daa4a44111c2df818fbc72dec3c.tar.bz2
musl-e472fdfb3ae93daa4a44111c2df818fbc72dec3c.zip
dev-lang/go-bootstrap: bump to EAPI 6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-lang/go-bootstrap/go-bootstrap-1.4.3.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/dev-lang/go-bootstrap/go-bootstrap-1.4.3.ebuild b/dev-lang/go-bootstrap/go-bootstrap-1.4.3.ebuild
index b58400ef..e52034a5 100644
--- a/dev-lang/go-bootstrap/go-bootstrap-1.4.3.ebuild
+++ b/dev-lang/go-bootstrap/go-bootstrap-1.4.3.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI=5
+EAPI=6
export CTARGET=${CTARGET:-${CHOST}}
@@ -34,13 +33,12 @@ STRIP_MASK="/usr/lib/go1.4/pkg/*.a
S="${WORKDIR}"/go
-src_prepare()
-{
+src_prepare() {
sed -i -e 's/"-Werror",//g' src/cmd/dist/build.c
+ eapply_user
}
-src_compile()
-{
+src_compile() {
export GOROOT_FINAL="${EPREFIX}"/usr/lib/go1.4
export GOROOT="$(pwd)"
export GOBIN="${GOROOT}/bin"
@@ -55,15 +53,13 @@ src_compile()
./make.bash || die "build failed"
}
-src_test()
-{
+src_test() {
cd src
PATH="${GOBIN}:${PATH}" \
./run.bash --no-rebuild --banner || die "tests failed"
}
-src_install()
-{
+src_install() {
dodir /usr/lib/go1.4
exeinto /usr/lib/go1.4/bin
doexe bin/*
@@ -72,8 +68,7 @@ src_install()
fperms -R +x /usr/lib/go1.4/pkg/tool
}
-pkg_postinst()
-{
+pkg_postinst() {
# If the go tool sees a package file timestamped older than a dependancy it
# will rebuild that file. So, in order to stop go from rebuilding lots of
# packages for every build we need to fix the timestamps. The compiler and