summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@tuffmail.com>2014-04-29 13:49:09 -0400
committerBrian Evans <grknight@tuffmail.com>2014-04-29 13:49:09 -0400
commitc54a922f9287333c7153e927b0605bb2f83a45b8 (patch)
tree064087b79fb218bb63c06df51560683ab978e96c
parentRemove RelWithDebInfo target to respect CFLAGS (diff)
downloadmysql-c54a922f9287333c7153e927b0605bb2f83a45b8.tar.gz
mysql-c54a922f9287333c7153e927b0605bb2f83a45b8.tar.bz2
mysql-c54a922f9287333c7153e927b0605bb2f83a45b8.zip
[mariadb-java-client] Version bump, remove old.
Signed-off-by: Brian Evans <grknight@tuffmail.com>
-rw-r--r--dev-java/mariadb-java-client/Manifest3
-rw-r--r--dev-java/mariadb-java-client/files/maven-build.xml250
-rw-r--r--dev-java/mariadb-java-client/mariadb-java-client-1.1.3.ebuild46
-rw-r--r--dev-java/mariadb-java-client/mariadb-java-client-1.1.7.ebuild (renamed from dev-java/mariadb-java-client/mariadb-java-client-1.1.4.ebuild)2
-rw-r--r--dev-java/mariadb-java-client/mariadb-java-client-9999.ebuild2
5 files changed, 3 insertions, 300 deletions
diff --git a/dev-java/mariadb-java-client/Manifest b/dev-java/mariadb-java-client/Manifest
index e1bc387..ff507d7 100644
--- a/dev-java/mariadb-java-client/Manifest
+++ b/dev-java/mariadb-java-client/Manifest
@@ -1,2 +1 @@
-DIST mariadb-java-client-1.1.3.tar.gz 179751 SHA256 bb9927e3bacaa501e8a0a04ac1a93cccf43c64d4a4742d17b115b54869964076 SHA512 22ed23483b5ab741bfbd82825ce21cb55533c78fa8ea839effda2eca185f283b92a3b551a12761c3e00de6a0722e95c4ebd670462d553b33dbe9925541ae5b97 WHIRLPOOL 0896218d64c5e488322a745a7819c2f9c39d5b5ed677d013abae7270455caea0b4394d013d8ee17b8fb166679f1a3f89af6ff06e2a9d026f525df5088e813ffa
-DIST mariadb-java-client-1.1.4.tar.gz 184565 SHA256 6feec7634572577fed376a19927d05d5abea01aa81615451b259f4fec52d72cd SHA512 4be86df3949845f48741e98a5f1ef17d30229af15966f86e502890f01b05b518bbf0aad8814e50512554cbb318b1048dfa9ff3f5540c41111a60c0059e526236 WHIRLPOOL 4966ae823933d2aefbcb2e86a1302b11b635def426500033e256277fd91a6ade0bfffe995b023a84b4c8fd448c3a78df7c2ea64f8c8e298dfc7f12a16662a42c
+DIST mariadb-java-client-1.1.7.tar.gz 187189 SHA256 5d0901777eabb477d65d9e1e123a8ade921c0dba486d26626c58b817bef05e82 SHA512 68f1cac13c508daedb03bb433a91d57526bd427f44f1fc2604095af1d947271d8328a44e82f64e6d93f474b4d7d9749f01810f2faf0027862554168d3a314aaa WHIRLPOOL 36d4cbb073c08e703df19023f8b85089940cac8775c05fa41262b44948ac289d8c63014ef604b44642a74915406adaf3c3ccbaf4170fca60a58776004126647f
diff --git a/dev-java/mariadb-java-client/files/maven-build.xml b/dev-java/mariadb-java-client/files/maven-build.xml
deleted file mode 100644
index 3251eb1..0000000
--- a/dev-java/mariadb-java-client/files/maven-build.xml
+++ /dev/null
@@ -1,250 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 7/1/13 1:49 PM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="mariadb-java-client-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="mariadb-java-client"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/4.6/junit-4.6.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}"/>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}"/>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- manifest="src/main/resources/META-INF/MANIFEST.MF"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- <mkdir dir="${maven.repo.local}"/>
- <mkdir dir="${maven.repo.local}/junit/junit/4.6"/>
- <get src="https://oss.sonatype.org/content/repositories/snapshots/junit/junit/4.6/junit-4.6.jar"
- dest="${maven.repo.local}/junit/junit/4.6/junit-4.6.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo.maven.apache.org/maven2/junit/junit/4.6/junit-4.6.jar"
- dest="${maven.repo.local}/junit/junit/4.6/junit-4.6.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- </target>
-
-</project>
diff --git a/dev-java/mariadb-java-client/mariadb-java-client-1.1.3.ebuild b/dev-java/mariadb-java-client/mariadb-java-client-1.1.3.ebuild
deleted file mode 100644
index 7ce3bfc..0000000
--- a/dev-java/mariadb-java-client/mariadb-java-client-1.1.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-VCS_INHERIT=""
-MY_PN="client-java"
-
-if [[ "${PV}" == 9999 ]] ; then
- VCS_INHERIT="bzr"
- EBZR_REPO_URI="lp:${PN}"
-else
-SRC_URI="
- http://ftp.osuosl.org/pub/mariadb/${MY_PN}-${PV}/${P}.tar.gz
- http://mirrors.fe.up.pt/pub/mariadb/${MY_PN}-${PV}/${P}.tar.gz
- http://ftp-stud.hs-esslingen.de/pub/Mirrors/mariadb/${MY_PN}-${PV}/${P}.tar.gz
- "
-fi
-
-JAVA_PKG_IUSE="doc"
-
-inherit java-pkg-2 java-ant-2 eutils "${VCS_INHERIT}"
-
-DESCRIPTION="Client Library for Java is used to connect applications to MariaDB/MySQL databases"
-HOMEPAGE="http://mariadb.org/"
-LICENSE="LGPL-2.1"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="${IUSE}"
-
-# Tests require a server running on localhost port 3306
-RESTRICT="test"
-
-RDEPEND="${RDEPEND} >=virtual/jre-1.6"
-DEPEND="${DEPEND} >=virtual/jdk-1.6"
-
-src_prepare() {
- cp "${FILESDIR}/maven-build.xml" build.xml
- java-pkg-2_src_prepare
-}
-
-src_install() {
- java-pkg_dojar target/${PN}.jar
-}
diff --git a/dev-java/mariadb-java-client/mariadb-java-client-1.1.4.ebuild b/dev-java/mariadb-java-client/mariadb-java-client-1.1.7.ebuild
index f6b371f..72b6625 100644
--- a/dev-java/mariadb-java-client/mariadb-java-client-1.1.4.ebuild
+++ b/dev-java/mariadb-java-client/mariadb-java-client-1.1.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
diff --git a/dev-java/mariadb-java-client/mariadb-java-client-9999.ebuild b/dev-java/mariadb-java-client/mariadb-java-client-9999.ebuild
index 46173b3..995c821 100644
--- a/dev-java/mariadb-java-client/mariadb-java-client-9999.ebuild
+++ b/dev-java/mariadb-java-client/mariadb-java-client-9999.ebuild
@@ -37,7 +37,7 @@ RDEPEND="${RDEPEND} >=virtual/jre-1.6"
DEPEND="${DEPEND} >=virtual/jdk-1.6"
src_prepare() {
- cp "${FILESDIR}/maven-build.xml" build.xml
+ cp "${FILESDIR}/maven-build-1.1.4.xml" build.xml
java-pkg-2_src_prepare
}