summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-06-28 14:28:25 -0400
committerBrian Evans <grknight@gentoo.org>2018-06-28 14:28:25 -0400
commit33b99abf2a667e3f9d1ed0b67a718862347ccc21 (patch)
treeb4467bf25c25dd98db80dc155b30806248388617
parentdev-db/mysql-cluster: New 7.4.20 with client-libs FIXME! (diff)
downloadmysql-33b99abf2a667e3f9d1ed0b67a718862347ccc21.tar.gz
mysql-33b99abf2a667e3f9d1ed0b67a718862347ccc21.tar.bz2
mysql-33b99abf2a667e3f9d1ed0b67a718862347ccc21.zip
dev-db/mysql: Revert config change on 5.6.40-r1
Package-Manager: Portage-2.3.41, Repoman-2.3.9 Manifest-Sign-Key: D1F781EFF9F4A3B6
-rw-r--r--dev-db/mysql/mysql-5.6.40-r1.ebuild47
1 files changed, 13 insertions, 34 deletions
diff --git a/dev-db/mysql/mysql-5.6.40-r1.ebuild b/dev-db/mysql/mysql-5.6.40-r1.ebuild
index f91b13d..3851573 100644
--- a/dev-db/mysql/mysql-5.6.40-r1.ebuild
+++ b/dev-db/mysql/mysql-5.6.40-r1.ebuild
@@ -164,16 +164,6 @@ pkg_postinst() {
einfo
fi
fi
-
- # Note about configuration change
- einfo
- elog "This version of mysql reorganizes the configuration from a single my.cnf"
- elog "to several files in /etc/mysql/${PN}.d."
- elog "Please backup any changes you made to /etc/mysql/my.cnf"
- elog "and add them as a new file under /etc/mysql/${PN}.d with a .cnf extension."
- elog "You may have as many files as needed and they are read alphabetically."
- elog "Be sure the options have the appropitate section headers, i.e. [mysqld]."
- einfo
}
src_unpack() {
@@ -381,32 +371,21 @@ src_install() {
# Configuration stuff
einfo "Building default configuration ..."
insinto "${MY_SYSCONFDIR#${EPREFIX}}"
- [[ -f "${S}/scripts/mysqlaccess.conf" ]] && doins "${S}"/scripts/mysqlaccess.conf
- cp "${FILESDIR}/my.cnf-5.7" "${TMPDIR}/my.cnf" || die
- eprefixify "${TMPDIR}/my.cnf"
- doins "${TMPDIR}/my.cnf"
- insinto "${MY_SYSCONFDIR#${EPREFIX}}/mysql.d"
- cp "${FILESDIR}/my.cnf.distro-client" "${TMPDIR}/50-distro-client.cnf" || die
- eprefixify "${TMPDIR}/50-distro-client.cnf"
- doins "${TMPDIR}/50-distro-client.cnf"
+ [[ -f "${S%/}/scripts/mysqlaccess.conf" ]] && doins "${S%/}"/scripts/mysqlaccess.conf
+ local mycnf_src="my.cnf-5.6"
+ sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
+ "${FILESDIR%/}/${mycnf_src}" \
+ > "${TMPDIR%/}/my.cnf.ok" || die
+ use prefix && sed -i -r -e '/^user[[:space:]]*=[[:space:]]*mysql$/d' "${TMPDIR%/}/my.cnf.ok"
+ if use latin1 ; then
+ sed -i \
+ -e "/character-set/s|utf8|latin1|g" \
+ "${TMPDIR%/}/my.cnf.ok" || die
+ fi
+ eprefixify "${TMPDIR%/}/my.cnf.ok"
+ newins "${TMPDIR}/my.cnf.ok" my.cnf
if use server ; then
- mycnf_src="my.cnf.distro-server"
- sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
- "${FILESDIR}/${mycnf_src}" \
- > "${TMPDIR}/my.cnf.ok" || die
- if use prefix ; then
- sed -i -r -e '/^user[[:space:]]*=[[:space:]]*mysql$/d' \
- "${TMPDIR}/my.cnf.ok" || die
- fi
- if use latin1 ; then
- sed -i \
- -e "/character-set/s|utf8|latin1|g" \
- "${TMPDIR}/my.cnf.ok" || die
- fi
- eprefixify "${TMPDIR}/my.cnf.ok"
- newins "${TMPDIR}/my.cnf.ok" 50-distro-server.cnf
-
einfo "Including support files and sample configurations"
docinto "support-files"
local script