summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-06-28 12:11:47 -0400
committerBrian Evans <grknight@gentoo.org>2018-06-28 12:11:47 -0400
commitf9fcab9d2daaedb9623afc335e37028f24d91bcc (patch)
treea092f7a6dcb863ccdf25dea3f7b4804c64c85823
parentdev-db/mysql: Add client-libs for 5.6.40 (diff)
downloadmysql-f9fcab9d2daaedb9623afc335e37028f24d91bcc.tar.gz
mysql-f9fcab9d2daaedb9623afc335e37028f24d91bcc.tar.bz2
mysql-f9fcab9d2daaedb9623afc335e37028f24d91bcc.zip
dev-db/mysql: Fix up warnings and errors
Restore libressl sed on 5.5 Fix whitespace on 5.5 Remove unused option from 5.6 Package-Manager: Portage-2.3.41, Repoman-2.3.9 Manifest-Sign-Key: D1F781EFF9F4A3B6
-rw-r--r--dev-db/mysql/mysql-5.5.60-r1.ebuild13
-rw-r--r--dev-db/mysql/mysql-5.6.40-r1.ebuild1
2 files changed, 12 insertions, 2 deletions
diff --git a/dev-db/mysql/mysql-5.5.60-r1.ebuild b/dev-db/mysql/mysql-5.5.60-r1.ebuild
index 6b499b3..36a1e5f 100644
--- a/dev-db/mysql/mysql-5.5.60-r1.ebuild
+++ b/dev-db/mysql/mysql-5.5.60-r1.ebuild
@@ -10,7 +10,7 @@ SUBSLOT="18"
inherit eutils flag-o-matic prefix toolchain-funcs user cmake-utils multilib-build
SRC_URI="https://cdn.mysql.com/Downloads/MySQL-5.5/${P}.tar.gz
- https://downloads.mysql.com/archives/MySQL-5.5/${P}.tar.gz"
+ https://downloads.mysql.com/archives/MySQL-5.5/${P}.tar.gz"
# Gentoo patches to MySQL
if [[ "${MY_EXTRAS_VER}" != "live" && "${MY_EXTRAS_VER}" != "none" ]]; then
SRC_URI="${SRC_URI}
@@ -189,6 +189,16 @@ src_prepare() {
echo "TARGET_LINK_LIBRARIES(mysqld jemalloc)" >> "${S%/}/sql/CMakeLists.txt" || die
fi
+ # Remove the centos and rhel selinux policies to support mysqld_safe under SELinux
+ if [[ -d "${S}/support-files/SELinux" ]] ; then
+ echo > "${S}/support-files/SELinux/CMakeLists.txt" || die
+ fi
+
+ if use libressl ; then
+ sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
+ "${S}/cmake/ssl.cmake" || die
+ fi
+
local plugin
local server_plugins=( semisync )
local test_plugins=( audit_null daemon_example fulltext )
@@ -206,6 +216,7 @@ src_prepare() {
# Don't build example
_disable_engine example
+ _disable_engine ndb
cmake-utils_src_prepare
}
diff --git a/dev-db/mysql/mysql-5.6.40-r1.ebuild b/dev-db/mysql/mysql-5.6.40-r1.ebuild
index b26f7d2..f91b13d 100644
--- a/dev-db/mysql/mysql-5.6.40-r1.ebuild
+++ b/dev-db/mysql/mysql-5.6.40-r1.ebuild
@@ -326,7 +326,6 @@ src_configure(){
# Storage engines
mycmakeargs+=(
- -DWITH_EXAMPLE_STORAGE_ENGINE=0
-DWITH_ARCHIVE_STORAGE_ENGINE=1
-DWITH_BLACKHOLE_STORAGE_ENGINE=1
-DWITH_CSV_STORAGE_ENGINE=1