summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/tacix/Manifest2
-rw-r--r--net-misc/tacix/tacix-0.1.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/tacix/Manifest b/net-misc/tacix/Manifest
new file mode 100644
index 0000000..9aa7a6c
--- /dev/null
+++ b/net-misc/tacix/Manifest
@@ -0,0 +1,2 @@
+DIST tacix-0.1.0.tar.gz 112714 RMD160 4f7f37bf1fbecc9c11b18fc0606c78e9fcf5bee2 SHA1 831d4f53f522fffbdb58991b3ecbfdac36d75b15 SHA256 888d6625f5f74bb6cf3d3dd55b9049b2c19727b5da58a78343a39b3eb7a606f5
+EBUILD tacix-0.1.0.ebuild 1480 RMD160 845f7d183069c249ec13d83564d4b2b562343656 SHA1 fe2746a4494c84234f3c71ded2cc9d213a3828b5 SHA256 386bc8639dfedc1191f1a7f3717a6acfb563896a3aed2403fbb9592337068364
diff --git a/net-misc/tacix/tacix-0.1.0.ebuild b/net-misc/tacix/tacix-0.1.0.ebuild
new file mode 100644
index 0000000..98fec8b
--- /dev/null
+++ b/net-misc/tacix/tacix-0.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+#TODO: need gentoo init script
+
+EAPI=2
+
+inherit distutils
+
+DESCRIPTION="Remote Desktop Server"
+HOMEPAGE="https://launchpad.net/tacix"
+SRC_URI="http://launchpad.net/${PN}/0.1/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-misc/nx
+ sys-apps/dbus
+ sys-auth/consolekit"
+
+export NX_HOME_DIR=/var/lib/nxserver/home
+
+pkg_setup () {
+ enewuser nx -1 -1 ${NX_HOME_DIR}
+}
+
+src_install() {
+ distutils_src_install
+
+ # For logs
+ keepdir ${NX_HOME_DIR}/.nx
+ fowners nx ${NX_HOME_DIR}/.nx
+}
+
+pkg_postinst () {
+ distutils_pkg_postinst
+ # Other NX servers ebuilds may have already created the nx account
+ # However they use different login shell/home directory paths
+ if [[ ${ROOT} == "/" ]]; then
+ usermod -s /usr/lib/tacix/tacix-freenx-server nx || die "Unable to set login shell of nx user!!"
+ usermod -d ${NX_HOME_DIR} nx || die "Unable to set home directory of nx user!!"
+ else
+ elog "If you had another NX server installed before, please make sure"
+ elog "the nx user account is correctly set to:"
+ elog " * login shell: /usr/lib/tacix/tacix-freenx-server"
+ elog " * home directory: ${NX_HOME_DIR}"
+ fi
+
+ if ! built_with_use net-misc/openssh pam; then
+ elog ""
+ elog "net-misc/openssh was not built with PAM support"
+ elog "You will need to unlock the nx account by setting a password for it"
+ fi
+}