summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/neatx/Manifest2
-rw-r--r--net-misc/neatx/neatx-0.3.1_p42.ebuild (renamed from net-misc/neatx/neatx-0.3.1_p41.ebuild)7
2 files changed, 5 insertions, 4 deletions
diff --git a/net-misc/neatx/Manifest b/net-misc/neatx/Manifest
index 83edfc7..fbcc201 100644
--- a/net-misc/neatx/Manifest
+++ b/net-misc/neatx/Manifest
@@ -1 +1 @@
-EBUILD neatx-0.3.1_p41.ebuild 2823 RMD160 f61daae57ff89a44a658693c48a0cf24dbc0a5e3 SHA1 7b8eecdcc19a414c56dc56e65efae0b5927411eb SHA256 49b6e138d9f2d76bd841f65b0ced38ea803ea7de61fcd26ba34cea2e3fe138a7
+EBUILD neatx-0.3.1_p42.ebuild 2870 RMD160 64e1d29d81304292dc6132815a49b364a0f6a5a5 SHA1 5b24dca825a37b6dc7dc4a44321141258a352a88 SHA256 2c44ecd9aba8b5224abb03d0ad96fb5c2f200abc1e2b7cee72ed96e67a9943f4
diff --git a/net-misc/neatx/neatx-0.3.1_p41.ebuild b/net-misc/neatx/neatx-0.3.1_p42.ebuild
index e8c6a01..86f33af 100644
--- a/net-misc/neatx/neatx-0.3.1_p41.ebuild
+++ b/net-misc/neatx/neatx-0.3.1_p42.ebuild
@@ -6,7 +6,8 @@ EAPI="2"
inherit eutils autotools distutils subversion
-ESVN_REPO_URI="http://neatx.googlecode.com/svn/trunk/neatx@41"
+REV="${PV/[0-9.]*\_p}"
+ESVN_REPO_URI="http://neatx.googlecode.com/svn/trunk/neatx@${REV}"
DESCRIPTION="Google implementation of NX server"
HOMEPAGE="http://code.google.com/p/neatx/"
@@ -83,12 +84,12 @@ pkg_postinst () {
# Other NX servers ebuilds may have already created the nx account
# However they use different login shell/home directory paths
if [[ ${ROOT} == "/" ]]; then
- usermod -s /usr/lib/neatx/nxserver-login nx || die "Unable to set login shell of nx user!!"
+ usermod -s /usr/$(get_libdir)/neatx/nxserver-login nx || die "Unable to set login shell of nx user!!"
usermod -d ${NX_HOME_DIR} nx || die "Unable to set home directory of nx user!!"
else
elog "If you had another NX server installed before, please make sure"
elog "the nx user account is correctly set to:"
- elog " * login shell: /usr/lib/neatx/nxserver-login"
+ elog " * login shell: /usr/$(get_libdir)/neatx/nxserver-login"
elog " * home directory: ${NX_HOME_DIR}"
fi