aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--system-auth.in3
2 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 671f64f..2d5e197 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,10 @@ ifeq "$(CRACKLIB)" "yes"
PAMFLAGS += -DHAVE_CRACKLIB=1
endif
+ifeq "$(PASSWDQC)" "yes"
+PAMFLAGS += -DHAVE_PASSWDQC
+endif
+
ifeq "$(CONSOLEKIT)" "yes"
PAMFLAGS += -DHAVE_CONSOLEKIT
endif
diff --git a/system-auth.in b/system-auth.in
index 297e681..b5b84f3 100644
--- a/system-auth.in
+++ b/system-auth.in
@@ -9,6 +9,9 @@ account required pam_unix.so DEBUG
#if HAVE_CRACKLIB
password required pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 try_first_pass retry=3 DEBUG
#endif
+#if HAVE_PASSWDQC
+password required pam_passwdqc.so min=8,8,8,8,8 retry=3
+#endif
password sufficient pam_unix.so try_first_pass AUTHTOK nullok UNIX_EXTENDED_ENCRYPTION DEBUG
password required pam_deny.so