aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2015-02-13 09:35:21 -0800
committerBrian Dolbec <dolsen@gentoo.org>2015-02-13 09:35:21 -0800
commit06a4e7a09211c4a598a72a97c64daff13cd502ff (patch)
treed4cf2e1156792e76658fe159703e8c886471f256
parentRELEASE-NOTES: Fix transposed bug number (diff)
downloadportage-06a4e7a09211c4a598a72a97c64daff13cd502ff.tar.gz
portage-06a4e7a09211c4a598a72a97c64daff13cd502ff.tar.bz2
portage-06a4e7a09211c4a598a72a97c64daff13cd502ff.zip
setup.py: Revert the select_plugins() changes
Install everything, leave it all as automagic.
-rwxr-xr-xsetup.py43
1 files changed, 1 insertions, 42 deletions
diff --git a/setup.py b/setup.py
index 953023dab..864580b86 100755
--- a/setup.py
+++ b/setup.py
@@ -609,46 +609,6 @@ def get_manpages():
for g, mans in groups.items():
yield [os.path.join('$mandir', topdir, 'man%s' % g), mans]
-# initialize the list here
-# it can then be modified by the select_plugins()
-PACKAGES = list(find_packages())
-
-# the USE flag selectable list of modules
-SELECTABLE = {
- 'cvs': 'cvs',
- 'git': 'git',
- 'subversion': 'svn',
- }
-
-# get the USE from the environment
-# split them so we don't get substring matches
-USE = os.environ.get("USE", "").split()
-
-
-class select_plugins(Command):
- """ Removes the plugin modules not selected from the packages list
- so they won't be installed."""
-
- user_options = [
- ]
-
- global PACKAGES
-
- def initialize_options(self):
- self.build_base = None
-
- def finalize_options(self):
- self.set_undefined_options('build',
- ('build_base', 'build_base'))
-
- def run(self):
- for plugin in sorted(SELECTABLE):
- if plugin not in USE:
- module = os.path.join('portage', 'sync', 'modules',
- SELECTABLE[plugin])
- PACKAGES.remove(module)
- remove_tree(os.path.join('pym', module))
-
setup(
name = 'portage',
@@ -658,7 +618,7 @@ setup(
author_email = 'dev-portage@gentoo.org',
package_dir = {'': 'pym'},
- packages = PACKAGES,
+ packages = list(find_packages()),
# something to cheat build & install commands
scripts = list(find_scripts()),
@@ -694,7 +654,6 @@ setup(
'install_scripts_portagebin': x_install_scripts_portagebin,
'install_scripts_sbin': x_install_scripts_sbin,
'sdist': x_sdist,
- 'select_plugins': select_plugins,
'test': test,
},