aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-10-15 01:22:57 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-10-15 17:02:36 +0200
commita934cafcf928b9e8cf2aaf749dca68fa6fa689d7 (patch)
tree25c8d36cbcbff88eedfff9d7fef9169fb77c8779
parentChildWatcherTestCase: python3.8 compat (diff)
downloadportage-a934cafcf928b9e8cf2aaf749dca68fa6fa689d7.tar.gz
portage-a934cafcf928b9e8cf2aaf749dca68fa6fa689d7.tar.bz2
portage-a934cafcf928b9e8cf2aaf749dca68fa6fa689d7.zip
Add python-3.8, drop python-3.4 from testing
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
-rw-r--r--.travis.yml15
-rwxr-xr-xrepoman/runtests6
-rwxr-xr-xruntests6
-rw-r--r--tox.ini9
4 files changed, 15 insertions, 21 deletions
diff --git a/.travis.yml b/.travis.yml
index ab0b8d304..b1b4bf26b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,18 +1,12 @@
language: python
python:
- 2.7
- - 3.4
- 3.5
- 3.6
+ - 3.7
+ - 3.8-dev
- pypy
-# See https://github.com/travis-ci/travis-ci/issues/9815
-matrix:
- include:
- - python: 3.7
- dist: xenial
- sudo: required
-
# command to install dependencies
install:
- pip install tox
@@ -21,8 +15,9 @@ script:
- printf "[build_ext]\nportage-ext-modules=true" >> setup.cfg
- ./setup.py test
- ./setup.py install --root=/tmp/install-root
- - if [[ ${TRAVIS_PYTHON_VERSION} == ?.? ]]; then
- tox -e py${TRAVIS_PYTHON_VERSION/./};
+ - if [[ ${TRAVIS_PYTHON_VERSION/-dev/} == ?.? ]]; then
+ TOX_PYTHON_VERSION=${TRAVIS_PYTHON_VERSION/-dev/};
+ tox -e py${TOX_PYTHON_VERSION/./};
else
tox -e ${TRAVIS_PYTHON_VERSION};
fi
diff --git a/repoman/runtests b/repoman/runtests
index e208ab61d..1ef52f482 100755
--- a/repoman/runtests
+++ b/repoman/runtests
@@ -24,14 +24,14 @@ import tempfile
# These are the versions we fully support and require to pass tests.
PYTHON_SUPPORTED_VERSIONS = [
'2.7',
- '3.4',
'3.5',
- '3.6'
+ '3.6',
+ '3.7'
]
# The rest are just "nice to have".
PYTHON_NICE_VERSIONS = [
'pypy',
- '3.7'
+ '3.8'
]
EPREFIX = os.environ.get('PORTAGE_OVERRIDE_EPREFIX', '/')
diff --git a/runtests b/runtests
index 7c3ebb1ca..50d7b8251 100755
--- a/runtests
+++ b/runtests
@@ -24,14 +24,14 @@ import tempfile
# These are the versions we fully support and require to pass tests.
PYTHON_SUPPORTED_VERSIONS = [
'2.7',
- '3.4',
'3.5',
- '3.6'
+ '3.6',
+ '3.7'
]
# The rest are just "nice to have".
PYTHON_NICE_VERSIONS = [
'pypy',
- '3.7'
+ '3.8'
]
EPREFIX = os.environ.get('PORTAGE_OVERRIDE_EPREFIX', '/')
diff --git a/tox.ini b/tox.ini
index f49bd413f..378ff01e3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,15 +1,14 @@
[tox]
-envlist = py27,py34,py35,py36,py37,pypy,pypy3
+envlist = py27,py35,py36,py37,py38,pypy,pypy3
skipsdist = True
[testenv]
deps =
pygost
pyyaml
- py34: lxml!=4.2.0,<4.4.0
- py27,py35,py36,py37,pypy,pypy3: lxml!=4.2.0
- py27,py34,py35,pypy: pyblake2
- py27,py34,py35,pypy: pysha3
+ py27,py35,py36,py37,py38,pypy,pypy3: lxml!=4.2.0
+ py27,py35,pypy: pyblake2
+ py27,py35,pypy: pysha3
setenv =
PYTHONPATH={toxinidir}/lib
commands =