aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-01 07:58:29 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-01 10:37:56 +0200
commitc852f0aed0d86178a5ebb3f30e50692f2657dcee (patch)
tree9ed4e5cd411d207f9a65683ae7820c98bad0a65b /tox.ini
parentReplace implicit {FEATURES->USE}=test forcing with USE default (diff)
downloadportage-c852f0aed0d86178a5ebb3f30e50692f2657dcee.tar.gz
portage-c852f0aed0d86178a5ebb3f30e50692f2657dcee.tar.bz2
portage-c852f0aed0d86178a5ebb3f30e50692f2657dcee.zip
Add a tox.ini to support running tests via tox
tox is the common Pythonic tool for running tests against multiple interpreters. It integrates well with virtualenv, making testing trivial on practically any system. Add a tox.ini file so users can take advantage of it. Reviewed-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini16
1 files changed, 16 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 000000000..cafdb0045
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,16 @@
+[tox]
+envlist = py27,py34,py35,py36,pypy,pypy3
+skipsdist = True
+
+[testenv]
+deps =
+ lxml!=4.2.0
+ pygost
+ pyyaml
+ py27,py34,py35,pypy: pyblake2
+ py27,py34,py35,pypy: pysha3
+setenv =
+ PYTHONPATH={toxinidir}/lib
+commands =
+ python -b -Wd setup.py test
+ python -b -Wd repoman/setup.py test