aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraurel32 <aurel32@c046a42c-6fe2-441c-8c8c-71466251a162>2008-11-11 13:41:01 +0000
committeraurel32 <aurel32@c046a42c-6fe2-441c-8c8c-71466251a162>2008-11-11 13:41:01 +0000
commitde9a95f0223733a524e4955f1b4bdb938f79255b (patch)
tree5f751c5c4a2e53849a141fba7f437f2e686cc383
parenttarget-alpha: disable single stepping and TB flush by default (diff)
downloadqemu-kvm-de9a95f0223733a524e4955f1b4bdb938f79255b.tar.gz
qemu-kvm-de9a95f0223733a524e4955f1b4bdb938f79255b.tar.bz2
qemu-kvm-de9a95f0223733a524e4955f1b4bdb938f79255b.zip
Revert commits 5685 to 5688 committed by mistake
Signed-off-by: Aurelien Jarno <aurelien@aurel32.net> git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@5691 c046a42c-6fe2-441c-8c8c-71466251a162
-rw-r--r--Makefile.target4
-rw-r--r--exec-all.h2
-rw-r--r--hw/alpha_palcode.c2
-rw-r--r--net.c3
-rw-r--r--target-mips/translate.c4
-rw-r--r--vl.c2
6 files changed, 7 insertions, 10 deletions
diff --git a/Makefile.target b/Makefile.target
index 3019f44f7..031ab456e 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -1,9 +1,5 @@
include config.mak
-ifndef CONFIG_DYNGEN_OP
-CC=$(HOST_CC)
-endif
-
TARGET_BASE_ARCH:=$(TARGET_ARCH)
ifeq ($(TARGET_ARCH), x86_64)
TARGET_BASE_ARCH:=i386
diff --git a/exec-all.h b/exec-all.h
index 95c10cd17..e3da98a7f 100644
--- a/exec-all.h
+++ b/exec-all.h
@@ -21,7 +21,7 @@
#ifndef _EXEC_ALL_H_
#define _EXEC_ALL_H_
/* allow to see translation results - the slowdown should be negligible, so we leave it */
-//#define DEBUG_DISAS
+#define DEBUG_DISAS
/* is_jmp field values */
#define DISAS_NEXT 0 /* next instruction can be analyzed */
diff --git a/hw/alpha_palcode.c b/hw/alpha_palcode.c
index 351bb4879..38466dbd8 100644
--- a/hw/alpha_palcode.c
+++ b/hw/alpha_palcode.c
@@ -1059,7 +1059,7 @@ void pal_init (CPUState *env)
void call_pal (CPUState *env, int palcode)
{
- target_long ret;
+ target_ulong ret;
if (logfile != NULL)
fprintf(logfile, "%s: palcode %02x\n", __func__, palcode);
diff --git a/net.c b/net.c
index bb9ea6e7c..35aeb1ece 100644
--- a/net.c
+++ b/net.c
@@ -622,8 +622,6 @@ static void tap_send(void *opaque)
/* fd support */
-void enable_sigio_timer(int fd);
-
static TAPState *net_tap_fd_init(VLANState *vlan, int fd)
{
TAPState *s;
@@ -632,7 +630,6 @@ static TAPState *net_tap_fd_init(VLANState *vlan, int fd)
if (!s)
return NULL;
s->fd = fd;
- enable_sigio_timer(fd);
s->vc = qemu_new_vlan_client(vlan, tap_receive, NULL, s);
qemu_set_fd_handler(s->fd, tap_send, NULL, s);
snprintf(s->vc->info_str, sizeof(s->vc->info_str), "tap: fd=%d", fd);
diff --git a/target-mips/translate.c b/target-mips/translate.c
index 03f3fbb82..386e0e37d 100644
--- a/target-mips/translate.c
+++ b/target-mips/translate.c
@@ -3609,6 +3609,8 @@ static void gen_mtc0 (CPUState *env, DisasContext *ctx, TCGv t0, int reg, int se
default:
goto die;
}
+ /* Stop translation as we may have switched the execution mode */
+ ctx->bstate = BS_STOP;
break;
case 12:
switch (sel) {
@@ -4791,6 +4793,8 @@ static void gen_dmtc0 (CPUState *env, DisasContext *ctx, TCGv t0, int reg, int s
default:
goto die;
}
+ /* Stop translation as we may have switched the execution mode */
+ ctx->bstate = BS_STOP;
break;
case 12:
switch (sel) {
diff --git a/vl.c b/vl.c
index 24c9c32c1..7bcffd334 100644
--- a/vl.c
+++ b/vl.c
@@ -1403,7 +1403,7 @@ static int fcntl_setfl(int fd, int flag)
#define RTC_FREQ 1024
-void enable_sigio_timer(int fd)
+static void enable_sigio_timer(int fd)
{
struct sigaction act;