aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-04-01 01:02:00 +0300
committerJimi Huotari <chiitoo@gentoo.org>2022-04-01 01:19:51 +0300
commit093e2b0924f8818951a27eeabbbd81e0b7174092 (patch)
treee0ceb6fb3f8fbb17b385bd93bfcdf5e4b4bf40e6
parent*.eclass: @ECLASS-VARIABLE renamed to @ECLASS_VARIABLE (diff)
downloadqt-093e2b09.tar.gz
qt-093e2b09.tar.bz2
qt-093e2b09.zip
dev-qt/qtwebsockets: add version 6.3.9999
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--dev-qt/qtwebsockets/qtwebsockets-6.3.9999.ebuild18
-rw-r--r--profiles/package.mask1
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-qt/qtwebsockets/qtwebsockets-6.3.9999.ebuild b/dev-qt/qtwebsockets/qtwebsockets-6.3.9999.ebuild
new file mode 100644
index 00000000..ae1b5fa1
--- /dev/null
+++ b/dev-qt/qtwebsockets/qtwebsockets-6.3.9999.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Implementation of the WebSocket protocol for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*
+ =dev-qt/qtdeclarative-${PV}*
+"
+RDEPEND="${DEPEND}"
diff --git a/profiles/package.mask b/profiles/package.mask
index a0174991..1bd07eaf 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -16,3 +16,4 @@
=dev-qt/qttools-6*
=dev-qt/qtwebchannel-6*
=dev-qt/qtwebengine-6*
+=dev-qt/qtwebsockets-6*