aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-10-31 21:20:50 +0200
committerJimi Huotari <chiitoo@gentoo.org>2018-10-31 21:24:05 +0200
commit141357aad041fd74e847dbd07af29b09159022b1 (patch)
tree81c228a9edac1daf7db6102c63c73e1ec2860464
parentdev-qt: Drop Qt 5.11.2 (diff)
downloadqt-141357aa.tar.gz
qt-141357aa.tar.bz2
qt-141357aa.zip
dev-qt/qtwebengine: sync with the main Gentoo repo tree
- Add patch for GCC-8 (https://bugs.gentoo.org/657124). - Remove 'net-libs/libsrtp' DEPEND (https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=02c290ff). Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.9.6-gcc8.patch24
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.11.9999.ebuild4
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild3
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.9.9999.ebuild4
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.9999.ebuild3
5 files changed, 32 insertions, 6 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.9.6-gcc8.patch b/dev-qt/qtwebengine/files/qtwebengine-5.9.6-gcc8.patch
new file mode 100644
index 00000000..ba6a49fd
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.9.6-gcc8.patch
@@ -0,0 +1,24 @@
+From: Fedora
+Subject: Fix build for 32-bit platforms
+
+Apparently not upstream, can't find this anywhere. So I assume Fedora is the actual source?
+https://src.fedoraproject.org/cgit/rpms/chromium.git/tree/chromium-66.0.3359.170-gcc8-alignof.patch
+
+diff -up chromium-66.0.3359.170/src/3rdparty/chromium/mojo/public/c/system/macros.h.gcc8-alignof chromium-66.0.3359.170/src/3rdparty/chromium/mojo/public/c/system/macros.h
+--- a/src/3rdparty/chromium/mojo/public/c/system/macros.h 2018-05-15 14:58:46.448912634 -0400
++++ b/src/3rdparty/chromium/mojo/public/c/system/macros.h 2018-05-15 14:58:52.041784613 -0400
+@@ -18,7 +18,13 @@
+ #endif
+
+ // Like the C++11 |alignof| operator.
+-#if __cplusplus >= 201103L
++#if defined(__GNUC__) && __GNUC__ >= 8
++// GCC 8 has changed the alignof operator to return the minimal alignment
++// required by the target ABI, instead of the preferred alignment.
++// This means that on 32-bit x86, it will return 4 instead of 8.
++// Use __alignof__ instead to avoid this.
++#define MOJO_ALIGNOF(type) __alignof__(type)
++#elif __cplusplus >= 201103L
+ #define MOJO_ALIGNOF(type) alignof(type)
+ #elif defined(__GNUC__)
+ #define MOJO_ALIGNOF(type) __alignof__(type)
diff --git a/dev-qt/qtwebengine/qtwebengine-5.11.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.11.9999.ebuild
index c3ed341b..57fa9ada 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.11.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.11.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,7 +40,6 @@ RDEPEND="
media-libs/libwebp:=
media-libs/mesa[egl]
media-libs/opus
- net-libs/libsrtp:0=
sys-apps/dbus
sys-apps/pciutils
sys-libs/libcap
@@ -80,6 +79,7 @@ DEPEND="${RDEPEND}
"
PATCHES+=(
+ "${FILESDIR}/${PN}-5.9.6-gcc8.patch" # bug 657124
"${FILESDIR}/${PN}-5.11.1-nouveau-disable-gpu.patch" # bug 609752
)
diff --git a/dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild
index 4a62001c..2a34a526 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild
@@ -40,7 +40,6 @@ RDEPEND="
media-libs/libwebp:=
media-libs/mesa[egl]
media-libs/opus
- net-libs/libsrtp:0=
sys-apps/dbus
sys-apps/pciutils
sys-libs/libcap
@@ -79,6 +78,8 @@ DEPEND="${RDEPEND}
pax_kernel? ( sys-apps/elfix )
"
+PATCHES+=( "${FILESDIR}/${PN}-5.9.6-gcc8.patch" ) # bug 657124
+
src_prepare() {
use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.3-paxmark-mksnapshot.patch" )
diff --git a/dev-qt/qtwebengine/qtwebengine-5.9.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.9.9999.ebuild
index 65a2d764..2b521acd 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.9.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.9.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -38,7 +38,6 @@ RDEPEND="
media-libs/libwebp:=
media-libs/mesa[egl]
media-libs/opus
- net-libs/libsrtp:0=
sys-apps/dbus
sys-apps/pciutils
sys-libs/libcap
@@ -81,6 +80,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-5.9.4-jpeg-9-1.patch"
"${FILESDIR}/${PN}-5.9.4-jpeg-9-2.patch"
+ "${FILESDIR}/${PN}-5.9.6-gcc8.patch" # bug 657124
)
src_prepare() {
diff --git a/dev-qt/qtwebengine/qtwebengine-5.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.9999.ebuild
index 4a62001c..2a34a526 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.9999.ebuild
@@ -40,7 +40,6 @@ RDEPEND="
media-libs/libwebp:=
media-libs/mesa[egl]
media-libs/opus
- net-libs/libsrtp:0=
sys-apps/dbus
sys-apps/pciutils
sys-libs/libcap
@@ -79,6 +78,8 @@ DEPEND="${RDEPEND}
pax_kernel? ( sys-apps/elfix )
"
+PATCHES+=( "${FILESDIR}/${PN}-5.9.6-gcc8.patch" ) # bug 657124
+
src_prepare() {
use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.3-paxmark-mksnapshot.patch" )