aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-06-01 02:28:54 +1000
committerMichael Palimaka <kensington@gentoo.org>2015-06-01 02:28:54 +1000
commit4b376d4e6d5163cc9d0c9f8f4fd9c3490a210d8f (patch)
tree249bc5e209d95115d58c152031c44be4fb0099c2
parent[qt4-build-multilib.eclass] Sync. (diff)
downloadqt-4b376d4e6d5163cc9d0c9f8f4fd9c3490a210d8f.tar.gz
qt-4b376d4e6d5163cc9d0c9f8f4fd9c3490a210d8f.tar.bz2
qt-4b376d4e6d5163cc9d0c9f8f4fd9c3490a210d8f.zip
[dev-qt/qtwebkit] Remove insecure RPATH wrt bug #466216.
Package-Manager: portage-2.2.20
-rw-r--r--dev-qt/qtwebkit/files/qtwebkit-5.4.1-rpath.patch13
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.4.9999.ebuild5
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.5.9999.ebuild5
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.9999.ebuild5
4 files changed, 25 insertions, 3 deletions
diff --git a/dev-qt/qtwebkit/files/qtwebkit-5.4.1-rpath.patch b/dev-qt/qtwebkit/files/qtwebkit-5.4.1-rpath.patch
new file mode 100644
index 00000000..ffe44d2a
--- /dev/null
+++ b/dev-qt/qtwebkit/files/qtwebkit-5.4.1-rpath.patch
@@ -0,0 +1,13 @@
+Avoid insecure RPATH wrt bug #466216.
+
+--- Tools/qmake/mkspecs/features/unix/default_post.prf
++++ Tools/qmake/mkspecs/features/unix/default_post.prf
+@@ -60,8 +60,6 @@
+ }
+ }
+
+-contains(TEMPLATE, app): CONFIG += rpath
+-
+ CONFIG(debug, debug|release)|force_debug_info|separate_debug_info {
+ # Make ld not cache the symbol tables of input files in memory to avoid memory exhaustion during the linking phase.
+ !force_static_libs_as_shared:config_gnuld: QMAKE_LFLAGS += -Wl,--no-keep-memory
diff --git a/dev-qt/qtwebkit/qtwebkit-5.4.9999.ebuild b/dev-qt/qtwebkit/qtwebkit-5.4.9999.ebuild
index 08750fbe..7812f80b 100644
--- a/dev-qt/qtwebkit/qtwebkit-5.4.9999.ebuild
+++ b/dev-qt/qtwebkit/qtwebkit-5.4.9999.ebuild
@@ -62,7 +62,10 @@ DEPEND="${RDEPEND}
virtual/rubygems
"
-PATCHES=( "${FILESDIR}/${PN}-5.4.1-leveldb.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-5.4.1-leveldb.patch"
+ "${FILESDIR}/${PN}-5.4.1-rpath.patch"
+)
src_prepare() {
# ensure bundled library cannot be used
diff --git a/dev-qt/qtwebkit/qtwebkit-5.5.9999.ebuild b/dev-qt/qtwebkit/qtwebkit-5.5.9999.ebuild
index 88a57677..c9a2b5df 100644
--- a/dev-qt/qtwebkit/qtwebkit-5.5.9999.ebuild
+++ b/dev-qt/qtwebkit/qtwebkit-5.5.9999.ebuild
@@ -62,7 +62,10 @@ DEPEND="${RDEPEND}
virtual/rubygems
"
-PATCHES=( "${FILESDIR}/${PN}-5.4.1-leveldb.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-5.4.1-leveldb.patch"
+ "${FILESDIR}/${PN}-5.4.1-rpath.patch"
+)
src_prepare() {
# ensure bundled library cannot be used
diff --git a/dev-qt/qtwebkit/qtwebkit-5.9999.ebuild b/dev-qt/qtwebkit/qtwebkit-5.9999.ebuild
index 88a57677..c9a2b5df 100644
--- a/dev-qt/qtwebkit/qtwebkit-5.9999.ebuild
+++ b/dev-qt/qtwebkit/qtwebkit-5.9999.ebuild
@@ -62,7 +62,10 @@ DEPEND="${RDEPEND}
virtual/rubygems
"
-PATCHES=( "${FILESDIR}/${PN}-5.4.1-leveldb.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-5.4.1-leveldb.patch"
+ "${FILESDIR}/${PN}-5.4.1-rpath.patch"
+)
src_prepare() {
# ensure bundled library cannot be used